AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi Kurioses Verhalten bei .loadfromfile

Kurioses Verhalten bei .loadfromfile

Ein Thema von toyoman · begonnen am 21. Mai 2008 · letzter Beitrag vom 22. Mai 2008
Antwort Antwort
toyoman

Registriert seit: 2. Jun 2003
323 Beiträge
 
Delphi 2010 Enterprise
 
#1

Kurioses Verhalten bei .loadfromfile

  Alt 21. Mai 2008, 15:00
Datenbank: Interbase • Zugriff über: DBX SQL Connection und Query
habe in vielen meiner Source-Codes folgende Befehle verwendet:

queryname.sql.loadfromfile(pfad+dateiname); Nun haben wir auf Delphi 2007 RAD Studio Prof gewechselt (vorher Delphi 7 Ent). Wenn ich diese Sourcecodes verwende erscheinen kryptische Fehlermeldungen: z.b. Token unknown oder der Value des eingelesenen Parameters vom File sind Fragezeichen oder Hyroglyphen.

Wenn ich das ganze aber über den Umweg "Stringlist" mache funktionierts dann wieder. Also das wäre dann so:

Delphi-Quellcode:
var str:TSTringList;

begin

   str:=TStringList.Create;
   str.loadfromfile(pfad+dateiname);$

   ...

   str.free

end;
Hat jemand eine Ahnung woher das kommen kann? Die Methode loadfromfile müsste doch direkt ausgeführt werden können wie früher in Delphi 7 oder? Was spricht dagegen?
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
16.863 Beiträge
 
Delphi 10.4 Sydney
 
#2

Re: Kurioses Verhalten bei .loadfromfile

  Alt 21. Mai 2008, 15:12
Alle Updates installiert?

AFAIK ist das SQL-Property in RAD2007 eine Widestrings-Klasse und die Implementierung dort kann keine Ansi-Dateien mehr korrekt laden.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
toyoman

Registriert seit: 2. Jun 2003
323 Beiträge
 
Delphi 2010 Enterprise
 
#3

Re: Kurioses Verhalten bei .loadfromfile

  Alt 21. Mai 2008, 15:18
was heisst AFAIK?

ich habe die damals verfügbaren Update Packs installiert (Dezember 2007).
wo seh ich den aktuellen Patchstand von Delphi 2007 und was hast du für einen Patch Level?

Zitat von Bernhard Geyer:
Alle Updates installiert?

AFAIK ist das SQL-Property in RAD2007 eine Widestrings-Klasse und die Implementierung dort kann keine Ansi-Dateien mehr korrekt laden.
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
16.863 Beiträge
 
Delphi 10.4 Sydney
 
#4

Re: Kurioses Verhalten bei .loadfromfile

  Alt 21. Mai 2008, 15:24
Zitat von toyoman:
was heisst AFAIK?
AFAIK
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
toyoman

Registriert seit: 2. Jun 2003
323 Beiträge
 
Delphi 2010 Enterprise
 
#5

Re: Kurioses Verhalten bei .loadfromfile

  Alt 21. Mai 2008, 15:47
habe die Version R2 11.0.2804.9245
bin ich da veraltet?

Zitat von Bernhard Geyer:
Zitat von toyoman:
was heisst AFAIK?
AFAIK
  Mit Zitat antworten Zitat
Benutzerbild von RavenIV
RavenIV

Registriert seit: 12. Jan 2005
Ort: Waldshut-Tiengen
2.875 Beiträge
 
Delphi 2007 Enterprise
 
#6

Re: Kurioses Verhalten bei .loadfromfile

  Alt 22. Mai 2008, 09:23
Zitat von toyoman:
habe in vielen meiner Source-Codes folgende Befehle verwendet:

queryname.sql.loadfromfile(pfad+dateiname);
Also bei mir klappt das.
Ich verwende aber die IBObjects.

Vielleicht liegt es an den verwendeten Komponenten?
Sind die Delphi2007-tauglich?
Klaus E.
Linux - das längste Text-Adventure aller Zeiten...
Wer nie Linux mit dem vi konfiguriert hat, der hat am Leben vorbei geklickt.
  Mit Zitat antworten Zitat
HiWieGehts

Registriert seit: 19. Aug 2005
101 Beiträge
 
Delphi 10 Seattle Professional
 
#7

Re: Kurioses Verhalten bei .loadfromfile

  Alt 22. Mai 2008, 18:01
Zitat von Bernhard Geyer:
Alle Updates installiert?

AFAIK ist das SQL-Property in RAD2007 eine Widestrings-Klasse und die Implementierung dort kann keine Ansi-Dateien mehr korrekt laden.
Schreibe den SQL-String mit SaveToFile in eine Neue Datei nachdem du in über die Stringlist geladen hast und vergleiche dann die alte und neue Datei (ev. Hexeditor). Dann ist zumindest klar, ob sich das Format des Strings geändert hat.

LG
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 22:04 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf