AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

FindComponent(...) geht nicht ?

Ein Thema von cetinbiryoldayim · begonnen am 8. Jun 2008 · letzter Beitrag vom 8. Jun 2008
Antwort Antwort
cetinbiryoldayim

Registriert seit: 6. Mai 2008
33 Beiträge
 
#1

FindComponent(...) geht nicht ?

  Alt 8. Jun 2008, 20:32
Servus leute,
hätte eine kurze frage... google spuckt nichts hilfreiches

wieso geht das nicht?
FindComponent('MaskBalkenPuffer'+IntToStr(i)+'.Can vas')

fehler: Inkompatible Typen TCanvas und TComponent
  Mit Zitat antworten Zitat
Benutzerbild von CK_CK
CK_CK

Registriert seit: 30. Aug 2005
Ort: Dortmund, Germany
388 Beiträge
 
Delphi 2006 Enterprise
 
#2

Re: FindComponent(...) geht nicht ?

  Alt 8. Jun 2008, 20:34
Du must casten, um auf den Canvas zuzugreifen:
TImage(FindComponent('MaskBalkenPuffer'+IntToStr(i))).Canvas Das "TImage" musst du natürlich anpassen

Chris

Edit: Du müsstest schon etwas mehr code zeigen, damit man genau sehen kann, wo der Fehler ist...
Chris
» «
Mehr von mir (Programme, etc.): http://www.kroegerama.de
  Mit Zitat antworten Zitat
Benutzerbild von SirThornberry
SirThornberry
(Moderator)

Registriert seit: 23. Sep 2003
Ort: Bockwen
12.235 Beiträge
 
Delphi 2006 Professional
 
#3

Re: FindComponent(...) geht nicht ?

  Alt 8. Jun 2008, 20:36
FindComponent ist zum suchen einer TComponent
TCanvas ist hingegen kein TComponent

Aber du machst da allgemein was falsch. Du suchst ja nach "Componentenname.Eigenschaftsname" aber FindComponent erwartet nur "Componentname".

Schau dir FindComponent am besten mal in der Hilfe an und such hier im Forum danach. Da wirst du einige Beispiele finden wie es richtig verwendet wird.
Jens
Mit Source ist es wie mit Kunst - Hauptsache der Künstler versteht's
  Mit Zitat antworten Zitat
cetinbiryoldayim

Registriert seit: 6. Mai 2008
33 Beiträge
 
#4

Re: FindComponent(...) geht nicht ?

  Alt 8. Jun 2008, 21:59
danke sehr
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 12:21 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf