AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke Delphi [Indy] IdHTTPServer hängt sich unter Vista auf

[Indy] IdHTTPServer hängt sich unter Vista auf

Ein Thema von Karsten der Kelte · begonnen am 9. Jul 2008 · letzter Beitrag vom 13. Jul 2008
Antwort Antwort
Karsten der Kelte

Registriert seit: 16. Mai 2006
7 Beiträge
 
#1

[Indy] IdHTTPServer hängt sich unter Vista auf

  Alt 9. Jul 2008, 14:23
Ich will mit Indy einen HTTP Server schreiben.

Starten des Programmes geht. Aber wenn ich dann im Browser mich selbst anwähle, legt das Programm volle CPU Last ein aber reagiert nicht auf die Anfrage.

Ich hab testweise in alle Events Breakpoints gelegt. Davon wird aber keiner angesprungen. Und der Browser wartet einfach nur vergebens.

Hat jemand ne Idee was helfen könnte? (die Firewall hat einmal gefragt und die Erlaubnis bekommen)

Eine andere Komponente wäre auch möglich. Ich will einfach nur HTML und JPG verteilen. Und eine Formular-Anfrage wäre noch toll.

Unter XP hatte ich sowas mal laufen. Aber die Programme hängen sich auch alle auf.

Delphi 2007
Indy 10
Vista Home Prof., UAC aktv
IE 7.0
Firefox 3.0
Ciao

Karsten
  Mit Zitat antworten Zitat
Benutzerbild von DataCool
DataCool

Registriert seit: 10. Feb 2003
Ort: Lingen
909 Beiträge
 
Delphi 10.3 Rio
 
#2

Re: [Indy] IdHTTPServer hängt sich unter Vista auf

  Alt 10. Jul 2008, 01:58
Hi,

welche 10er Version der Indys ? 10.1.5 ?
Wenn ja auf den Developsnapshot 10.2.3 updaten,

Greetz Data
Der Horizont vieler Menschen ist ein Kreis mit Radius Null, und das nennen sie ihren Standpunkt.
  Mit Zitat antworten Zitat
rotfc
(Gast)

n/a Beiträge
 
#3

Re: [Indy] IdHTTPServer hängt sich unter Vista auf

  Alt 10. Jul 2008, 02:20
Zitat von Karsten der Kelte:
...

Starten des Programmes geht. Aber wenn ich dann im Browser mich selbst anwähle, legt das Programm volle CPU Last ein aber reagiert nicht auf die Anfrage.
...
Repeat until true? Schleife übersehen?


Ansonsten: Herzlich willkommen in der Delphi-Praxis!
  Mit Zitat antworten Zitat
Karsten der Kelte

Registriert seit: 16. Mai 2006
7 Beiträge
 
#4

Re: [Indy] IdHTTPServer hängt sich unter Vista auf

  Alt 13. Jul 2008, 12:40
Hi,

danke für Eure Antworten.

Die Beta hab ich leider nich kompiliert bekommen. Irgendwie fehlen da Dateien.

Repeat oder so hatte ich im Test nicht drinnen. Einfach auf die Events nen Beep; gelegt mit Breakpoint.

Ich habs jetzt erstmal mit TServerSocket gemacht. Wenn ich wieder etwas Luft hab werd ich mir die Indys nochmal vornehmen. Bisher war ich sehr zufriedenen mit denen.
Ciao

Karsten
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 02:55 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz