AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke Delphi TWebbrowser + "protected" Button

TWebbrowser + "protected" Button

Ein Thema von Bl00dh0und · begonnen am 11. Jul 2008 · letzter Beitrag vom 12. Jul 2008
Antwort Antwort
Bl00dh0und

Registriert seit: 13. Okt 2005
5 Beiträge
 
#1

TWebbrowser + "protected" Button

  Alt 11. Jul 2008, 23:52
Hi,

Ich möchte mit TWebbrowser den Button Continue anklicken. Leider scheint selbiger noch irgendwie geschützt zu sein und deshalb sind wohl auch alle meine Versuche fehlgeschlagen.

Delphi-Quellcode:
</script>



<div id="ajax">
    <div class="bgpanel">
      <div class="forms">
        



          <a href=.>[img]http://i31.tinypic.com/i50he9.jpg[/img]</a>



            [url="http://protect.tehparadox.com/3d53cdd0!"][b]http://protect.tehparadox.com/3d53cdd0![/b][/url]



              <form action="." method="POST" id="submit_form">
                <INPUT type="hidden" name="id" size="20" value="3d53cdd0">
                This link has been protected by protect.tehparadox.com: <input class="button" type="Submit" Value="Continue">
              </form>

          
<script type="text/javascript">
   var AdBrite_Title_Color = 'ff9d03';
   var AdBrite_Text_Color = '2f2f2f';
   var AdBrite_Background_Color = 'ffffff';
   var AdBrite_Border_Color = 'FFFFFF';
</script>
<span style="white-space:nowrap;"><script src="http://ads.adbrite.com/mb/text_group.php?sid=575951&zs=3436385f3630" type="text/javascript"></script><!--
-->[url="http://www.adbrite.com/mb/commerce/purchase_form.php?opid=575951&afsid=1"][img]http://files.adbrite.com/mb/images/adbrite-your-ad-here-banner.gif[/img][/url]</span>


          
&copy 2008 - [url="http://tehparadox.com"]tehPARADOX.COM Online Sharing Community[/url]







      </div>
    </div>
  </div>

<script src="http://www.google-analytics.com/urchin.js" type="text/javascript">
</script>
<script type="text/javascript">
_uacct = "UA-1339782-2";
urchinTracker();
</script>
Hat Jemand eine Idee wie man das machen könnte?

THX
  Mit Zitat antworten Zitat
Benutzerbild von Zacherl
Zacherl

Registriert seit: 3. Sep 2004
4.629 Beiträge
 
Delphi 10.2 Tokyo Starter
 
#2

Re: TWebbrowser + "protected" Button

  Alt 12. Jul 2008, 00:17
Also ich sehe da keinen großartigen Schutz. Wie hattest du es denn versucht? BTW: Den Link solltest du lieber rausnehmen, um dich nicht strafbar zu machen
  Mit Zitat antworten Zitat
Bl00dh0und

Registriert seit: 13. Okt 2005
5 Beiträge
 
#3

Re: TWebbrowser + "protected" Button

  Alt 12. Jul 2008, 03:13
Folgender Code
Delphi-Quellcode:
procedure TForm1.Button2Click(Sender: TObject);
var
  ovElements: OleVariant;
  i: Integer;
begin
  ovElements := WebBrowser1.OleObject.Document.forms.item(0).elements;
  for i := 0 to (ovElements.Length - 1) do
    if {(ovElements.item(i).tagName = 'id') and}
      (ovElements.item(i).type = 'submit') and
      (ovElements.item(i).Value = 'Continue') then
      ovElements.item(i).Click;
end;
Also hab jetzt das ganze noch auf VMWare mit WinXP SP3 und IE6 ausprobiert und dann klappt es. Wenn ich nun das auf meinem normalen Betriebssystem (Windows Server 2008 SP1 mit IE7) mein Programm ausführe, kommt beim Aufrufen der Seite folgender Fehler:
Zitat:
A Runtime Error has occured.
Do you wish to Debug?
Line: 18
Error: 'document.submition.link' is null or not an object'
Beim Versuch den Button mit dem obigen Code anzuklicken, kommt folgender Fehler:
Zitat:
A Runtime Error has occured.
Do you wish to Debug?
Line: 27
Error: Automation server can't create object
  Mit Zitat antworten Zitat
Benutzerbild von toms
toms
(CodeLib-Manager)

Registriert seit: 10. Jun 2002
4.648 Beiträge
 
Delphi XE Professional
 
#4

Re: TWebbrowser + "protected" Button

  Alt 12. Jul 2008, 05:38
Zitat von Bl00dh0und:
Beim Versuch den Button mit dem obigen Code anzuklicken, kommt folgender Fehler:

A Runtime Error has occured.
Do you wish to Debug?
Line: 18
Error: 'document.submition.link' is null or not an object'
Setze die Eigenschaft Silent im OI auf True. Somit erscheint keine Fehlermeldung mehr.


Zitat:
Beim Versuch den Button mit dem obigen Code anzuklicken, kommt folgender Fehler:

A Runtime Error has occured.
Do you wish to Debug?
Line: 27
Error: Automation server can't create object
Getestet mit IE7, XP2 SP3. Button wird angeklickt ohne Fehlermeldung.
Thomas
  Mit Zitat antworten Zitat
Bl00dh0und

Registriert seit: 13. Okt 2005
5 Beiträge
 
#5

Re: TWebbrowser + "protected" Button

  Alt 12. Jul 2008, 12:09
Mit Silent funktioniert es, aber ActiveX muss beim IE aktiviert sein.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 02:40 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz