AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi Probleme mit ADO nach Portierung von D5 nach D7

Probleme mit ADO nach Portierung von D5 nach D7

Ein Thema von UweR · begonnen am 2. Dez 2008 · letzter Beitrag vom 2. Dez 2008
Antwort Antwort
UweR

Registriert seit: 15. Mär 2004
Ort: Bad Marienberg
219 Beiträge
 
Delphi 7 Professional
 
#1

Probleme mit ADO nach Portierung von D5 nach D7

  Alt 2. Dez 2008, 12:26
Datenbank: ACCESS, MS-SQL • Version: div. • Zugriff über: ADO
Hallo,

ich bin dabei gerade ein Program von D5 nach D7 portieren. Dabei habe ich unter D5 mit KAADO auf Datenbanken zugegriffen. Das Projekt mit D7 aufgemacht, die KAADO-Komponenten runter geschmissen, ADO-Komponenteb drauf geknallt, die Properties passend gesetzt und zur Designtime war erst mal alles glücklich. Dann habe ich dummerweise mein Programm mal gestartet.

Zuerst hab ich ne Exception bekommen das ich CoInitialize nicht aufgerufen wurde. OK, in meinem Datenmodul einen Initialization-Teil eingefügt, CoInitialze schön brav aufgerufen und es ging weiter. Und zwar genau bis zum ersten öffnen der ADO-Connection. Da kriege ich die Fehlermeldung "Installierbares ISAM nicht gefunden". Zur Entwurfszeit kann ich die Datenbank mit dem gleichen ConnectString problemlos öffnen. Irgendjemand irgendwelche Ideen?

Noch der kurze Hinweis das die Verwendung von ADO bei Projekten die nicht vorher mit D5 erstellt wurden auch zur Laufzeit wunderbar funktioniert.
Gruß
UweR
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
16.566 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#2

Re: Probleme mit ADO nach Portierung von D5 nach D7

  Alt 2. Dez 2008, 13:30
Zeig mal deinen Connection-String.

und das CoInitialze-"Problem" solltest du über die Ergänzung von Application.Initialize; in der DPR-Datei lösen.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 22:24 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf