AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

WriteProcessMemory funktioniert nicht

Ein Thema von -=Breeze=- · begonnen am 28. Mär 2009 · letzter Beitrag vom 30. Mär 2009
Antwort Antwort
-=Breeze=-

Registriert seit: 14. Apr 2008
Ort: Köln
29 Beiträge
 
Delphi 7 Enterprise
 
#1

WriteProcessMemory funktioniert nicht

  Alt 28. Mär 2009, 17:21
Guten Abend,

ich habe vor einigen Tagen eine Prozedur geschrieben, die mithilfe von WriteProcessMemory Werte in einem Spiel verändert.

Doch nach kleinen Veränderungen funktioniert diese leider nicht mehr, und ich finde den Fehler einfach nicht...
Die Adresse ist statisch, werden beim Neustart des Spiels nicht verändert.

Hier der Code, ich hoffe jemand findet den Fehler

Delphi-Quellcode:
const
  WindowTitle = 'SPIEL-NAME';
  Address = $00431CA8;
  NumberOfBytes = 1;


procedure TForm1.setlives(lives: integer);
begin
  if DX_running then // wenn das Spiel läuft
  begin
  GetMem(buf,1);
  ThreadId := GetWindowThreadProcessId(WindowName,@ProcessId);
  HandleWindow := OpenProcess(PROCESS_ALL_ACCESS,False,ProcessId);

  try
    buf^ := Chr(Lives);
    WriteProcessMemory(HandleWindow,ptr(Address), buf, NumberOfBytes, write);
  finally
    FreeMem(buf);
    closehandle(HandleWindow);
  end;
  end;
end;
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)

Registriert seit: 29. Mai 2002
37.013 Beiträge
 
Delphi 2006 Professional
 
#2

Re: WriteProcessMemory funktioniert nicht

  Alt 28. Mär 2009, 17:53
Könntest du was mit der Fehlermeldung "Läuft nicht mehr" anfangen?
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Christian Seehase
(Co-Admin)

Registriert seit: 29. Mai 2002
Ort: Hamburg
11.262 Beiträge
 
Delphi 2006 Professional
 
#3

Re: WriteProcessMemory funktioniert nicht

  Alt 29. Mär 2009, 13:49
Moin Breeze,

ich finde, Du solltest Deinen Code erst einmal etwas "aufräumen"

Du prüfst nämlich nicht, ob Deine Funktionsaufrufe überhaupt erfolgreich waren.
Wenn OpenProcess fehlschlägt, was gerade bei PROCESS_ALL_ACCESS leicht passieren kann, bekommst Du kein gültiges Handle, und WriteProcessMemory muss fehlschlagen.
Tschüss Chris
Die drei Feinde des Programmierers: Sonne, Frischluft und dieses unerträgliche Gebrüll der Vögel.
Der Klügere gibt solange nach bis er der Dumme ist
  Mit Zitat antworten Zitat
-=Breeze=-

Registriert seit: 14. Apr 2008
Ort: Köln
29 Beiträge
 
Delphi 7 Enterprise
 
#4

Re: WriteProcessMemory funktioniert nicht

  Alt 29. Mär 2009, 21:20
Guten abend,
"läuft nicht mehr" bedeutet hier, dass es keinerlei Fehler gibt, die Speicheradresse aber nicht verändert wird.

@christian: soll ich nach openprocess überprüfen, ob das Handle=0 ist?
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
34.931 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#5

Re: WriteProcessMemory funktioniert nicht

  Alt 29. Mär 2009, 21:45
Rückgabewerte solltest du möglicht immer prüfen
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
Christian Seehase
(Co-Admin)

Registriert seit: 29. Mai 2002
Ort: Hamburg
11.262 Beiträge
 
Delphi 2006 Professional
 
#6

Re: WriteProcessMemory funktioniert nicht

  Alt 29. Mär 2009, 23:18
Moin Breeze,

schau Dir doch einfach mal die Dokumentation zu MSDN-Library durchsuchenOpenProcess und MSDN-Library durchsuchenWriteProcessMemory an, dann weisst Du auf welche Werte Du testen musst.
Im Fehlerfalle kannst Du Dir dann mit

ShowMessage(SysErrorMessage(GetLastError)); den Fehler im Klartext anzeigen lassen.
Tschüss Chris
Die drei Feinde des Programmierers: Sonne, Frischluft und dieses unerträgliche Gebrüll der Vögel.
Der Klügere gibt solange nach bis er der Dumme ist
  Mit Zitat antworten Zitat
-=Breeze=-

Registriert seit: 14. Apr 2008
Ort: Köln
29 Beiträge
 
Delphi 7 Enterprise
 
#7

Re: WriteProcessMemory funktioniert nicht

  Alt 30. Mär 2009, 21:58
Nachdem ich WriteProcessMemory aufrufe, spuckt er als Error das aus:
"Das Handle ist ungültig"
Ich werde mal ein bisschen probieren...

Kann es außerdem sein, dass in der Variable ProcessId gar nichts gespeichert wird?

Delphi-Quellcode:
  ThreadId := GetWindowThreadProcessId(WindowName,@ProcessId);
HandleWindow := OpenProcess(PROCESS_ALL_ACCESS,False,ProcessId);

Nächstes Edit


Ich war mal wieder zu voreilig, und habe die Lösung.

Einleuchtend ist jetzt, warum er kein richtiges Handle gefunden hat^^
Schließlich habe ich WindowName verwendet, aber nicht vorher bestimmt.

Der folgende Code hat also ausgereicht, um das Problem zu beheben

WindowName := FindWindow(nil, WindowTitle); Nochmal vielen Dank für eure Tips
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 09:26 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf