AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Multimedia [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

[Andorra2D] Umlaute in der GUI werden nicht angezeigt!

Offene Frage von "Eljey"
Ein Thema von Eljey · begonnen am 5. Apr 2009 · letzter Beitrag vom 9. Apr 2009
Antwort Antwort
Seite 2 von 2     12
Benutzerbild von igel457
igel457

Registriert seit: 31. Aug 2005
1.622 Beiträge
 
FreePascal / Lazarus
 
#11

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 9. Apr 2009, 14:50
Gut, dann liegt es schonmal nicht am XML.

Schreib mal in AdStandardFontGenerator vor die Zeile "rgb.Free" (bei mir Zeile 226) rgb.SaveToFile('dump.bmp') und poste diese Datei.
Andreas
"Sollen sich auch alle schämen, die gedankenlos sich der Wunder der Wissenschaft und Technik bedienen, und nicht mehr davon geistig erfasst haben als die Kuh von der Botanik der Pflanzen, die sie mit Wohlbehagen frisst." - Albert Einstein
  Mit Zitat antworten Zitat
Benutzerbild von Eljey
Eljey

Registriert seit: 5. Mai 2007
56 Beiträge
 
#12

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 9. Apr 2009, 15:16
ok, hier ist die datei.
Angehängte Grafiken
Dateityp: bmp dump_151.bmp (107,3 KB, 12x aufgerufen)
  Mit Zitat antworten Zitat
Benutzerbild von igel457
igel457

Registriert seit: 31. Aug 2005
1.622 Beiträge
 
FreePascal / Lazarus
 
#13

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 9. Apr 2009, 16:07
Scheinbar weigert sich die LCL den erweiterten ASCII Zeichensatz auszugeben: Wie du siehst fehlen alle Zeichen ab #127. Ist also eindeutig ein Bug in Lazarus/der LCL - sofern sie nicht zwischenzeitlich auf eine andere Kodierung als ASCII/ANSI umgestiegen sind.
Andreas
"Sollen sich auch alle schämen, die gedankenlos sich der Wunder der Wissenschaft und Technik bedienen, und nicht mehr davon geistig erfasst haben als die Kuh von der Botanik der Pflanzen, die sie mit Wohlbehagen frisst." - Albert Einstein
  Mit Zitat antworten Zitat
Benutzerbild von Eljey
Eljey

Registriert seit: 5. Mai 2007
56 Beiträge
 
#14

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 9. Apr 2009, 16:42
ok, ich werde das Projekt einfach mit der alten version von lazarus kompelieren, aber für die version 0.5 von Andorra2d wäre die unterstützung der neuen Version nicht schlech

EDIT: Ich hab das Projekt mit der Version 0.9.24 von Lazarus kompiliert und siehe da die umlaute werden angezeigt. Im anhang nochmal die dump.bmp.

Vielleicht haben die in der 0.9.26 ja eine Unit geändert oder so was, eventuel helfen dir die Change Notes
Angehängte Grafiken
Dateityp: bmp dump_165.bmp (146,3 KB, 9x aufgerufen)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 22:13 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf