AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Multimedia [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

[Andorra2D] Umlaute in der GUI werden nicht angezeigt!

Offene Frage von "Eljey"
Ein Thema von Eljey · begonnen am 5. Apr 2009 · letzter Beitrag vom 9. Apr 2009
Antwort Antwort
Seite 1 von 2  1 2   
Benutzerbild von Eljey
Eljey

Registriert seit: 5. Mai 2007
56 Beiträge
 
#1

[Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 5. Apr 2009, 16:46
Ich benutze die Andorra Version 0.451 und habe eine GUI mit dem GUI Editor erstellt. In einem TAdLabel steht der text "Wüste" es wird aber nur "Wste" angezeigt. Und so ist das bei Umlauten immer. Ich habe versucht die Fonts in der eigenschaft Fonts von TAdGUI zu ändern, aber das hat nichts geholfen, bzw. das Programm stürzte ab (wenn ich den font gelöscht habe, dann startete es wieder.

Wie kann ich Umlaute darstellen?
  Mit Zitat antworten Zitat
Benutzerbild von igel457
igel457

Registriert seit: 31. Aug 2005
1.622 Beiträge
 
FreePascal / Lazarus
 
#2

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 5. Apr 2009, 16:56
Hm, mit deutschen Umlauten (ü, ö, ä, ß) hatte ich noch kein Problem. Standardmäßig wird glaube ich der Font "Tahoma" verwendet und die Zeichen #0 - #255 ausgegeben. Was für eine Betriebssystem(sprach)-Version hast du, welche Ländereinstellungen?
Andreas
"Sollen sich auch alle schämen, die gedankenlos sich der Wunder der Wissenschaft und Technik bedienen, und nicht mehr davon geistig erfasst haben als die Kuh von der Botanik der Pflanzen, die sie mit Wohlbehagen frisst." - Albert Einstein
  Mit Zitat antworten Zitat
Benutzerbild von Eljey
Eljey

Registriert seit: 5. Mai 2007
56 Beiträge
 
#3

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 5. Apr 2009, 17:02
Deutsche windows xp, bei Regions und Spracheinstellungen steht überall Deutsch.

Ich hab mein Programm auch an anderen Computern ausprobiert, das gleiche. In dem GUIEditor steh das noch mit Umlaut, sobald es geladen wird ist das Umlaut weg
  Mit Zitat antworten Zitat
Benutzerbild von igel457
igel457

Registriert seit: 31. Aug 2005
1.622 Beiträge
 
FreePascal / Lazarus
 
#4

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 5. Apr 2009, 17:13
Hm, kann ich jetzt nicht bestätigen. Verwendest du Delphi 2009? Was eine erstellte XML-Datei mit einem Button auf dem "üöä" steht, sieht bei mir so aus:
Code:
<?xml version="1.0" encoding="iso-8859-1"?>
  <TAdGUI name="AdGUI1" alpha="255" cursor="default" enabled="-1" height="576" width="635" hint="" showhint="0" visible="-1" x="0" y="0" fontcolor="0" fontname="" fontdata="00000000">
    <TAdPanel name="AdPanel1" alpha="255" cursor="default" enabled="-1" height="80" width="280" hint="" showhint="0" visible="-1" x="95" y="125" fontcolor="0" fontname="" textpos="0" alignment="0" [b]caption="&#xFC;&#xF6;&#xE4;"[/b] wordwrap="0"/>
  </TAdGUI>
Sieht das bei dir anders aus?
Andreas
"Sollen sich auch alle schämen, die gedankenlos sich der Wunder der Wissenschaft und Technik bedienen, und nicht mehr davon geistig erfasst haben als die Kuh von der Botanik der Pflanzen, die sie mit Wohlbehagen frisst." - Albert Einstein
  Mit Zitat antworten Zitat
Benutzerbild von Eljey
Eljey

Registriert seit: 5. Mai 2007
56 Beiträge
 
#5

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 5. Apr 2009, 17:20
Ich benutze Lazarus (bitte sag mir nicht das es daran liegt, das wäre blöd )

so sieht das wort wüste in der xml aus "W&#xFC;ste", entspricht deinem Beispiel
  Mit Zitat antworten Zitat
Benutzerbild von igel457
igel457

Registriert seit: 31. Aug 2005
1.622 Beiträge
 
FreePascal / Lazarus
 
#6

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 5. Apr 2009, 18:12
Doch, daran müsste es liegen - Sobald ich Zeit finde, versuche ich das Problem zu lösen...
Andreas
"Sollen sich auch alle schämen, die gedankenlos sich der Wunder der Wissenschaft und Technik bedienen, und nicht mehr davon geistig erfasst haben als die Kuh von der Botanik der Pflanzen, die sie mit Wohlbehagen frisst." - Albert Einstein
  Mit Zitat antworten Zitat
Benutzerbild von Eljey
Eljey

Registriert seit: 5. Mai 2007
56 Beiträge
 
#7

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 5. Apr 2009, 18:47
Gut, dann warte ich gespannt. Ich muss nur im Mai meine Facharbeit für die Schule abgeben und das ist das Programm, ist blöd wenn die Texte ohne Umlaute sind.

Hoffe du findest bald Zeit Schreib einfach in den Thread
  Mit Zitat antworten Zitat
Benutzerbild von Eljey
Eljey

Registriert seit: 5. Mai 2007
56 Beiträge
 
#8

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 7. Apr 2009, 18:52
Ok ich hab den Fehler jetzt so weit eingeschränkt, dass er nur bei der 0.9.26beta version von Lazarus auftritt, bei älteren Versionen klappt die Umlaut ausgabe hervorragend.
  Mit Zitat antworten Zitat
Benutzerbild von igel457
igel457

Registriert seit: 31. Aug 2005
1.622 Beiträge
 
FreePascal / Lazarus
 
#9

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 9. Apr 2009, 11:48
Puh... Scheint also als wäre ich nicht daran Schuld

Versuche mal folgendes:
Gib einen Text folgendermaßen in der Hauptschleife deines Programmes aus:
Delphi-Quellcode:
with AdDraw.Canvas do
begin
  TextOut(0, 0, 'ÄÖÜäöü');
  Release;
end;
Funktioniert das? Wenn das geht, liegt es an der XML-Datei.
Andreas
"Sollen sich auch alle schämen, die gedankenlos sich der Wunder der Wissenschaft und Technik bedienen, und nicht mehr davon geistig erfasst haben als die Kuh von der Botanik der Pflanzen, die sie mit Wohlbehagen frisst." - Albert Einstein
  Mit Zitat antworten Zitat
Benutzerbild von Eljey
Eljey

Registriert seit: 5. Mai 2007
56 Beiträge
 
#10

Re: [Andorra2D] Umlaute in der GUI werden nicht angezeigt!

  Alt 9. Apr 2009, 14:30
Nein, leider zeigt er diesen Text auch nicht an.
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 18:30 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf