AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi SQL Komponenten haben keine Verbindung

SQL Komponenten haben keine Verbindung

Ein Thema von simmi · begonnen am 24. Mai 2009 · letzter Beitrag vom 26. Mai 2009
Antwort Antwort
Benutzerbild von simmi
simmi

Registriert seit: 24. Nov 2004
Ort: Röbel/Müritz
112 Beiträge
 
Delphi XE5 Professional
 
#1

SQL Komponenten haben keine Verbindung

  Alt 24. Mai 2009, 17:41
Hallo,

wahrscheinlich ist mein Problem etwas ganz einfaches. Ich möchte eine Verbindung zu einer MySQL Tabelle aufbauen.

1. Der Server läuft - mit PHPMyAdmin geprüft
2. Die Delphi Komponente TSQLConnection hat die Verbindung zum SQL Server hergestellt (Connected = true)

Nun habe ich auf meiner Form das Objekt TSQLTable hinzugefügt. In diesem Objekt die Verbindung zu SQLConnection hergestellt. Sofern ich nun jedoch eine von den beiden in dieser Datenbank vorhandenen Tabellen auswählen möchte, dann finde ich in der SQLTable einfach keine Tabelle.

Warum nicht? Fehlt irgendwas?

Für jeden Hinweis bin ich dankbar.

Simmi
Uwe
  Mit Zitat antworten Zitat
24. Mai 2009, 21:51
Dieses Thema wurde von "mkinzler" von "Neuen Beitrag zur Code-Library hinzufügen" nach "Datenbanken" verschoben.
Ist eine Frage und kein Vorschlag zur CL
Benutzerbild von Die Muhkuh
Die Muhkuh

Registriert seit: 21. Aug 2003
7.332 Beiträge
 
Delphi 2009 Professional
 
#3

Re: SQL Komponenten haben keine Verbindung

  Alt 24. Mai 2009, 22:35
Hast Du externen Zugriff auf Deine MySQL-DB?
  Mit Zitat antworten Zitat
Benutzerbild von simmi
simmi

Registriert seit: 24. Nov 2004
Ort: Röbel/Müritz
112 Beiträge
 
Delphi XE5 Professional
 
#4

Re: SQL Komponenten haben keine Verbindung

  Alt 25. Mai 2009, 12:58
Beides läuft auf einem PC. Ich habe WAMP installiert, welches mir keine Fehler meldet (XP 32).

Muss ich auch in diesem Fall beim Firewall Portfreigaben beachten? Eigentlich wäre das unsinnig. Mein PC sagt mir auch er hat eine Verbindung zur DB.

Habe übrigens auch MYSQLdirekt mit dem Tutorial (Delphi Treff)ausprobiert. Auch hier bekam ich die Meldung das die Verbindung zur DB besteht, einen Datensatz hinzufügen konnte - nur bekam ich keine Daten aus der Tabelle wieder zurück. Hier lieferte mir die Variable FResult dann immer den Wert nil.

Wie ich es auch anfange, ich komme zu keinem brauchbaren Ergebnis.
Uwe
  Mit Zitat antworten Zitat
Benutzerbild von simmi
simmi

Registriert seit: 24. Nov 2004
Ort: Röbel/Müritz
112 Beiträge
 
Delphi XE5 Professional
 
#5

Re: SQL Komponenten haben keine Verbindung

  Alt 26. Mai 2009, 09:43
Habe nach einigem Suchen den Fehler gefunden. Lag im System selbst. Durch vieles Testen sind Systemeinstellungen nicht mehr korrekt. Diese verhindern die korrekte Verbindung. Habe XP neu installiert und es ging.
Uwe
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 08:58 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz