AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Sprachen und Entwicklungsumgebungen Sonstige Fragen zu Delphi Delphi Registry Werte beim starten auslesen klappt nicht

Registry Werte beim starten auslesen klappt nicht

Ein Thema von Helpliner · begonnen am 23. Jan 2004 · letzter Beitrag vom 25. Jan 2004
Antwort Antwort
Seite 1 von 3  1 23   
Helpliner

Registriert seit: 6. Aug 2003
Ort: Hamburg
84 Beiträge
 
Delphi 7 Personal
 
#1

Registry Werte beim starten auslesen klappt nicht

  Alt 23. Jan 2004, 07:43
Hallo Leute,

ich habe eine kleine Frage. Ich benutze folgenden Code um Daten aus der Registry auszulesen, ich benutze dafür die OnClick Routine eines MainMenu eintrages:

Delphi-Quellcode:
procedure TForm1.Datenholen1Click(Sender: TObject);
 var reg : TRegistry;
begin
 reg:=TRegistry.Create;
 reg.RootKey:=HKEY_CURRENT_USER;
   reg.OpenKey('Software\Fischmob\Flotteninformationen\0.1 beta', false);
   Edit1.Text := reg.ReadString('Typ 1');
   Edit2.Text := reg.ReadString('Typ 2');
   Edit3.Text := reg.ReadString('Typ 3');
   Edit4.Text := reg.ReadString('Typ 4');
   Edit5.Text := reg.ReadString('Typ 5');
   Edit6.Text := reg.ReadString('Typ 6');
   Edit7.Text := reg.ReadString('Typ 7');
   Edit8.Text := reg.ReadString('Typ 8');
   Edit9.Text := reg.ReadString('Typ 9');
 reg.free;
end;
weil ich aber eigentlich einen klick sparen wollte da die Daten sowieso bei jedem Programmstart gelesen werden sollen, habe ich den identischen Code in das OnCreate Ereigniss von Form1 gesetzt, sobald ich dann das Programm starte werden keine Werte mehr gelesen und alle Werte in der Registry werden auf 0 gesetzt, wie kann das sein?
VORSICHT: blutiger Anfänger!

Ähnlichkeiten mit tatsächlich funktionierendem Code sind rein zufällig und definitiv unbeabsichtigt.
  Mit Zitat antworten Zitat
Benutzerbild von Pseudemys Nelsoni
Pseudemys Nelsoni

Registriert seit: 24. Dez 2002
Ort: Hamburg-Harburg
3.551 Beiträge
 
#2

Re: Registry Werte beim starten auslesen klappt nicht

  Alt 23. Jan 2004, 07:48
daran ist nichts falsch, bist du sicher das der pfad richtig ist?
Mario
  Mit Zitat antworten Zitat
Benutzerbild von Pseudemys Nelsoni
Pseudemys Nelsoni

Registriert seit: 24. Dez 2002
Ort: Hamburg-Harburg
3.551 Beiträge
 
#3

Re: Registry Werte beim starten auslesen klappt nicht

  Alt 23. Jan 2004, 07:55
also ich habs nochmal getestet:

Delphi-Quellcode:
procedure TForm1.Button1Click(Sender: TObject);
var reg: TRegistry;
begin
  reg := TRegistry.Create;
  with reg do
  begin
    RootKey := HKEY_CURRENT_USER;
    if OpenKey('Software\Fischmob\Flotteninformationen\0.1 beta', false) then
    begin
      Try
        Edit1.Text := ReadString('Typ 1');
        Edit2.Text := ReadString('Typ 2');
        Edit3.Text := ReadString('Typ 3');
        Edit4.Text := ReadString('Typ 4');
        Edit5.Text := ReadString('Typ 5');
        Edit6.Text := ReadString('Typ 6');
        Edit7.Text := ReadString('Typ 7');
        Edit8.Text := ReadString('Typ 8');
        Edit9.Text := ReadString('Typ 9');
      finally
        CloseKey;
        Free;
      end;
    end;
  end;
end;
funktioniert einwandfrei
Mario
  Mit Zitat antworten Zitat
Helpliner

Registriert seit: 6. Aug 2003
Ort: Hamburg
84 Beiträge
 
Delphi 7 Personal
 
#4

Re: Registry Werte beim starten auslesen klappt nicht

  Alt 23. Jan 2004, 08:02
Ich glaube nicht das Tippfehler drinne sind, ich schaue da seit 5:30 drauf, aber ich häng das Projekt nochmal an, so wie es nicht funktioniert.

Nochmal zur verdeutlichung was passiert:

Erster Start:
- Registry Werte existieren noch nicht und werden mit dem Wert 0 erzeugt.
- Ich gebe Werte in die Edits ein und beende das Progg, die Werte werden geschrieben.

Zweiter Start:
- Überprüfung ob der Key schon existiert über
   reg.OpenKey('Software\Fischmob\Flotteninformationen\0.1 beta', true); - Die in der Registrierung stehenden werte werden nicht eingetragen, sondern nur Nullen (Die Werte stehen aber noch in der Registrierung).
- Beenden des Programmes, Werte in der Registrierung werden mit Nullen überschrieben......und ich habe keine Ahnung wieso.
Angehängte Dateien
Dateityp: rar flotten.rar (167,2 KB, 2x aufgerufen)
VORSICHT: blutiger Anfänger!

Ähnlichkeiten mit tatsächlich funktionierendem Code sind rein zufällig und definitiv unbeabsichtigt.
  Mit Zitat antworten Zitat
Benutzerbild von Pseudemys Nelsoni
Pseudemys Nelsoni

Registriert seit: 24. Dez 2002
Ort: Hamburg-Harburg
3.551 Beiträge
 
#5

Re: Registry Werte beim starten auslesen klappt nicht

  Alt 23. Jan 2004, 08:03
die unit1.pas/unit1.dcu brauch ich schon
Mario
  Mit Zitat antworten Zitat
Helpliner

Registriert seit: 6. Aug 2003
Ort: Hamburg
84 Beiträge
 
Delphi 7 Personal
 
#6

Re: Registry Werte beim starten auslesen klappt nicht

  Alt 23. Jan 2004, 08:07
ups...war das falsche Projektverzeichniss
Angehängte Dateien
Dateityp: rar flotten_246.rar (174,3 KB, 3x aufgerufen)
VORSICHT: blutiger Anfänger!

Ähnlichkeiten mit tatsächlich funktionierendem Code sind rein zufällig und definitiv unbeabsichtigt.
  Mit Zitat antworten Zitat
Benutzerbild von Pseudemys Nelsoni
Pseudemys Nelsoni

Registriert seit: 24. Dez 2002
Ort: Hamburg-Harburg
3.551 Beiträge
 
#7

Re: Registry Werte beim starten auslesen klappt nicht

  Alt 23. Jan 2004, 08:12
hi Helpliner, das dürfte wohl am OnCreate liegen, die edits sind nach dem create von form1 wohl noch nicht da, machs mal im OnShow/OnActivate
Mario
  Mit Zitat antworten Zitat
Benutzerbild von BrinkschulteManfred
BrinkschulteManfred

Registriert seit: 23. Sep 2003
Ort: Menden
97 Beiträge
 
Delphi 7 Enterprise
 
#8

Re: Registry Werte beim starten auslesen klappt nicht

  Alt 23. Jan 2004, 08:19
Hast Du mal versucht, die Einträge nicht schon beim OnCreate sondern erst beim OnActivate zu lesen?
Ich hatte da mal so ein Problem.
Gruß
Manfred
  Mit Zitat antworten Zitat
Helpliner

Registriert seit: 6. Aug 2003
Ort: Hamburg
84 Beiträge
 
Delphi 7 Personal
 
#9

Re: Registry Werte beim starten auslesen klappt nicht

  Alt 23. Jan 2004, 08:25
Besten Dank Leute, jetzt geht es......ist das denn Zufall das die Edits....tja..."langsamer" da sind als das Form.Create oder ist das eine Erstellungsreihenfolge (Erst Form, dann Items auf der Form) ?
VORSICHT: blutiger Anfänger!

Ähnlichkeiten mit tatsächlich funktionierendem Code sind rein zufällig und definitiv unbeabsichtigt.
  Mit Zitat antworten Zitat
MathiasSimmack
(Gast)

n/a Beiträge
 
#10

Re: Registry Werte beim starten auslesen klappt nicht

  Alt 23. Jan 2004, 09:25
Trotzdem solltest du noch mal über das try und finally nachdenken, wenn das in deinem Programm so aussieht wie in deinem Codeauszug oben. Ich gebe zu, ich habe mir deinen Anhang nicht angesehen. Vielleicht ist da ja inzwischen alles richtig.
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 3  1 23   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 01:15 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf