AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

TOutlookApplication in D2010

Ein Thema von Captnemo · begonnen am 30. Jan 2011 · letzter Beitrag vom 15. Sep 2013
Antwort Antwort
Seite 1 von 3  1 23   
Benutzerbild von Captnemo
Captnemo

Registriert seit: 27. Jan 2003
Ort: Bodenwerder
1.126 Beiträge
 
Delphi XE4 Architect
 
#1

TOutlookApplication in D2010

  Alt 30. Jan 2011, 22:02
Hallo Leute,

ich probe grad den Umstieg von D7 -> D2010. Soweit klappt das ganz gut.
Scheitern tue ich aber an der TOutlookApplication.
Ich D2010 mit allen Optionen installiert. Nachdem ich es nicht gefunden habe, hab ich unter Komponenten - Packages installieren mal das Package "Microsoft Office XP Beispiele für gekapselte Komponenten für Automation Server" angehakt. Bei den Komponenten, die da angezeigt werden, ist ja OutlookApplication dabei.
Aber ich finde die Komponente nirgends wieder.
Kann mir irgendwer einen Tipp geben?
Dieter
9 von 10 Stimmen in meinem Kopf sagen ich bin nicht verrückt. Die 10. summt dazu die Melodie von Supermario Bros.
MfG Captnemo
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman
Online

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
3.906 Beiträge
 
Delphi 10.1 Berlin Professional
 
#2

AW: TOutlookApplication in D2010

  Alt 30. Jan 2011, 22:10
...jetzt wo du es sagst. Unter XE Professionell kann ich die Packages anwählen, die Komponenten werden gelistet aber tauchen in der Komponentenpalette nicht auf. Nach einem Neustart ist das Package wieder abgewählt.

Nachtrag: Ich hab mal ein wenig experimentiert. Wenn ich das Package anwähle und mit OK bestätige sind die Komponenten, welche sich dann in der "Registerkarte" Server verstecken nicht gelistet. Nach einer Suche über die Komponenten und der Rücknahme des Suchbegriffes waren sie dann gelistet. Wahrscheinlich wird die Liste aktualisiert. Jedoch nach einem Neustart ist das Package wieder abgewählt.

Geändert von haentschman (30. Jan 2011 um 22:34 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Captnemo
Captnemo

Registriert seit: 27. Jan 2003
Ort: Bodenwerder
1.126 Beiträge
 
Delphi XE4 Architect
 
#3

AW: TOutlookApplication in D2010

  Alt 30. Jan 2011, 22:32
Hm....das wär jetzt aber blöd. Ich erzeuge mit der Komponente eine E-Mail für den User. Das würde ich weiterhin gern tun. Und recht komfortabel war es auch.

Ich kann mir aber jetzt auch nicht vorstellen, das es die nicht mehr gibt? Hab schon gegoogled wie ein Blöder...nix. Und wenn's die nicht mehr so gäbe, hätten doch ganz viele die Frage danach gestellt.
Dieter
9 von 10 Stimmen in meinem Kopf sagen ich bin nicht verrückt. Die 10. summt dazu die Melodie von Supermario Bros.
MfG Captnemo
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman
Online

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
3.906 Beiträge
 
Delphi 10.1 Berlin Professional
 
#4

AW: TOutlookApplication in D2010

  Alt 30. Jan 2011, 22:34
...siehe Nachtrag

Schon komisch, daß sich noch niemand beschwert hat. Googlen ist nicht erfolgreich... Macht keiner mehr Office Anbindungen ?

Geändert von haentschman (30. Jan 2011 um 22:44 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Captnemo
Captnemo

Registriert seit: 27. Jan 2003
Ort: Bodenwerder
1.126 Beiträge
 
Delphi XE4 Architect
 
#5

AW: TOutlookApplication in D2010

  Alt 30. Jan 2011, 22:46
Die Registerkarte "Server" hab ich auch. Nur ist da keine TOutlookApplication drin. Genausowenig ein TWordAppliation, TExcelApplication und TPowerpointApplication.
Und der Compiler findet's auch net.
Dieter
9 von 10 Stimmen in meinem Kopf sagen ich bin nicht verrückt. Die 10. summt dazu die Melodie von Supermario Bros.
MfG Captnemo
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman
Online

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
3.906 Beiträge
 
Delphi 10.1 Berlin Professional
 
#6

AW: TOutlookApplication in D2010

  Alt 30. Jan 2011, 22:49
bei mir ist zumindest Zeitweise "Server" voll mit Excel, Outlook, Access etc.

Nachtrag: Egal wie ich es drehe... Wenn ich das Package entferne ist es nach dem nächsten Start abgewählt wieder da. Entferne ich es und füge es manuell wieder hinzu habe ich die Komponenten.... Nach dem nächsten Start ist das Package wieder abgewählt.

PS: in D2007 war das Package standardmäßig auch nicht ausgewählt. Jedoch bleibt die Auswahl auch nach einem Neustart erhalten.

Geändert von haentschman (30. Jan 2011 um 23:03 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Bummi
Bummi

Registriert seit: 15. Jun 2010
Ort: Augsburg Bayern Süddeutschland
3.470 Beiträge
 
Delphi XE3 Enterprise
 
#7

AW: TOutlookApplication in D2010

  Alt 30. Jan 2011, 23:03
Ich habe es bisher nicht benötigt, unter den Disables Packages entsteht jedes mal ein neuer Eintrag....wann der warum geschrieben wird
Thomas Wassermann H₂♂
Das Problem steckt meistens zwischen den Ohren
DRY DRY KISS
H₂ (wenn bei meinen Snipplets nichts anderes angegeben ist Lizenz: WTFPL)
  Mit Zitat antworten Zitat
Benutzerbild von Chemiker
Chemiker

Registriert seit: 14. Aug 2005
1.781 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#8

AW: TOutlookApplication in D2010

  Alt 31. Jan 2011, 13:58
Hallo,

habe dasselbe Problem unter Delphi XE Prof. die Komponenten stehen nicht zur Verfügung.

Bis bald Chemiker
wer gesund ist hat 1000 wünsche wer krank ist nur einen.
  Mit Zitat antworten Zitat
hhcm

Registriert seit: 12. Feb 2006
Ort: Wegberg
62 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#9

AW: TOutlookApplication in D2010

  Alt 31. Jan 2011, 14:33
Komisch, wenn ich in den Projektoptionen eines Projektes unter Packages die OutlookXP Geschichte Aktiviere, habe ich unter Server TOutlookApplication. Auch nach einem Neustart. Also da wählt sich nichts ab

Ich nutze hier Delphi 2010 Prof.
Chris
Gruß Chris
  Mit Zitat antworten Zitat
DSCHUCH

Registriert seit: 6. Jun 2007
Ort: Dresden
182 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#10

AW: TOutlookApplication in D2010

  Alt 31. Jan 2011, 19:46
also ich kenne das problem mit den aktivierenden / verschwindenden packages von delphi 7. dort war immer das problem: wenn delphi in die registry in den schlüssel "Disabled Packages" einmal etwas eingetragen hatte, konnte man sich auf den kopf stellen. man mußte den eintrag entfernen um das package wieder in die ide zu bekommen. der eintrag wurde also nicht wieder entfernt, wenn man das package wieder aktiviert.
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 3  1 23   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 16:05 Uhr.
Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2018 by Daniel R. Wolf