AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Apache Problem mit Button

Ein Thema von xxsasch4xx · begonnen am 27. Feb 2011 · letzter Beitrag vom 27. Feb 2011
Antwort Antwort
xxsasch4xx

Registriert seit: 1. Mär 2010
210 Beiträge
 
#1

Apache Problem mit Button

  Alt 27. Feb 2011, 14:30
Hallo jedes Mal wenn ich in meiner PHP Datei auf einen Button klicke dann kommt immer eine Fehlermeldung, dass das Objekt nicht gefunden wurde.
Ich benutze den Apache Server von XAMMP.


Ich habe mal ein simples Beispiel Programm in PHP geschrieben in dem ich 2 Zahlen zusammen addiere:

Code:
<html>
<head>
<title> Rechnung </title>
</head>
<body>
<form action= "<?php echo $_server['PHP.SELF']?>" method="GET">
Erste Zahl: <br>
<input type="text" name="zahl1" size ="10"><br>
Zweite Zahl: <br>
<input type="text" name ="zahl2" size="10">
<br>
<input type="submit" name="button" value="addiere">
</form>

<?php
if (isset($_GET['button']))
{
$zahl1 =$_GET['zahl1'];
$zahl2 =$_GET['zahl2'];
$zahl3 = $zahl1+$zahl2;
echo "$zahl3";
}
?>
</body>
</html>
Mein Code stimmt doch oder nicht??

In der Adressleiste steht immer irgendwas von undefinierter Variable, vielleicht hilft das damit ihr den Fehler finden könnt.
localhost/%3Cbr%20/%3E%3Cb%3ENotice%3C/b%3E:%20%20Undefined%20variable:%20_server%20in%20 %3Cb%3EC:%5Cxampp%5Chtdocs%5Chey.php%3C/b%3E%20on%20line%20%3Cb%3E6%3C/b%3E%3Cbr%20/%3E?zahl1=4&zahl2=5&button=addiere

Geändert von xxsasch4xx (28. Feb 2011 um 13:49 Uhr)
  Mit Zitat antworten Zitat
Grolle

Registriert seit: 5. Nov 2004
Ort: Coesfeld
1.268 Beiträge
 
Delphi 2010 Professional
 
#2

AW: Appache Problem mit Button

  Alt 27. Feb 2011, 14:36
//Edit kann gelöscht werden. Doppelpost wg. Stress mit Internetverbindung.


Geändert von Grolle (27. Feb 2011 um 17:09 Uhr)
  Mit Zitat antworten Zitat
Grolle

Registriert seit: 5. Nov 2004
Ort: Coesfeld
1.268 Beiträge
 
Delphi 2010 Professional
 
#3

AW: Appache Problem mit Button

  Alt 27. Feb 2011, 14:37
Hi,

probiere mal
Code:
$_SERVER['PHP_SELF']
. Generell ist das aber eine sehr unsichere Variante (XSS).

Viele Grüße ...

  Mit Zitat antworten Zitat
xxsasch4xx

Registriert seit: 1. Mär 2010
210 Beiträge
 
#4

AW: Appache Problem mit Button

  Alt 27. Feb 2011, 14:50
geht. warum unsicher?
  Mit Zitat antworten Zitat
Benutzerbild von Valle
Valle

Registriert seit: 26. Dez 2005
Ort: Karlsruhe
1.223 Beiträge
 
#5

AW: Appache Problem mit Button

  Alt 27. Feb 2011, 15:08
Hi,

erstmal: Der Webserver heißt Apache, mit einem P.
Du hast aber eher ein Problem mit PHP, nicht mit Apache.

Grolle bezog sich auf so genannte Cross-Site Scripting Lücken.
Um diese musst du dir in diesem Script aber keine Sorgen machen, denn dort ist kein XSS Problem.

Liebe Grüße,
Valentin
Valentin Voigt
BOFH excuse #423: „It's not RFC-822 compliant.“
Mein total langweiliger Blog

Geändert von Valle (27. Feb 2011 um 15:09 Uhr) Grund: Olle Tippfehler ^^
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 04:38 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf