AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken ADO-Fehler ohne Fehlermeldung?!

ADO-Fehler ohne Fehlermeldung?!

Ein Thema von p80286 · begonnen am 13. Mai 2011 · letzter Beitrag vom 13. Mai 2011
Antwort Antwort
Benutzerbild von p80286
p80286

Registriert seit: 28. Apr 2008
Ort: Stolberg (Rhl)
6.659 Beiträge
 
FreePascal / Lazarus
 
#1

ADO-Fehler ohne Fehlermeldung?!

  Alt 13. Mai 2011, 11:02
Datenbank: oracle • Version: egal • Zugriff über: ADO
Hallo zusammen,
Ich greife über ADOConnection und ADOQuery auf eine OracleDB zu.
Eine meiner Querys liefert plötzlich kein Ergebnis mehr. Wenn ich sie über SQL+ ausführe kommt allerdings sehr wohl ein Ergebnis.
Wenn ich die Anzahl der AusgabeFelder einschränke läuft es auch wieder.(sind nur strings <255)
Allerdings gibt es keine Fehlermeldung an der ich mich orientieren könnte.

Könnt Ihr mir einen Tip geben wo ich nachschauen kann?

Gruß
K-H
Programme gehorchen nicht Deinen Absichten sondern Deinen Anweisungen
R.E.D retired error detector
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
17.177 Beiträge
 
Delphi 10.4 Sydney
 
#2

AW: ADO-Fehler ohne Fehlermeldung?!

  Alt 13. Mai 2011, 11:08
Welchen Oracle-Provider? Von MS oder Oracle? Und auch aktuelle Version?
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
Benutzerbild von p80286
p80286

Registriert seit: 28. Apr 2008
Ort: Stolberg (Rhl)
6.659 Beiträge
 
FreePascal / Lazarus
 
#3

AW: ADO-Fehler ohne Fehlermeldung?!

  Alt 13. Mai 2011, 11:18
Code:
Provider=OraOLEDB.Oracle.1;Password=xxxxx;Persist Security Info=True;User ID=xxxx;Data Source=MyDB
Wie kann ich die Version heraus bekommen?

Gruß
K-H
Programme gehorchen nicht Deinen Absichten sondern Deinen Anweisungen
R.E.D retired error detector
  Mit Zitat antworten Zitat
Jumpy

Registriert seit: 9. Dez 2010
Ort: Mönchengladbach
1.733 Beiträge
 
Delphi 6 Enterprise
 
#4

AW: ADO-Fehler ohne Fehlermeldung?!

  Alt 13. Mai 2011, 11:22
Ich glaube der kommt mit dem OracleClient, oder? Was ist denn da die Version?
Ralph
  Mit Zitat antworten Zitat
Benutzerbild von p80286
p80286

Registriert seit: 28. Apr 2008
Ort: Stolberg (Rhl)
6.659 Beiträge
 
FreePascal / Lazarus
 
#5

AW: ADO-Fehler ohne Fehlermeldung?!

  Alt 13. Mai 2011, 11:26
Wenn ich mir die Installierten dateien anschaue scheint es sich um 9.2.0 zu handeln

Gruß
K-H
Programme gehorchen nicht Deinen Absichten sondern Deinen Anweisungen
R.E.D retired error detector
  Mit Zitat antworten Zitat
Jumpy

Registriert seit: 9. Dez 2010
Ort: Mönchengladbach
1.733 Beiträge
 
Delphi 6 Enterprise
 
#6

AW: ADO-Fehler ohne Fehlermeldung?!

  Alt 13. Mai 2011, 11:34
Also ich hab das auch manchmal. Oracle 9 Client aber die Datenbank ist schon 10 (die Buchstaben lass ich mal weg). Allerdings nicht unbedingt bei Tabellen mit vielen Feldern, sondern bei Tabellen mit vielen Datensätzen (>1 Mio.).
Ralph
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
17.177 Beiträge
 
Delphi 10.4 Sydney
 
#7

AW: ADO-Fehler ohne Fehlermeldung?!

  Alt 13. Mai 2011, 12:01
Wenn ich mir die Installierten dateien anschaue scheint es sich um 9.2.0 zu handeln
Aktuell ist eine 11.1er Version. Könnte also sein das hier durch Windows-Updates das ADO-Verhalten etwas geändert sein.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
Benutzerbild von p80286
p80286

Registriert seit: 28. Apr 2008
Ort: Stolberg (Rhl)
6.659 Beiträge
 
FreePascal / Lazarus
 
#8

AW: ADO-Fehler ohne Fehlermeldung?!

  Alt 13. Mai 2011, 13:04
in der letzten Woche sind allerdings keine (mir bekannten) Updates gelaufen.
(den Cursor und den / die Timeouts habe ich geändert => keine Auswirkung
ADOConnection.Errors hat keinen Inhalt)


Gruß
k-H

Ich hab mir jetzt anders beholfen, einen View, den ich verwende etwas erweitert, jetzt geht's.

Vielen Dank an alle, die versucht haben mir zu helfen.
Programme gehorchen nicht Deinen Absichten sondern Deinen Anweisungen
R.E.D retired error detector

Geändert von p80286 (13. Mai 2011 um 13:23 Uhr)
  Mit Zitat antworten Zitat
jobo

Registriert seit: 29. Nov 2010
3.072 Beiträge
 
Delphi 2010 Enterprise
 
#9

AW: ADO-Fehler ohne Fehlermeldung?!

  Alt 13. Mai 2011, 17:57
Treiber gibt's mittlerweile bis Version 11.2.irgendwas.

Bin mir nicht sicher, ob das ein Treiberproblem ist, obwohl die Client Version 9 echt nicht die tollste von Oracle ist. Sollte man vielleicht die aktuelle nehmen, wenn man Wartung & Support hat.
Wie wärs mit Download und Trial der 11er Version, ist allerdings ein fetter Brocken, vielleicht lieber gleich die Instant Client Variante nehmen. Da musst Du dann aber schon bei Download und Installation genau hinschauen.

Die Version des Clients kannst Du via SQLplus sehen, das zeigt normalerweise bei Aufruf/nach Connect Client und Serverversion an.
Alternativ kannst Du mit einer TADOConnection die
Code:
Properties.count
Properties[].name
Properties[].value
abfragen. Da ist dann wirklich die Version des OLE DB Providers dabei.

Ansonsten musst Du wohl mal ein wenig konkreter werden, was die Randbedingungen Deines Problems angeht.
Gruß, Jo
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 08:36 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz