AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Delphi 6-Programm startet nicht

Ein Thema von thion007 · begonnen am 15. Dez 2011 · letzter Beitrag vom 16. Dez 2011
Antwort Antwort
Seite 2 von 2     12
Benutzerbild von SirThornberry
SirThornberry
(Moderator)

Registriert seit: 23. Sep 2003
Ort: Bockwen
12.235 Beiträge
 
Delphi 2006 Professional
 
#11

AW: Delphi 6-Programm startet nicht

  Alt 15. Dez 2011, 17:49
Wenn kein Fehler im Debugger kommt und das Programm sich wieder beendet ist vermutlich irgendwo ein Halt platziert oder das Application.Run etc. fehlt in der Projektdatei.
Jens
Mit Source ist es wie mit Kunst - Hauptsache der Künstler versteht's
  Mit Zitat antworten Zitat
thion007

Registriert seit: 9. Nov 2011
24 Beiträge
 
#12

AW: Delphi 6-Programm startet nicht

  Alt 16. Dez 2011, 09:22
Hallo zusammen,

ich habe diverse Punkte abgeklopft:
- es werden keine nicht-existierenden oder zugriffsbeschränkten Dateien geöffnet
- wenn ich mit dem Debugger durch die Projektdatei steppe, fliege ich bei "Application.Run" raus
- Haltepunkte sind keine gesetzt

Ergibt das für irgendjemanden einen Sinn?!?

Danke und Gruß,

thion007
  Mit Zitat antworten Zitat
Benutzerbild von DeddyH
DeddyH

Registriert seit: 17. Sep 2006
Ort: Barchfeld
27.270 Beiträge
 
Delphi 11 Alexandria
 
#13

AW: Delphi 6-Programm startet nicht

  Alt 16. Dez 2011, 09:30
Hast Du das Projekt mal neu erzeugt? Sind in irgendeiner enthaltenen Unit Initialization-Abschnitte vorhanden? Werden ggf. nicht vorhandene DLLs statisch gelinkt?
Detlef
"Ich habe Angst vor dem Tag, an dem die Technologie unsere menschlichen Interaktionen übertrumpft. Die Welt wird eine Generation von Idioten bekommen." (Albert Einstein)
Dieser Tag ist längst gekommen
  Mit Zitat antworten Zitat
thion007

Registriert seit: 9. Nov 2011
24 Beiträge
 
#14

AW: Delphi 6-Programm startet nicht

  Alt 16. Dez 2011, 10:25
Hi,

yepp, Projekt habe ich neu erzeugt. Initializations sind vorhanden, hier ist aber nix Ungewöhnliches zu erkennen. Es fehlte eine Dll (srvapi32.dll), die habe ich nachinstalliert. Leider auch ohne Erfolg...

Danke und Gruß,

thion007
  Mit Zitat antworten Zitat
Benutzerbild von Bummi
Bummi

Registriert seit: 15. Jun 2010
Ort: Augsburg Bayern Süddeutschland
3.470 Beiträge
 
Delphi XE3 Enterprise
 
#15

AW: Delphi 6-Programm startet nicht

  Alt 16. Dez 2011, 10:47
irgendein nicht installiertes/registriertes OCX, statisch gelinkte DLL's ....
Thomas Wassermann H₂♂
Das Problem steckt meistens zwischen den Ohren
DRY DRY KISS
H₂ (wenn bei meinen Snipplets nichts anderes angegeben ist Lizenz: WTFPL)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 02:38 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf