AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Delphi 6-Programm startet nicht

Ein Thema von thion007 · begonnen am 15. Dez 2011 · letzter Beitrag vom 16. Dez 2011
Antwort Antwort
Seite 1 von 2  1 2   
thion007

Registriert seit: 9. Nov 2011
24 Beiträge
 
#1

Delphi 6-Programm startet nicht

  Alt 15. Dez 2011, 09:43
Delphi-Version: 6
Hallo zusammen,

ich habe hier eine Delphi6-Anwendung, die nicht aus meiner Feder stammt. Mittlerweile bin ich soweit, dass die Anwendung kompiliert wird, beim Starten jedoch wird kurz das Hauptfenster angezeigt und verschwindet sofort wieder. BreakPoints setzen hilft auch nicht...
In der Windows-Ereignisanzeige (Win7 Pro) steht für delphi32.exe ein Eintrag mit dem Ereignis "RADAR_PRE_LEAK_32".

Ist das schon mal jemandem untergekommen?

Danke und Gruß,

thion007
  Mit Zitat antworten Zitat
Klaus01
Online

Registriert seit: 30. Nov 2005
Ort: München
5.610 Beiträge
 
Delphi 10.4 Sydney
 
#2

AW: Delphi 6-Programm startet nicht

  Alt 15. Dez 2011, 13:20
Hallo,

hast Du schon versucht, ein Breakpoint (Haltepunkt) im onCreate Ereignis der Form zu setzen?
Dann mit F7 bzw. F8 durch den Code wandern bis es kracht.

Ansonsten sind Deine Angaben etwas dürfig um konkret Hilfe zu leisten.

Grüße
Klaus
Klaus
  Mit Zitat antworten Zitat
thion007

Registriert seit: 9. Nov 2011
24 Beiträge
 
#3

AW: Delphi 6-Programm startet nicht

  Alt 15. Dez 2011, 13:47
Hi Klaus,

ich würde gerne weniger dürftige Auskünfte geben...
Das mit dem Breakpoint hatte ich schon versucht... Er stoppt, ich drücke F7 und <BOOM>.
Ich habe keinerlei Möglichkeit einzugrenzen, wo das Programm wegbricht.

Macht es Sinn, das Ganze mal auf einem WinXP-Rechner zu versuchen?

Danke und Gruß,

thion007
  Mit Zitat antworten Zitat
Impulz

Registriert seit: 19. Aug 2011
Ort: Lübeck
68 Beiträge
 
Delphi 7 Professional
 
#4

AW: Delphi 6-Programm startet nicht

  Alt 15. Dez 2011, 13:49
schau mal auf deiner Form bei dem Object Inspektor, hast du das ereigniss vllt unter events bei "OnCreate" rausgelöscht oder was falsches stehen? ist mir auch schon mal passiert...
grüße
Danil
  Mit Zitat antworten Zitat
Impulz

Registriert seit: 19. Aug 2011
Ort: Lübeck
68 Beiträge
 
Delphi 7 Professional
 
#5

AW: Delphi 6-Programm startet nicht

  Alt 15. Dez 2011, 13:50
wo startest du das delphi? ist das projekt schon auf dem rechner geschrieben worden oder hast du es reingezogen? das wäre noch wichtig
Danil
  Mit Zitat antworten Zitat
thion007

Registriert seit: 9. Nov 2011
24 Beiträge
 
#6

AW: Delphi 6-Programm startet nicht

  Alt 15. Dez 2011, 13:59
Hi,

das Programm habe ich auf meinem Rechner kompiliert, die Quellen, etc. wurden auf einem anderen Rechner, vermutlich mit WinXP, erstellt.

Danke und Gruß,

thion007
  Mit Zitat antworten Zitat
thion007

Registriert seit: 9. Nov 2011
24 Beiträge
 
#7

AW: Delphi 6-Programm startet nicht

  Alt 15. Dez 2011, 14:07
Hi,

also im ObjectInspector ist "FormCreate" bei onCreate hinterlegt. Dort hatte ich auch den Breakpoint...

Danke und Gruß,

thion007
  Mit Zitat antworten Zitat
Benutzerbild von xZise
xZise

Registriert seit: 3. Mär 2006
Ort: Waldbronn
4.303 Beiträge
 
Delphi 2009 Professional
 
#8

AW: Delphi 6-Programm startet nicht

  Alt 15. Dez 2011, 14:10
Ich habe lange nicht mehr mit Delphi gearbeitet, aber es gibt doch eine Projektdatei. Dort könntest du eventuell ein Breakpoint setzen oder einen Anhaltspunkt finden, wieso das Programm nicht startet bzw. sofort wieder beendet.

Fabian
Fabian
Eigentlich hat MS Windows ab Vista den Hang zur Selbstzerstörung abgewöhnt – mkinzler
  Mit Zitat antworten Zitat
angos

Registriert seit: 26. Mai 2004
Ort: Rheine
543 Beiträge
 
Delphi 10.4 Sydney
 
#9

AW: Delphi 6-Programm startet nicht

  Alt 15. Dez 2011, 14:11
zeig doch mal ein paar Zeilen.
Einmal den Bereich wo das onCreate aufgerufen wird und das oncreate selbst.

Gruß
Ansgar
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)

Registriert seit: 29. Mai 2002
37.621 Beiträge
 
Delphi 2006 Professional
 
#10

AW: Delphi 6-Programm startet nicht

  Alt 15. Dez 2011, 14:45
Werden im OnCreate irgendwelche Dateien gelesen, die nicht existieren oder auf die du keinen Zugriff hast?
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 14:12 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf