AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Multimedia Delphi Kein Video mit tMediaplayer unter WinXP

Kein Video mit tMediaplayer unter WinXP

Ein Thema von PhilmacFLy · begonnen am 13. Feb 2012 · letzter Beitrag vom 14. Feb 2012
Antwort Antwort
Benutzerbild von PhilmacFLy
PhilmacFLy

Registriert seit: 20. Jan 2008
Ort: Nürnberg
340 Beiträge
 
FreePascal / Lazarus
 
#1

Kein Video mit tMediaplayer unter WinXP

  Alt 13. Feb 2012, 13:48
Moin DP'ler

Ich hab folgendes Problem, ich hab hier ein kleines Programm geschrieben, das mit ein paar Buttons bestimmte .wmv Dateien abspielt.
Nun hab ich in Windows 7 programmiert und es läuft soweit auch sehr gut sprich es funktioniert alles.
jetzt hab ichs auf 2 Windows XP Rechnern getestet und da läufts nicht.
Hat jemand ne Idee woran das liegen könnte?
Philipp N.
"Programmiern ist wie küssen:
Mann kan darüber reden, mann kann es beschreiben,
aber man weiss erst, was es bedeutet,
wenn man es getan hat"
  Mit Zitat antworten Zitat
Benutzerbild von s.h.a.r.k
s.h.a.r.k

Registriert seit: 26. Mai 2004
3.159 Beiträge
 
#2

AW: Kein Video mit tMediaplayer unter WinXP

  Alt 13. Feb 2012, 14:00
Fehlende Codecs? Bzw. andere Version des Codecs?

Was sagt denn der MediaPlayer unter Windows XP, wenn du das Video direkt abspielen willst?

Und was genau heißt "es läufts nichts"?
»Remember, the future maintainer is the person you should be writing code for, not the compiler.« (Nick Hodges)
  Mit Zitat antworten Zitat
Benutzerbild von DeddyH
DeddyH

Registriert seit: 17. Sep 2006
Ort: Barchfeld
27.557 Beiträge
 
Delphi 11 Alexandria
 
#3

AW: Kein Video mit tMediaplayer unter WinXP

  Alt 13. Feb 2012, 14:03
Ich denke auch, dass es am Codec liegen könnte, da es laut Wikipedia verschiedene Versionen gibt.
Detlef
"Ich habe Angst vor dem Tag, an dem die Technologie unsere menschlichen Interaktionen übertrumpft. Die Welt wird eine Generation von Idioten bekommen." (Albert Einstein)
Dieser Tag ist längst gekommen
  Mit Zitat antworten Zitat
Benutzerbild von PhilmacFLy
PhilmacFLy

Registriert seit: 20. Jan 2008
Ort: Nürnberg
340 Beiträge
 
FreePascal / Lazarus
 
#4

AW: Kein Video mit tMediaplayer unter WinXP

  Alt 13. Feb 2012, 14:31
Fehlende Codecs? Bzw. andere Version des Codecs?

Was sagt denn der MediaPlayer unter Windows XP, wenn du das Video direkt abspielen willst?

Und was genau heißt "es läufts nichts"?
Wenn ichs mim Mediaplayer so abspiel läufts.
Läuft nicht heisst die Trackbar die ich zur anzeige im Video benutzt läuft, aber ich krieg nur schwarzen Bildschirm
Philipp N.
"Programmiern ist wie küssen:
Mann kan darüber reden, mann kann es beschreiben,
aber man weiss erst, was es bedeutet,
wenn man es getan hat"
  Mit Zitat antworten Zitat
Benutzerbild von lbccaleb
lbccaleb

Registriert seit: 25. Mai 2006
Ort: Rostock / Bremen
2.037 Beiträge
 
Delphi 7 Enterprise
 
#5

AW: Kein Video mit tMediaplayer unter WinXP

  Alt 13. Feb 2012, 15:53
Ich würde in dem Fall auch erstmal von einer falschen Codec-Version ausgehen.
Um was für Video Dateien handelt es sich? Lade dir passend dafür, den neusten Codec runter, oder eines der neueren "Codec-Packs". Sollte das nicht helfen, dann meld dich nochmal^^
Martin
MFG Caleb
TheSmallOne (MediaPlayer)
Die Dinge werden berechenbar, wenn man die Natur einer Sache durchschaut hat (Blade)
  Mit Zitat antworten Zitat
Klaus01

Registriert seit: 30. Nov 2005
Ort: München
5.764 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: Kein Video mit tMediaplayer unter WinXP

  Alt 13. Feb 2012, 16:00

Wenn ichs mim Mediaplayer so abspiel läufts.
.. im TMediaplayer ist meines Wissens der mplay32 gekapselt.
Nicht der aktuelle Mediaplayer.
Versuche die wmv mal mit dem mplay32 abzuspielen.

Grüße
Klaus
Klaus
  Mit Zitat antworten Zitat
Benutzerbild von PhilmacFLy
PhilmacFLy

Registriert seit: 20. Jan 2008
Ort: Nürnberg
340 Beiträge
 
FreePascal / Lazarus
 
#7

AW: Kein Video mit tMediaplayer unter WinXP

  Alt 14. Feb 2012, 09:10
Kann leider auf meinem Rechner keinen reinen MPlayer finden.
Hab jetzt daher leider in den saueren Apfel gebissen und lass das Video per SehllExecute starten.
Trotzdem danke für eure Hilfe.
Philipp N.
"Programmiern ist wie küssen:
Mann kan darüber reden, mann kann es beschreiben,
aber man weiss erst, was es bedeutet,
wenn man es getan hat"
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 09:51 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz