AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Algorithmen, Datenstrukturen und Klassendesign Auf einer manuell erstellen Form wird nichts angezeigt

Auf einer manuell erstellen Form wird nichts angezeigt

Ein Thema von mcinternet · begonnen am 2. Jul 2012 · letzter Beitrag vom 2. Jul 2012
Antwort Antwort
mcinternet

Registriert seit: 22. Apr 2010
Ort: Odenwald
193 Beiträge
 
Delphi 10.3 Rio
 
#1

Auf einer manuell erstellen Form wird nichts angezeigt

  Alt 2. Jul 2012, 10:20
Hallo,

ich erstelle eine Form innerhalb einer Komponente manuell. Ein Button, welchen ich darauf erstelle wird problemlos angezeit, aber weder ein Memo, noch ein StaticText oder Tlabel.
Hier der Quellcode:
Code:
unit ProgInfo;

interface

uses
  Forms, Classes, StdCtrls;




  type
  TFormInfo = class(TForm)

  private
    btn_ok: TButton;
    text_info : TLabel;
    procedure btn_okClick(Sender: TObject);
  public
    constructor create(AOwner : TComponent);
    procedure anzeigen;
  end;

implementation



constructor TFormInfo.create(AOwner : TComponent);
begin
  inherited CreateNew(AOwner);
  btn_ok := TButton.Create(self); // self ist die 'eigene Adresse'
  btn_ok.Left := 192;
  btn_ok.Top := 471;
  btn_ok.Width := 49;
  btn_ok.caption := 'OK';
  btn_ok.parent := self;
  btn_ok.OnClick := btn_okClick; // Zuweisung der Ereignisbehandlung;
  text_info := Tlabel.Create(self);
  text_info.Top := 0;
  text_info.Left := 0;
  text_info.Height := 465;
  text_info.Width := 449;
  text_info.Visible := true;
  text_info.Caption := 'Info!';
end;

procedure TFormInfo.btn_okClick(Sender: TObject);
begin
  close;
end;

procedure TFormInfo.anzeigen;
begin
  text_info.Caption := 'Es sind neue Einstellungen hinzugekommen:';
end;

end.
Ich möchte auf dieser Form einfach nur einen längeren Text (Info) anzeigen.
Da das ganze in einer Komponente statt findet, baue ich dazu kein dfm.

Gruss
mc
Jörg
  Mit Zitat antworten Zitat
TBx
(Moderator)

Registriert seit: 13. Jul 2005
Ort: Stadthagen
1.807 Beiträge
 
Delphi 2007 Enterprise
 
#2

AW: Auf einer manuell erstellen Form wird nichts angezeigt

  Alt 2. Jul 2012, 10:26
Du hast vergessen, den Parent Deines Labels zu setzen.
Gruß Thomas
- Moderator Delphi-Praxis -
- Admin Delphi-Treff
- Embarcadero MVP
  Mit Zitat antworten Zitat
mcinternet

Registriert seit: 22. Apr 2010
Ort: Odenwald
193 Beiträge
 
Delphi 10.3 Rio
 
#3

AW: Auf einer manuell erstellen Form wird nichts angezeigt

  Alt 2. Jul 2012, 10:30
aaaaahhhh

vielen Dank!

Gruss

mc
Jörg
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 12:14 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf