AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Multimedia Keine Grafikausgabe mit Image1.Canvas.MoveTo... unter Win 7

Keine Grafikausgabe mit Image1.Canvas.MoveTo... unter Win 7

Ein Thema von andydp · begonnen am 3. Jul 2012 · letzter Beitrag vom 20. Sep 2012
Antwort Antwort
Seite 3 von 3     123
andydp

Registriert seit: 4. Aug 2006
36 Beiträge
 
#21

AW: Keine Grafikausgabe mit Image1.Canvas.MoveTo... unter Win 7

  Alt 20. Sep 2012, 10:35
Hi Bummi

Im Anhang findest Du die Source Datei falls es Dich interessiert.

Bin wieder ein Stück weitergekommen:
Es hat mir den Admin Rechten zu tun.
Wenn ich keine Admin Rechte besitze, erscheint beim Einlesen der Temperatur-
Daten eine Fehlermeldung betreffend Bereichsüberschreitung. Dabei wird in der
Software ein Flag zurückgesetzt (Data_ok := False
Ist dieses Flag nicht gesetzt, werden einzelne Routinen nicht ganz abgearbeite,
was zu diesem Effekt führt.
Nun muss ich noch herausfinden, was diese Bereichsüberschreitung verursacht...
Angehängte Dateien
Dateityp: pas temp_dat.pas (41,3 KB, 7x aufgerufen)
  Mit Zitat antworten Zitat
Benutzerbild von SirThornberry
SirThornberry
(Moderator)

Registriert seit: 23. Sep 2003
Ort: Bockwen
12.235 Beiträge
 
Delphi 2006 Professional
 
#22

AW: Keine Grafikausgabe mit Image1.Canvas.MoveTo... unter Win 7

  Alt 20. Sep 2012, 12:28
Das Problem ist viel mehr das du auf die Canvas zeichnest welche beim nächsten Repaint leer gemacht wird.
Richtig wäre hier eine Paintbox und im OnPaint zu zeichnen oder auf der Grafik vom TImage. Direkt auf TImage.Canvas zu zeichnen ist fast so effektiv wie direkt auf dem Desktop zu malen und sich dann zu wundern dass, das gemalte weg ist sobald eine andere Anwendung an der Stelle sich neu zeichnet.
Jens
Mit Source ist es wie mit Kunst - Hauptsache der Künstler versteht's
  Mit Zitat antworten Zitat
andydp

Registriert seit: 4. Aug 2006
36 Beiträge
 
#23

AW: Keine Grafikausgabe mit Image1.Canvas.MoveTo... unter Win 7

  Alt 20. Sep 2012, 13:40
Danke für die Antwort.
Bin mir aber nicht sicher, ob dies tatsächlich das Problem ist.
Wenn das Grafikfenster geöffnet ist, kann ich mit einem Fenster einer anderen Applikation problemlos darüber fahren, ohne das der Inhalt überschrieben wird.
Bisher hat es ja unter Windows XP / Vista die letzten Jahre auch nie Probleme gegeben. Das Phänomen trat erst mit Win 7 auf...
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 10:54 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz