AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Animierte Image Button

Ein Thema von EWeiss · begonnen am 20. Aug 2012 · letzter Beitrag vom 23. Aug 2012
Antwort Antwort
Seite 1 von 3  1 23   
EWeiss
(Gast)

n/a Beiträge
 
#1

Animierte Image Button

  Alt 20. Aug 2012, 07:57
Falls jemand lust hat kann er das mal testen.
Es geht mir Hauptsächlich darum ob diese auf euren System Flickerfrei laufen.

EDIT:
Anhang gelöscht..

gruss

Geändert von EWeiss (20. Aug 2012 um 20:45 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Jonas Shinaniganz
Jonas Shinaniganz

Registriert seit: 30. Aug 2011
249 Beiträge
 
Delphi XE5 Ultimate
 
#2

AW: Animierte Image Button

  Alt 20. Aug 2012, 08:23
Beim Ausführen der Exe, Diese Meldung:

Zitat:
Exception Exception in Modul ProgBar.exe bei 0004C21F .
Cannot create C:\Users\Jonas\AppData\Roaming\BrewIdeas\ProgComma nd.
Habs auch mal als Admin gestartet. Win7 Pro 64Bit. Gleiches Ding.
Die Leiter der Entwicklungsabteilung dreht total am Mausrad!

Geändert von Jonas Shinaniganz (20. Aug 2012 um 08:25 Uhr)
  Mit Zitat antworten Zitat
EWeiss
(Gast)

n/a Beiträge
 
#3

AW: Animierte Image Button

  Alt 20. Aug 2012, 08:26
Beim Ausführen der Exe, Diese Meldung:

Zitat:
Exception Exception in Modul ProgBar.exe bei 0004C21F .
Cannot create C:\Users\Jonas\AppData\Roaming\BrewIdeas\ProgComma n.
Habs auch mal als Admin gestartet. Win7 Pro 64Bit. Gleiches Ding.
Der Pfad sollte sein
C:\Users\Jonas\AppData\Roaming\BrewIdeas\ProgComma nd\ProgBar
Ohne das leerzeichen zwischen dem "a" und "n" wird hier nicht richtig angezeigt warum auch immer.

Dort wird dann die INI gespeichert.
Seltsam wieder so ein ding das bei mir nicht auftritt.

Danke für die Info.

gruss

Geändert von EWeiss (20. Aug 2012 um 08:29 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
16.663 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#4

AW: Animierte Image Button

  Alt 20. Aug 2012, 08:29
Seltsam wieder so ein ding das bei mir nicht auftritt.
Lösch/Benenn mal das Verzeichnis um. Ich tipp darauf das du vergisst hier das Verzeichnis anzulegen und es nur klappt weil das Verzeichnis bei dir (aufgrund alter Version/Test) schon existiert.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
EWeiss
(Gast)

n/a Beiträge
 
#5

AW: Animierte Image Button

  Alt 20. Aug 2012, 08:34
Seltsam wieder so ein ding das bei mir nicht auftritt.
Lösch/Benenn mal das Verzeichnis um. Ich tipp darauf das du vergisst hier das Verzeichnis anzulegen und es nur klappt weil das Verzeichnis bei dir (aufgrund alter Version/Test) schon existiert.
Du hast recht!
Durch die änderung in meiner LIB habe ich vergessen die erste DIR zu erstellen BrewIdeas daher geht es nicht.
Lade gleich ne fixed Version hoch.

Danke!

gruss
  Mit Zitat antworten Zitat
Benutzerbild von Sir Rufo
Sir Rufo

Registriert seit: 5. Jan 2005
Ort: Stadthagen
9.454 Beiträge
 
Delphi 10 Seattle Enterprise
 
#6

AW: Animierte Image Button

  Alt 20. Aug 2012, 08:37
Seltsam wieder so ein ding das bei mir nicht auftritt.
Lösch/Benenn mal das Verzeichnis um. Ich tipp darauf das du vergisst hier das Verzeichnis anzulegen und es nur klappt weil das Verzeichnis bei dir (aufgrund alter Version/Test) schon existiert.
Du hast recht!
Durch die änderung in meiner LIB habe ich vergessen die erste DIR zu erstellen BrewIdeas daher geht es nicht.
Lade gleich ne fixed Version hoch.

Danke!

gruss
Delphi-Referenz durchsuchenForceDirectories
Kaum macht man's richtig - schon funktioniert's
Zertifikat: Sir Rufo (Fingerprint: ‎ea 0a 4c 14 0d b6 3a a4 c1 c5 b9 dc 90 9d f0 e9 de 13 da 60)
  Mit Zitat antworten Zitat
EWeiss
(Gast)

n/a Beiträge
 
#7

AW: Animierte Image Button

  Alt 20. Aug 2012, 08:42
Jo habe ich ja
if not DirectoryExists ....
Nur das bringt mir nichts wenn ich den Pfad im Quelltext nicht erstelle.

Habe es korrigiert und dürfte jetzt laufen.

gruss
  Mit Zitat antworten Zitat
Benutzerbild von Sir Rufo
Sir Rufo

Registriert seit: 5. Jan 2005
Ort: Stadthagen
9.454 Beiträge
 
Delphi 10 Seattle Enterprise
 
#8

AW: Animierte Image Button

  Alt 20. Aug 2012, 08:55
Der Unterschied zwischen ForceDirectories und DirectoryExists ist allerdings folgender:

ForceDirectories prüft, ob es das Verzeichnis gibt (wie DirectoryExists) aber versucht auch gleichzeitig die ganzen Verzeichnisse anzulegen, wenn es diese noch nicht gibt. Und nur wenn das nicht funktioniert (warum auch immer) dann liefert es dir ein False zurück.
Kaum macht man's richtig - schon funktioniert's
Zertifikat: Sir Rufo (Fingerprint: ‎ea 0a 4c 14 0d b6 3a a4 c1 c5 b9 dc 90 9d f0 e9 de 13 da 60)
  Mit Zitat antworten Zitat
EWeiss
(Gast)

n/a Beiträge
 
#9

AW: Animierte Image Button

  Alt 20. Aug 2012, 08:58
Der Unterschied zwischen ForceDirectories und DirectoryExists ist allerdings folgender:

ForceDirectories prüft, ob es das Verzeichnis gibt (wie DirectoryExists) aber versucht auch gleichzeitig die ganzen Verzeichnisse anzulegen, wenn es diese noch nicht gibt. Und nur wenn das nicht funktioniert (warum auch immer) dann liefert es dir ein False zurück.
Sollte ich wohl noch implementieren.
Könnte mir da im nachhinein einiges an Schreibkram sparen.

Frage mich nur warum ich da nicht selbst drauf gekommen bin

Danke.

gruss

Geändert von EWeiss (20. Aug 2012 um 09:37 Uhr)
  Mit Zitat antworten Zitat
EWeiss
(Gast)

n/a Beiträge
 
#10

AW: Animierte Image Button

  Alt 20. Aug 2012, 19:29
Schade! Dachte eigentlich jemand könnte mir sagen ob die Animationen
flüssig laufen, keine CPU auslasten und die resourcen freigegeben werden. (zumindest was im Taskmanager so sichtbar ist.)

Da keine Negativen aussagen gepostet wurden gehe ich davon aus das es in Ordnung zu sein scheint.
Was ich wohl noch machen muss ist ein ImageDn zu übergeben.
Das erste Frame im Filmstrip ist nicht dafür geeignet da es zur Animations sequenz gehört und schon erhaben ist.(Schatten)


gruss
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 3  1 23   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 06:04 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf