AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

TService debuggen

Ein Thema von JRadke · begonnen am 8. Jan 2014 · letzter Beitrag vom 8. Jan 2014
Antwort Antwort
JRadke

Registriert seit: 23. Feb 2006
Ort: Hamburg
13 Beiträge
 
#1

TService debuggen

  Alt 8. Jan 2014, 15:14
Ich habe mir mit Delphi XE3 unter Windows 7 zum Testen einen TService mit minimaler Funktionalität erstellt und versuche nun vergeblich, diesen auch zu debuggen.
Der Dienst ist installiert und läuft auch tadellos. Nach allem, was ich bisher gelesen habe, wird zum Debuggen in der IDE "Start | Mit Prozess verbinden" aufgerufen, aber hier tauchen in der Liste nur einige wenige Prozesse auf, und meiner ist nicht mit dabei, obwohl er nachweislich läuft.
Weiß jemand, was zu tun ist?
Danke vorab.
Jürgen
  Mit Zitat antworten Zitat
Mikkey

Registriert seit: 5. Aug 2013
265 Beiträge
 
#2

AW: TService debuggen

  Alt 8. Jan 2014, 15:17
Es gibt eine Checkbox "Systemprozesse anzeigen".

Es ist aber möglich, dass das Debuggen trotzdem nicht funktioniert. In solchen Fällen helfe ich mir, indem ich eine normale Anwendung schreibe, in dem der TService als unit eingebunden wird.
  Mit Zitat antworten Zitat
Benutzerbild von Bummi
Bummi

Registriert seit: 15. Jun 2010
Ort: Augsburg Bayern Süddeutschland
3.470 Beiträge
 
Delphi XE3 Enterprise
 
#3

AW: TService debuggen

  Alt 8. Jan 2014, 15:18
Delphi als Administrator (rechter Mausklick) ausführen. Im Dienst vorzugsweise ein Delay im Start einbauen um bestimmte Breakpoints zu erreichen.
Thomas Wassermann H₂♂
Das Problem steckt meistens zwischen den Ohren
DRY DRY KISS
H₂ (wenn bei meinen Snipplets nichts anderes angegeben ist Lizenz: WTFPL)
  Mit Zitat antworten Zitat
JRadke

Registriert seit: 23. Feb 2006
Ort: Hamburg
13 Beiträge
 
#4

AW: TService debuggen

  Alt 8. Jan 2014, 15:40
Danke für die Antworten.
Delphi "Als Administrator ausführen" hat geholfen, ich kann meinen Prozess nun sehen.

Das gehört vielleicht nicht hier her, aber gibt es denn einen Unterschied, ob ich als Administrator angemeldet bin oder ob ich Delphi als Administrator starte?

Gruß
Jürgen
  Mit Zitat antworten Zitat
Benutzerbild von Zacherl
Zacherl

Registriert seit: 3. Sep 2004
4.629 Beiträge
 
Delphi 10.2 Tokyo Starter
 
#5

AW: TService debuggen

  Alt 8. Jan 2014, 21:19
Klar, ab Vista werden alle Programme standardmäßig selbst auf Administratorkonten nur noch mit eingeschränkten Rechten gestartet. Stichwort: Benutzerkontensteuerung, UAC. Mit dem manuellen "Start als Administrator" erhält Delphi erst wirklich Administratorrechte.
Projekte:
- GitHub (Profil, zyantific)
- zYan Disassembler Engine ( Zydis Online, Zydis GitHub)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 22:23 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf