AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke Datasnap/DSAuthenticationManager User immer 'a'

Datasnap/DSAuthenticationManager User immer 'a'

Ein Thema von christophspaeth · begonnen am 23. Dez 2014 · letzter Beitrag vom 7. Jan 2015
Antwort Antwort
christophspaeth

Registriert seit: 7. Mär 2008
73 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#1

Datasnap/DSAuthenticationManager User immer 'a'

  Alt 23. Dez 2014, 12:39
Hallo,

ich bin gerade dabei zu evaluieren, ob sich der DataSnap REST-Server für meine Zwecke als Backend für eine kleine Webanwendung eignet. (Delphi XE2 Enterprise)

Ich habe jetzt das Projekt aus dem Wizard als stand-alone vcl application (zum einfach debuggen) erstellt und auf der dritten Seite die Punkte "Authentication" ohne den Unterpunkt "Authorization" angewählt (valider Benutzer oder nicht reicht mir, ich brauche keine Rollen), und "Server Methods Class" inkl der beiden Unterpuntke angewählt gelassen.

Wenn ich jetzt in der funktion TWebModule1.DSAuthenticationManager1UserAuthentica te auf die Parameter User und Password schaue (Debugger, Log, ShowMessage) enthaten beide Parameter nur 'a', egal was ich im Browser eingebe.

Muss ich da noch irgendwo etwas einstellen/implementieren oder ist das ein Bug im DataSnap?
Oder gibt es vielleicht sowieso Gründe, die gegen einen Einsatz von DataSnap REST im Allgemeinen oder dem AuthenticationManager im Speziellen sprechen?

Grüße und frohe Feiertage!
Christoph Späth
  Mit Zitat antworten Zitat
christophspaeth

Registriert seit: 7. Mär 2008
73 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#2

AW: Datasnap/DSAuthenticationManager User immer 'a'

  Alt 7. Jan 2015, 13:24
Hallo und ein frohes Neues Jahr!

Anscheinend hatte ich es irgendwie geschafft gehabt, dass sich da was bei den DCUs "verklemmt".

Nachdem ich jetzt nochmal mit Debug-DCUs schauen wollte wo die falschen Daten herkommen, haben die Daten plötzlich gestimmt - auch nach dem Ausschalten der DebugDCUs.
Und ja, eigentlich mache ich genau wegen sowas so gut wie immer ein "Build" und nicht nur "Compile" im Delphi.
Christoph Späth
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 09:22 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf