AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Win32/Win64 API (native code) Fehler beim Einfügen einer Zeile in RichEdit.

Fehler beim Einfügen einer Zeile in RichEdit.

Ein Thema von fredat · begonnen am 17. Jan 2015
Antwort Antwort
fredat

Registriert seit: 7. Okt 2014
1 Beiträge
 
#1

Fehler beim Einfügen einer Zeile in RichEdit.

  Alt 17. Jan 2015, 13:18
Hallo!

Füge einen Memorystrem in ein RichEdit ein(von Robocopy aus der Konsole).
Dabei kommt folgende Meldung
'Fehler beim Einfügen einer Zeile in RichEdit.'
Bekomme diese Meldung von RichEdit2.dll(glaube ich), denn da werden bevor der
String ins RichEdit eingefügt wird alle CRLF nach CR geändert bzw. alle LF entfernt.

Meine bisherigen Untersuchungen:
Wenn vor #0(Streamende) die Zeichen [#13,#13,#10,#0] kommen tritt die Fehlermeldung auf.
Ändere ich es auf [#13,#13#,#0] also das #10(LF) vor dem #0 ist alles Okay

Meine FRAGE!
Wie setzte ich es am besten um das letzt #10 vor #0 in ein #0 zu ändern...
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 19:18 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf