AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Cross-Platform-Entwicklung Fehler beim Upload in AppStore iOS9 mit Delphi XE10

Fehler beim Upload in AppStore iOS9 mit Delphi XE10

Ein Thema von equitania · begonnen am 20. Sep 2015 · letzter Beitrag vom 27. Sep 2015
Antwort Antwort
Seite 1 von 3  1 23   
equitania

Registriert seit: 20. Sep 2015
5 Beiträge
 
#1

Fehler beim Upload in AppStore iOS9 mit Delphi XE10

  Alt 20. Sep 2015, 17:50
Hallo,

wenn ich meine App mittels Application Loader 3 hoch lade, bekomme ich nach der Prüfung die Fehler:

ERROR ITMS-90507: "Missing Info.plist valua. A value for the kay DTPlatformName in bundle .. is required."
ERROR ITMS-90094: "Invalid Launch Image - Your app contains a launch image with a size modifier that is only supported for apps built with iOS 6.0 SDK or later."
ERROR ITMS-90534: "Inavalid Toochain. News and app updates must be built with the public (GM) version of Xcode 6 or later, and iOS 8 SDK or ...

Ich verwende XCode 7 unter Mac OSX 10.11.1
  Mit Zitat antworten Zitat
Jef

Registriert seit: 8. Sep 2013
Ort: München
40 Beiträge
 
Delphi 10.3 Rio
 
#2

AW: Fehler beim Upload in AppStore iOS9 mit Delphi XE10

  Alt 20. Sep 2015, 19:53
Hier steht wie der erste Fehler zu lösen ist:
http://community.embarcadero.com/ind...-ios-app-store
Sebastian
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
7.834 Beiträge
 
Delphi XE4 Professional
 
#3

AW: Fehler beim Upload in AppStore iOS9 mit Delphi XE10

  Alt 21. Sep 2015, 03:18
Hallo,
bei Fehler 2 und 3 muss wohl XCode bzw. das SDK aktualisiert werden..

Heiko
Heiko
  Mit Zitat antworten Zitat
equitania

Registriert seit: 20. Sep 2015
5 Beiträge
 
#4

AW: Fehler beim Upload in AppStore iOS9 mit Delphi XE10

  Alt 21. Sep 2015, 09:16
Hallo,

habe alle Tipps ausprobiert, aber ohne Erfolg siehe Screenshots.

Anbei Screenshots meiner Einstellungen.
Miniaturansicht angehängter Grafiken
errors.jpg   sdk_otions.jpg   project_options.jpg  
  Mit Zitat antworten Zitat
bra

Registriert seit: 20. Jan 2015
710 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#5

AW: Fehler beim Upload in AppStore iOS9 mit Delphi XE10

  Alt 21. Sep 2015, 09:33
Das klingt als hättest du noch eine alte Version von XCode installiert. Eventuell musst du auch in den Xcode-Einstellungen nur die Commandline-Tools auf eine aktuelle Version umstellen?
  Mit Zitat antworten Zitat
equitania

Registriert seit: 20. Sep 2015
5 Beiträge
 
#6

AW: Fehler beim Upload in AppStore iOS9 mit Delphi XE10

  Alt 21. Sep 2015, 10:25
Nein - alles steht auf XCode 7.0 siehe Anlage.
Miniaturansicht angehängter Grafiken
xcode.jpg  
  Mit Zitat antworten Zitat
Benutzerbild von Sir Rufo
Sir Rufo

Registriert seit: 5. Jan 2005
Ort: Stadthagen
9.454 Beiträge
 
Delphi 10 Seattle Enterprise
 
#7

AW: Fehler beim Upload in AppStore iOS9 mit Delphi XE10

  Alt 21. Sep 2015, 12:14
Was ich nicht verstehe ist der Wert 9.0 bei CFBundleInfoDictionaryVersion.

Default steht der bei einem neuen Projekt auf 7.1 was laut apple Doc auch nicht richtig ist:
Zitat:
CFBundleInfoDictionaryVersion

CFBundleInfoDictionaryVersion (String - iOS, OS X) identifies the current version of the property list structure. This key exists to support future versioning of the information property list file format. Xcode generates this key automatically when you build a bundle and you should not change it manually. The value for this key is currently 6.0.
Kaum macht man's richtig - schon funktioniert's
Zertifikat: Sir Rufo (Fingerprint: ‎ea 0a 4c 14 0d b6 3a a4 c1 c5 b9 dc 90 9d f0 e9 de 13 da 60)
  Mit Zitat antworten Zitat
bra

Registriert seit: 20. Jan 2015
710 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#8

AW: Fehler beim Upload in AppStore iOS9 mit Delphi XE10

  Alt 21. Sep 2015, 12:25
Ich denke da ist die Doku von Apple einfach nicht aktuell. Das ist unter XE8 auch schon 7.1, da gibt es auch einen QC-Eintrag dazu, dass es mind. 7.1 sein muss.
  Mit Zitat antworten Zitat
Benutzerbild von Sir Rufo
Sir Rufo

Registriert seit: 5. Jan 2005
Ort: Stadthagen
9.454 Beiträge
 
Delphi 10 Seattle Enterprise
 
#9

AW: Fehler beim Upload in AppStore iOS9 mit Delphi XE10

  Alt 21. Sep 2015, 12:31
Ich denke da ist die Doku von Apple einfach nicht aktuell. Das ist unter XE8 auch schon 7.1, da gibt es auch einen QC-Eintrag dazu, dass es mind. 7.1 sein muss.
Ein frisch mit Xcode 7 erstellte Anwendung schreibt da immer eine 6.0 rein ... however
Kaum macht man's richtig - schon funktioniert's
Zertifikat: Sir Rufo (Fingerprint: ‎ea 0a 4c 14 0d b6 3a a4 c1 c5 b9 dc 90 9d f0 e9 de 13 da 60)
  Mit Zitat antworten Zitat
equitania

Registriert seit: 20. Sep 2015
5 Beiträge
 
#10

AW: Fehler beim Upload in AppStore iOS9 mit Delphi XE10

  Alt 21. Sep 2015, 13:27
Hallo,

ich habe es mit 6.0 und 7.1 getestet ohne Erfolg.
Als Versuch hatte ich auch mal 9.0 eingetragen.
Macht aber alles keinen Unterschied.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 20:40 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf