AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Programmieren allgemein Es konnten nicht alle Netzlaufwerke wiederhergestellt werden

Es konnten nicht alle Netzlaufwerke wiederhergestellt werden

Ein Thema von waldforest · begonnen am 6. Aug 2016 · letzter Beitrag vom 9. Aug 2016
Antwort Antwort
Seite 1 von 2  1 2   
waldforest

Registriert seit: 8. Mai 2005
366 Beiträge
 
Delphi XE3 Enterprise
 
#1

Es konnten nicht alle Netzlaufwerke wiederhergestellt werden

  Alt 6. Aug 2016, 14:47
Hallo,
ich habe in meinen Netzwerk auf einem Rechner ein Laufwerk freigegeben, auf das verschieden Rechner zugreifen.
Nun ist es so, dass wenn die "Clients" früher gestartet werden als der Rechner auf den Zugegriffen werden soll der Hinweis "Es konnten nicht alle Netzlaufwerke wiederhergestellt werden" erscheint.
Im Explorer ist die Verbindung mit einem roten Kreuz markiert. Wenn man jetzt über diesen Weg auf das Verzeichnis klickt, wird die Verbindung hergestellt.

Zu meiner Frage: was passiert in diesem Moment ?, Wie kann ich diese Aktion z.B. über einen Batch-File, oder ein kleine Anwendung simulieren.
Ggf. in meine Anwendung integrieren, diese Verbindung prüft, bei Bedarf aktiviert.
Ich möchte ungern bei jedem Programmstart die Netzwerkverbindungen löschen und neu einrichten um sicher zu stellen, dass diese Verbindung besteht.
mfg wf

Geändert von waldforest ( 6. Aug 2016 um 15:04 Uhr)
  Mit Zitat antworten Zitat
jobo

Registriert seit: 29. Nov 2010
2.978 Beiträge
 
Delphi 2010 Enterprise
 
#2

AW: Es konnten nicht alle Netzlaufwerke wiederhergestellt werden

  Alt 6. Aug 2016, 15:13
Ich würde sagen, es erfolgt ein Zugriff.
Ein
Code:
dir laufwerk:/<freigabe>
sollte ausreichen, das nachzustellen.

Die Frage wäre allerdings wofür? Außer das das rote Dinx verwschwindet geschieht nichts.
Gruß, Jo
  Mit Zitat antworten Zitat
waldforest

Registriert seit: 8. Mai 2005
366 Beiträge
 
Delphi XE3 Enterprise
 
#3

AW: Es konnten nicht alle Netzlaufwerke wiederhergestellt werden

  Alt 6. Aug 2016, 15:47
Danke, passt

Hintergrund ist, dass ich aus einer DOS-Anwendung auf ein freigegebenes Verzeichnis zugreifen muss.
Aus der DOS-Anwendung wird leider der Anstoß zur Aktivierung (Reconnect) nicht gegeben.
mfg wf
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
16.940 Beiträge
 
Delphi 10.4 Sydney
 
#4

AW: Es konnten nicht alle Netzlaufwerke wiederhergestellt werden

  Alt 6. Aug 2016, 16:04
Danke, passt

Hintergrund ist, dass ich aus einer DOS-Anwendung auf ein freigegebenes Verzeichnis zugreifen muss.
Aus der DOS-Anwendung wird leider der Anstoß zur Aktivierung (Reconnect) nicht gegeben.
Wirklich noch DOS-Anwendung?
Bei einer Consolen-Anwendung würde ich das Share direkt verwenden statt mich auf den Laufwerksbuchstaben verlassen.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
waldforest

Registriert seit: 8. Mai 2005
366 Beiträge
 
Delphi XE3 Enterprise
 
#5

AW: Es konnten nicht alle Netzlaufwerke wiederhergestellt werden

  Alt 7. Aug 2016, 09:56
Tja,es gibt noch alte bisher gut funktionierende Anwendungen welche auf DOS-Basis (Clipper) laufen.

leider funktioniert das mit dem DIR doch nicht
Habe es nun mit folgender Batch-Lösung hinbekommen.

Aufruf erfolgt mit Laufwerksbuchstabe als Parameter

Code:
echo off
:start
if not exist %1: goto start1
if exist %1: goto OK

:start1
start /min explorer %1:
echo warte auf Verbindung zu Laufwerk %1.
timeout 2
taskkill /im explorer.exe
Goto start

if exist %1: goto OK

:OK
echo Das Laufwerk %1 ist vorbunden !!!
mfg wf

Geändert von waldforest ( 7. Aug 2016 um 11:32 Uhr)
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
3.354 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: Es konnten nicht alle Netzlaufwerke wiederhergestellt werden

  Alt 7. Aug 2016, 22:09
Zitat:
Die Frage wäre allerdings wofür? Außer das das rote Dinx verwschwindet geschieht nichts.
Ich habe bei einer ähnlichen Rechnerkonstellation folgendes Problem:

- solange das Netzlaufwerk nicht verbunden ist (rotes Kreuz)
- Ich Öffne mit einem Programm den FileOpen Dialog --> schon stürzt es ab ohne Meldung
(das macht z.B. auch die RadStudio IDE wenn ich FileOpen öffne, aber auch viele Andere)
- wohlgemerkt: Öffnen des Dialoges reicht, sonst muss man nichts weiter machen
- es hilft ein wenig wenn man die Maus sofort beim Öffnen schnell weit wegfährt

- hat man aber mit dem Explorer einmal die Verbindung angeclickt, so dass das rote Kreuz weg ist
- schon können alle Programme wunderbar damit arbeiten und FileOpen öffnen

Also Gründe dafür fände ich schon ...

Rollo
  Mit Zitat antworten Zitat
Benutzerbild von BeBored
BeBored

Registriert seit: 2. Jun 2004
Ort: Cremlingen
90 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#7

AW: Es konnten nicht alle Netzlaufwerke wiederhergestellt werden

  Alt 8. Aug 2016, 08:31
Ich kenne das Problem und habe eine Batch Datei die im Autostart liegt.
Dort werden die Netzlaufwerke entfern, ein paar Sekunden Pause und dann wieder hinzugefügt.
Matthias
Wer nichts wagt der nichts verliert.
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)

Registriert seit: 29. Mai 2002
37.621 Beiträge
 
Delphi 2006 Professional
 
#8

AW: Es konnten nicht alle Netzlaufwerke wiederhergestellt werden

  Alt 8. Aug 2016, 08:46
Habe ich auch. Zwei Wochen hat es ohne geklappt, dann auf einmal nicht mehr.

@ECHO OFF
Echo Auf Netzwerkverbindung warten...
rem NAS mit Ping aufwecken und warten
ping 192.168.2.11 -n 8 >nul
if %ERRORLEVEL% NEQ 0 goto ERROR_NAS

rem alles trennen
echo VC Container "Dokumente" trennen...
veracrypt /d /l y /f /q >nul
echo Netzlaufwerk "\\herakles\Michael" trennen...
net use z: /d /yes >nul

rem neu verbinden
echo Netzlaufwerk "\\herakles\Michael" verbinden...
rem Namen an Netzlaufwerk vergeben
reg add HKCU\Software\Microsoft\Windows\CurrentVersion\Exp lorer\MountPoints2\##herakles#home /v _LabelFromReg /t REG_SZ /f /d "Daten"
net use z: \\herakles\home /user:Michael passwort /PERSISTENT:no >nul
if %ERRORLEVEL% NEQ 0 goto ERROR_CON

rem VeraCrypt Container einbinden, wenn gewünscht
echo.
choice /M "VC Container 'Dokumente' einbinden?"
if %ERRORLEVEL% == 1 goto MOUNT_VC
if %ERRORLEVEL% == 2 goto DONE
:MOUNT_VC
echo VC Container "Dokumente" einbinden...
set /P pw="Passwort: "
veracrypt /v z:\Dokumente /l y /p %pw% /q
if %ERRORLEVEL% NEQ 0 goto ERROR_VC
goto DONE

rem Fehlerbehandlung
:ERROR_NAS
echo Fehler: Herakles nicht erreichbar!
pause
exit

:ERROR_CON
pause
exit

:ERROR_VC
pause
exit

ONE
exit

Code-Tags funktionieren irgendwie nicht.
Michael
Ein Teil meines Codes würde euch verunsichern.

Geändert von Luckie ( 8. Aug 2016 um 08:52 Uhr)
  Mit Zitat antworten Zitat
waldforest

Registriert seit: 8. Mai 2005
366 Beiträge
 
Delphi XE3 Enterprise
 
#9

AW: Es konnten nicht alle Netzlaufwerke wiederhergestellt werden

  Alt 8. Aug 2016, 11:47
Alles sehr merkwürdig,
wüsste mal gerne was Microsoft da wieder geändert hat.

Interessant ist, dass wenn ein Rechner im Netzwerk auf das Serverlaufwerk aktiviert hat, die anderen keine Probleme haben.

Kann es sein, dass es irgend etwas mit der Namensauflösung des "Severs" zu tun hat ?
mfg wf
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
3.354 Beiträge
 
Delphi 10.4 Sydney
 
#10

AW: Es konnten nicht alle Netzlaufwerke wiederhergestellt werden

  Alt 8. Aug 2016, 18:57
Neu ist das nicht, das gibt es so seit Win8.1 womögloch auch früher.

Aber ich vermute das es bei den 64-Bit Windows Versionen auftritt, allerdings habe ich kaum
noch 32-Bit um das mal richtig zu Testen.

Wie gesagt, mir reicht das manuelle anclicken im Moment, weil ich es in der Konfiguration selten benutze.
Bisher war mit das testen und bauen einer Batch-Datei mehr Arbeit als das anclicken.
Weil ich mit TotalCommander sowieso meist auf dem richtigen Laufwerk stehe ist es mit einem CLick refresht.

Rollo
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 00:30 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf