AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Win32/Win64 API (native code) LoadResource lädt 2 Resourcen statt nur einer / falsches Encoding

LoadResource lädt 2 Resourcen statt nur einer / falsches Encoding

Ein Thema von RandomDD · begonnen am 19. Aug 2016 · letzter Beitrag vom 20. Aug 2016
Antwort Antwort
Seite 3 von 3     123
Sailor

Registriert seit: 20. Jul 2008
Ort: Balaton
112 Beiträge
 
Delphi 2010 Professional
 
#21

AW: LoadResource lädt 2 Resourcen statt nur einer / falsches Encoding

  Alt 20. Aug 2016, 13:21
Nein, Uwe, das ist kein Einprügeln auf Emba. Die haben einen Ressourcen-Editor zur Verfügung zu stellen, mit dessen Hilfe ich korrekte Ressource-Dateien erstellen kann, ohne mich um den Kram dahinter kümmern zu müssen. Und das, ohne mich mit irgendwelchen kryptischen Parametern befassen zu müssen. Die Zeiten der Freaks oder Nerds sollten vorbei sein. Jedenfalls ist das meine Meinung.
  Mit Zitat antworten Zitat
nahpets
(Gast)

n/a Beiträge
 
#22

AW: LoadResource lädt 2 Resourcen statt nur einer / falsches Encoding

  Alt 20. Aug 2016, 13:28
Wenn ich mal 'ne Resourcendatei brauche, dann schreib' ich die mit dem Editor der IDE. Was brauche ich denn da noch für 'nen weiteren Editor, den mir Emba zur Verfügung stellen muss?
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
9.716 Beiträge
 
Delphi 11 Alexandria
 
#23

AW: LoadResource lädt 2 Resourcen statt nur einer / falsches Encoding

  Alt 20. Aug 2016, 13:32
Die haben einen Ressourcen-Editor zur Verfügung zu stellen, mit dessen Hilfe ich korrekte Ressource-Dateien erstellen kann, ohne mich um den Kram dahinter kümmern zu müssen.
Aber genau das tut er ja auch! Das Problem war ja lediglich, daß die Resource im Programm selbst als ANSI interpretiert wurde, aber als HTML-Datei in UTF-8 vorlag. Insofern hat der Resource-Compiler schon alles richtig gemacht und die Resource (auch ohne weitere Schalter und Einstellungen oder irgendwelchen Nerd-Zauber) korrekt aufbereitet. Lediglich der Programmierer hat die Resource im Code falsch interpretiert.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
RandomDD

Registriert seit: 11. Aug 2016
42 Beiträge
 
#24

AW: LoadResource lädt 2 Resourcen statt nur einer / falsches Encoding

  Alt 20. Aug 2016, 14:07
Korrekt, ich habe alles mögliche nur vertauscht und es nicht gesehen.
  Mit Zitat antworten Zitat
EWeiss
(Gast)

n/a Beiträge
 
#25

AW: LoadResource lädt 2 Resourcen statt nur einer / falsches Encoding

  Alt 20. Aug 2016, 14:16
Korrekt, ich habe alles mögliche nur vertauscht und es nicht gesehen.
Ich denke wohl eher du hast es nicht gewusst..
nicht immer funktioniert ein Copy/Paste.

Aber man kann nur bei lernen.

gruss
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 02:30 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf