AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Projekte AnimatePNG

AnimatePNG

Ein Thema von EWeiss · begonnen am 20. Mär 2017 · letzter Beitrag vom 8. Jun 2018
Antwort Antwort
Seite 14 von 16   « Erste     4121314 1516   
EWeiss
Projekt entfernt..

Geändert von EWeiss (24. Jul 2019 um 04:48 Uhr)
 
Delphi-Laie

 
Delphi 10.1 Berlin Starter
 
#131
  Alt 31. Mär 2017, 17:05
Zitat:
"AnimatePNG.exe hat ein Problem festgestellt
Hatten wir schon .. habe es nochmal aktualisiert.
Es hat sich aber leider nichts geändert, geschweige denn, verbessert. Das / ein Problem, das von Windows leider in keiner Weise konkretisiert wird, ist immer noch vorhanden.

Quelltext ist dabei.
Ab welchem Delphi compiliert das denn? Wegen dieser massiven Probleme vermute ich ein ziemlich aktuelles Delphi.

An sich ein akzeptables Angebot, nur bezweifele ich, als Außenstehender das Problem in vertretbarer Zeit zu lösen.

Geändert von Delphi-Laie (31. Mär 2017 um 17:08 Uhr)
  Mit Zitat antworten Zitat
EWeiss
 
#132
  Alt 31. Mär 2017, 17:15
Zitat:
Es hat sich aber leider nichts geändert, geschweige denn, verbessert. Das / ein Problem, das von Windows leider in keiner Weise konkretisiert wird, ist immer noch vorhanden.
lösch doch einfach mal die Ini.

user/deinname/appdata/roaming/BrewIdeas/AnimatePNG

Zitat:
Ab welchem Delphi compiliert das denn?
D2010

gruss
  Mit Zitat antworten Zitat
Delphi-Laie

 
Delphi 10.1 Berlin Starter
 
#133
  Alt 31. Mär 2017, 17:28
lösch doch einfach mal die Ini.
Yo, jetzt funktioniert es, danke!
  Mit Zitat antworten Zitat
Delphi-Laie

 
Delphi 10.1 Berlin Starter
 
#134
  Alt 31. Mär 2017, 17:32
So, das nächste Problemchen: Drücke ich auf den Beenden-Knopf und dann auf "no", friert das Programm ein.

Edit: Zumindest wird man diese Nachfrage nicht wieder los.

Edit 2: Auch den Dialog, wenn man auf "APNG" klickt, wird man mit "no" nicht mehr los.

Geändert von Delphi-Laie (31. Mär 2017 um 17:42 Uhr)
  Mit Zitat antworten Zitat
EWeiss
 
#135
  Alt 31. Mär 2017, 17:44
So, das nächste Problemchen: Drücke ich auf den Beenden-Knopf und dann auf "no", friert das Programm ein.

Edit: Zumindest wird man diese Nachfrage nicht wieder los.
XP? Wenn ich mich nicht irre.
Wenn dem so ist/war da kann ich leider nichts tun.

Das Programm wurde unter W7 entwickelt und manche Dinge die hier laufen müssen das nicht zwangsweise auch unter XP tun.
Da muss nur eine Api fehlen oder wie unter W7 kein Aero vorhanden sein dann kann es zu Problemen kommen.

Meine DLL ist nun mal auf Aero angewiesen das sagt der Name schon SK_Aero.dll
SK = Skinengine
AERO = DWM ist nötig.

Es kann unter XP laufen aber Garantien zwecks CPU Auslastung .. Ausführung usw. gibt es kein.
Es ist nicht das Programm es ist die Umgebung in der es läuft.

Ok nochmal ein Pic mehr kann ich dazu nicht mehr sagen. (W7 ohne Aero)
Nur eins noch:
Alleine die Speicherverwaltung unter XP macht schon ärger die Animation im Shot 203 MB im Speicher kann von XP nicht gelesen werden.
Es wird beim Abspielen nur das 1 Frame gerendert die anderen bleiben leer.
Nein! Keine Sorge bei der nächsten Animation wird der Speicher korrekt freigegeben.

gruss

Geändert von EWeiss (11. Jul 2019 um 15:47 Uhr)
  Mit Zitat antworten Zitat
Ghostwalker

 
Delphi 10.3 Rio
 
#136
  Alt 31. Mär 2017, 21:10
Unter XP kannst du das Knicken. AERO gabs erst ab Vista (also eine Version später).

Man bekommts zwar teilweise zum laufen, aber wirklich sauber ist was anderes
Uwe
  Mit Zitat antworten Zitat
EWeiss
 
#137
  Alt 1. Apr 2017, 05:16
Unter XP kannst du das Knicken. AERO gabs erst ab Vista (also eine Version später).

Man bekommts zwar teilweise zum laufen, aber wirklich sauber ist was anderes
Ist ja auch nicht mehr das jüngste. (So wie ich) LOL.
Hier läuft es auch mit ausgeschalteten Aero.
Ich habe ja XP auf der anderen Platte muss halt nur vom anderen Bootlaufwerk hochfahren und habe es dort getestet aber wie gesagt es läuft dort nicht.

Weder mit der DLL Version noch das in der EXE implementierte.

Habe APNG aus der EXE herausgenommen weil die Optimierung doch einiges an Zeit in Anspruch genommen hat.
Es muss nicht jeder meine Tricks kennen.

EDIT:
Ich könnte auch die Auslastung der Gif Animationen auf 0% CPU bringen aber dann müsste ich auch diese aus der EXE herausnehmen.
Daher denke ich, ist es besser ihr versucht euch selbst daran.
Was ich nur sagen kann es geht definitiv.

gruss

Geändert von EWeiss ( 1. Apr 2017 um 19:04 Uhr)
  Mit Zitat antworten Zitat
EWeiss
 
#138
  Alt 4. Apr 2017, 11:06
Neue Version..
Infos siehe oben.

gruss
  Mit Zitat antworten Zitat
Benutzerbild von Sherlock
Sherlock

 
Delphi 10.4 Sydney
 
#139
  Alt 4. Apr 2017, 11:23
Also ich kann mir ein animiertes Gif ansehen, daß im Gif-Ordner liegt, aber die Konvertierung klappt nicht. Fehlermeldung:
---------------------------
GIFtoAPNG
---------------------------
\\Mac\Home\Downloads\AnimatePNG(1)\AnimatePNG\imag es\Gif\nyzsQKk.pngFrame count =0
---------------------------
OK
---------------------------

Das kleine Fensterchen "GifToAPNG" meldet Framecount=68, Value=68 und Status=Ok

Dann hab ich dieses hier (http://i826.photobucket.com/albums/z...APNG-Glass.png) in den png-Ordner kopiert, und es wird gemeldet, es sei kein Bild da.


Achja: Immer noch Win10 Prof auf einem Mac via Parallels.

Sherlock

Geändert von Sherlock ( 4. Apr 2017 um 11:30 Uhr)
  Mit Zitat antworten Zitat
EWeiss
 
#140
  Alt 4. Apr 2017, 11:28
Also ich kann mir ein animiertes Gif ansehen, daß im Gif-Ordner liegt, aber die Konvertierung klappt nicht. Fehlermeldung:
---------------------------
GIFtoAPNG
---------------------------
\\Mac\Home\Downloads\AnimatePNG(1)\AnimatePNG\imag es\Gif\nyzsQKk.pngFrame count =0
---------------------------
OK
---------------------------

Das kleine Fensterchen "GifToAPNG" meldet Framecount=68, Value=68 und Status=Ok

Achja: Immer noch Win10 Prof auf einem Mac via Parallels.

Sherlock
Kannst mal bitte hochladen das GIF?
Hmm komischer pfad "imag es"

gruss
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 07:55 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf