AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

XE7 und Andorid 6 Gerät

Ein Thema von Kralle · begonnen am 16. Apr 2017 · letzter Beitrag vom 20. Apr 2017
Antwort Antwort
Seite 1 von 2  1 2   
Kralle

Registriert seit: 31. Okt 2004
Ort: Bremerhaven
349 Beiträge
 
Delphi XE7 Professional
 
#1

XE7 und Andorid 6 Gerät

  Alt 16. Apr 2017, 18:44
OS: Windows 8.1
SDK 25.2.5
SDK-API-Level 23
Java JDK: 1.8.0_121

Zielgerät: "Trekstor SurfTab breeze 9.6 quad 3G" mit "Android 6.0.1"

Moin,
das Tablet ist eingerichtet und wird auch von "Delphi XE 7 Pro + Mobil AddOn-Pack" erkannt.
Wenn ich nun einen neue "Geräteübergreifende Anwendung - Delphi" erstelle und dann die Anwendung auf dem Zielgerät ausführen lassen will,
dann erhalte ich erst die Meldung
Zitat:
application does not support this device
.

Wenn ich darauf hin den Workaround von http://docwiki.embarcadero.com/RADSt...oid-Ger%C3%A4t
ausführe, dann wird die Anwendung zwar auf das Gerät übertagen, aber wenn ich sie dann starte, poppt die Anwenung nur kurz auf und beendet sich ohne weiteren Kommentar.

Irgend welche Ideen?

Wie kann man eigentlich im SDK-Manager mehrere Varianten eines SDK mit unterschiedlichen API-Leveln anlegen?

Gruß Heiko

P.S. Wie bekommt man ein Bild in sein Profil?

Nachtrag: Auch ein Rückschritt zu SDK 23.0.2 oder API-Level 22 bringen keine Besserung.

Kann man mit XE7 keine "Android 6"-Apps erstellen?
OS: Linux Mint 20 Cinnamon (64-Bit), Windows 10 Professional, Delphi XE7 Pro SP1 +(Mobilpack & FireDAC), Lazarus 2.1 (Freepascal 3.3.1),

Geändert von Kralle (16. Apr 2017 um 20:08 Uhr) Grund: Ergänzung
  Mit Zitat antworten Zitat
zeras

Registriert seit: 11. Mär 2007
Ort: Saalkreis
1.458 Beiträge
 
Delphi 10.4 Sydney
 
#2

AW: XE7 und Andorid 6 Gerät

  Alt 16. Apr 2017, 21:17
Ich hatte letztens noch XE5 und da ging auch kein Android 5 mehr. Das hatten wir hier im Forum aber irgendwo besprochen. Dann habe ich auf XE10 geupdatet und alles war OK.
Ob die Änderung schon bei XE7 drin war, weiß ich leider nicht. Es müsste hier aber im Forum dokumentiert sein.
Wenn ich den Post finde, sende ich den Link.
Es ist nie falsch das Richtige zu tun!
- Mark Twain
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
16.880 Beiträge
 
Delphi 10.4 Sydney
 
#3

AW: XE7 und Andorid 6 Gerät

  Alt 16. Apr 2017, 21:24
Wenn ich nach dem Gerät suche steht da was von Intel Atom.
Das ist was die Entwicklung mit Delphi-Betrifft nicht kompatible. Hier gehen (aktuell und vermutlich auch noch einige Zeit) nur ARM-Prozessoren
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
Kralle

Registriert seit: 31. Okt 2004
Ort: Bremerhaven
349 Beiträge
 
Delphi XE7 Professional
 
#4

AW: XE7 und Andorid 6 Gerät

  Alt 16. Apr 2017, 21:53
Moin,

also auch auf meinen "Samsung S5 mini" mit "ARMV7I" geht es nicht mehr.
Und das Tablet hat "x86, armeabi-v7a".

Also, müssen das mehrere Probleme sein.

Gruß Heiko
OS: Linux Mint 20 Cinnamon (64-Bit), Windows 10 Professional, Delphi XE7 Pro SP1 +(Mobilpack & FireDAC), Lazarus 2.1 (Freepascal 3.3.1),
  Mit Zitat antworten Zitat
zeras

Registriert seit: 11. Mär 2007
Ort: Saalkreis
1.458 Beiträge
 
Delphi 10.4 Sydney
 
#5

AW: XE7 und Andorid 6 Gerät

  Alt 16. Apr 2017, 22:00
Nutze doch mal die APP Syscheck. Dort muss ARMV7 rauskommen (das scheint bei dir der Fall zu sein) und der NEON Support muss supported sein.
Es ist nie falsch das Richtige zu tun!
- Mark Twain
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
38.510 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: XE7 und Andorid 6 Gerät

  Alt 16. Apr 2017, 22:12
Offiziell, also in den Delphi-Dokumentationen seht es so drin
Delphi XE5 -> Android 4.0
Delphi 10 -> Android 5.1.1
Delphi 10.1 -> Android 6.0
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
Kralle

Registriert seit: 31. Okt 2004
Ort: Bremerhaven
349 Beiträge
 
Delphi XE7 Professional
 
#7

AW: XE7 und Andorid 6 Gerät

  Alt 16. Apr 2017, 22:15
Moin,

Also auf dem S5 meldet die APP: ARMv7
Auf dem Tablet leider: X86 Genuine Intel(R) CPU @728

Aber, bedeutet das nicht, das es zu mindest auf dem Handy funktionieren müsste?

Gruß Heiko
OS: Linux Mint 20 Cinnamon (64-Bit), Windows 10 Professional, Delphi XE7 Pro SP1 +(Mobilpack & FireDAC), Lazarus 2.1 (Freepascal 3.3.1),
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
38.510 Beiträge
 
Delphi 10.4 Sydney
 
#8

AW: XE7 und Andorid 6 Gerät

  Alt 16. Apr 2017, 22:21
Auf meinem S5-Mini lief es damals.
PS: Vor Kurzem gab es ein da Systemupdate.

Mein Tablet mit Intel will es natürlich nicht, wobei es da ja einen "Trick" gibt, wenn es eine ARM-Emulation drin hat.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
zeras

Registriert seit: 11. Mär 2007
Ort: Saalkreis
1.458 Beiträge
 
Delphi 10.4 Sydney
 
#9

AW: XE7 und Andorid 6 Gerät

  Alt 16. Apr 2017, 23:12
Offiziell, also in den Delphi-Dokumentationen seht es so drin
Delphi XE5 -> Android 4.0
Delphi 10 -> Android 5.1.1
Delphi 10.1 -> Android 6.0
Ich habe eine APP mit Seattle programmiert, die sogar unter Android 7 läuft.
Es ist nie falsch das Richtige zu tun!
- Mark Twain
  Mit Zitat antworten Zitat
Kralle

Registriert seit: 31. Okt 2004
Ort: Bremerhaven
349 Beiträge
 
Delphi XE7 Professional
 
#10

AW: XE7 und Andorid 6 Gerät

  Alt 17. Apr 2017, 07:53
Moin,

Offiziell, also in den Delphi-Dokumentationen seht es so drin
Delphi XE5 -> Android 4.0
Delphi 10 -> Android 5.1.1
Delphi 10.1 -> Android 6.0
Aber, ist das nicht eigentlich unlogisch?
Macht nicht eigentlich das Android-SDK erst aus dem Firemonkey-Code eine Android-APP?
Müsste es denn nicht eigenlich nur davon abhängen, welches SDK bzw. welchen API-Level man nutzt?

Gruß Heiko
OS: Linux Mint 20 Cinnamon (64-Bit), Windows 10 Professional, Delphi XE7 Pro SP1 +(Mobilpack & FireDAC), Lazarus 2.1 (Freepascal 3.3.1),
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 05:40 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf