AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

IOS "paclient" exited with code 1.

Ein Thema von mlc42 · begonnen am 7. Sep 2017 · letzter Beitrag vom 13. Dez 2019
Antwort Antwort
Seite 2 von 2     12
Rollo62

Registriert seit: 15. Mär 2007
3.406 Beiträge
 
Delphi 11 Alexandria
 
#11

AW: IOS "paclient" exited with code 1.

  Alt 10. Okt 2017, 05:28
Gibt es da noch mehr Status- Fehlerinfo, wenn man die Fehlermeldungen aufklappt ?
Könntest du das bitte mal hier reinkopieren ?
Es kommt ja oft auf das Kleingedruckte an.

Rollo
  Mit Zitat antworten Zitat
arnof

Registriert seit: 25. Apr 2013
1.243 Beiträge
 
Delphi 10.1 Berlin Enterprise
 
#12

AW: IOS "paclient" exited with code 1.

  Alt 10. Okt 2017, 08:53
außer Code 1 kommt da nichts!


via cmd kommt Fehler E0776
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
3.406 Beiträge
 
Delphi 11 Alexandria
 
#13

AW: IOS "paclient" exited with code 1.

  Alt 10. Okt 2017, 09:44
Hast du die Zertifikate geändert / umbenannt ?
Und dann auch die alten wieder entfernt und die Neuen neu runtergeladen ?
Das ganze Theater halt ?

Ich denke wenn man irgendwas an den Zertifikaten ändert oder umbenennt kann Alles Mögliche passieren.
Kam der Fehler erst nachdem du das geändert hattest ?
Ich hoffe du bist dir sicher das damit islled OK ist.


Rollo
  Mit Zitat antworten Zitat
arnof

Registriert seit: 25. Apr 2013
1.243 Beiträge
 
Delphi 10.1 Berlin Enterprise
 
#14

AW: IOS "paclient" exited with code 1.

  Alt 10. Okt 2017, 19:56
Hast du die Zertifikate geändert / umbenannt ?
Und dann auch die alten wieder entfernt und die Neuen neu runtergeladen ?
Das ganze Theater halt ?

Ich denke wenn man irgendwas an den Zertifikaten ändert oder umbenennt kann Alles Mögliche passieren.
Kam der Fehler erst nachdem du das geändert hattest ?
Ich hoffe du bist dir sicher das damit islled OK ist.


Rollo
Alle Zertifikate habe ich zur Sicherheit neu gemacht und den ganze Apple kram halt .....

Bis Sep 2017 haben wir nur mit Seattle und Berlin App für IOS parallel gemacht, alles ohne Probleme (Namen der Zertifikate gibt ja Apple vor, die bleiben auch gleich, keine abgelaufene mehr auf dem System vorhanden).

Ich denke der kommt mit dem Namen des Zertifikats nicht klar. Zu Zeiten, wo noch keine automatische Erkennung vorhanden war, und nur ein Zertifikat vorhanden war, reichte es aus, das man nur den Zertifikatsnamen und sein Entwickler ID angibt.
Das habe ich nun manuell nachgebildet.

'iPhone Distribution: werauchimmer GmbH & Co.KG (xxxxxxx)' -> 'iPhone Distributionxxxxxx'

Entweder ist der Bug im PASERVER oder bei XCODE9

Geändert von arnof (10. Okt 2017 um 20:47 Uhr)
  Mit Zitat antworten Zitat
CHackbart

Registriert seit: 22. Okt 2012
252 Beiträge
 
#15

AW: IOS "paclient" exited with code 1.

  Alt 13. Nov 2017, 11:48
Hallo,

bei der Suche nach einer Lösung für mein aktuelles Problem bin ich wieder hier gelandet. Ich denke mal es handelt sich dabei um das Gleiche:

Code:
Fehler: E0776 2017-11-13 12:40:07.113 xcodebuild[15126:4728226] [MT] IDEDistribution: -[IDEDistributionLogging _createLoggingBundleAtPath:]: Created bundle at path '/var/folders/yj/tdj525vs2jzcjtt9xyfdc1sh0000gn/T/SatIPViewer_2017-11-13_12-40-07.112.xcdistributionlogs'.
Fehler: E0776 2017-11-13 12:40:07.511 xcodebuild[15126:4728226] [MT] IDEDistribution: Step failed: <IDEDistributionSigningAssetsStep: 0x7fb1e1732fc0>: Error Domain=IDEDistributionSigningAssetStepErrorDomain Code=0 "Locating signing assets failed." UserInfo={NSLocalizedDescription=Locating signing assets failed., IDEDistributionSigningAssetStepUnderlyingErrors=(
Fehler: E0776     "Error Domain=IDEProvisioningErrorDomain Code=9 \"\"SatIPViewer.app\" requires a provisioning profile.\" UserInfo={NSLocalizedDescription=\"SatIPViewer.app\" requires a provisioning profile., NSLocalizedRecoverySuggestion=
Add a profile to the \"provisioningProfiles\" dictionary in your Export Optionsproperty list.}" Fehler: E0776 )}
Fehler: E0776 error: exportArchive: "SatIPViewer.app" requires a provisioning profile.
Fehler: E0776 Error Domain=IDEProvisioningErrorDomain Code=9 ""SatIPViewer.app" requires a provisioning profile." UserInfo={NSLocalizedDescription="SatIPViewer.app" requires a provisioning profile., NSLocalizedRecoverySuggestion=Add a profile to the "provisioningProfiles" dictionary in your Export Options property list.}
Fehler: E0776 ** EXPORT FAILED **
Christian
  Mit Zitat antworten Zitat
CHackbart

Registriert seit: 22. Okt 2012
252 Beiträge
 
#16

AW: IOS "paclient" exited with code 1.

  Alt 13. Nov 2017, 12:54
Seit ein paar Tagen gibt es ein Hotfix https://cc.embarcadero.com/Download.aspx?id=30805. Damit geht das Erstellen wieder.
  Mit Zitat antworten Zitat
JohnDirkDer1te

Registriert seit: 16. Mai 2007
Ort: Unterhaching
7 Beiträge
 
Delphi 10.3 Rio
 
#17

AW: IOS "paclient" exited with code 1.

  Alt 12. Dez 2019, 07:50
Hallo
mit 10.3.3 und XCODE 11.3 wieder das gleiche, ich hoffe es kommt bald ein Hotfix
Vor Update auf akt. XCODE ging alles noch.
Gruß Dirk
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
3.406 Beiträge
 
Delphi 11 Alexandria
 
#18

AW: IOS "paclient" exited with code 1.

  Alt 12. Dez 2019, 07:58
Zitat:
"Error Domain=IDEProvisioningErrorDomain Code=9 \"\"SatIPViewer.app\" requires a provisioning profile.\"
Da stimmt wohl was nicht mit den iOS Zertifikaten.
Evtl. sind die auch doppelt vorhanden, nach einem jährlichen Update bei Apple.
Am Besten mal die alten auf dem Rechner löschen, und neu runterladen.
Ich mache das mit XCode, und lege mir ein Dummy-Projekt mit gleicher Bundle-ID an, damit kann man dann, bei manueller Verwaltung, besser nachvollziehen welche Zertifikate OK sind, und welche nicht.
XCode kann da auch oft was reparieren wenn es klemmt.
Wenn XCode das Dummy-Projekt nicht starten kann, dann kann es RadStudio auch nicht.

Es gibt schon Einige Hinweise hier im Forum, einfach mal danach suchen.

Rollo
  Mit Zitat antworten Zitat
JohnDirkDer1te

Registriert seit: 16. Mai 2007
Ort: Unterhaching
7 Beiträge
 
Delphi 10.3 Rio
 
#19

AW: IOS "paclient" exited with code 1.

  Alt 13. Dez 2019, 07:05
Hallo Rollo,

"alte" Zertifikate sind alle gelöscht.
Bei xcode geht auch alles.
Bei 10.3.3 auch, bis auf AdHoc, das gleiche hatte ich damals vor dem patch auch.
"Fehler: E0776 error: exportArchive: Provisioning profile "xyxyxyxy" doesn't include signing certificate "Apple Distribution: Max Mueller (ababababab)""
das stimmt aber nicht, es ist drin und geht bei XCODE.

Viele Grüße

Dirk
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 15:33 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf