AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke Indy -> SSL3_GET_RECORD:wrong version number

Indy -> SSL3_GET_RECORD:wrong version number

Ein Thema von erich.wanker · begonnen am 14. Dez 2017 · letzter Beitrag vom 14. Dez 2017
Antwort Antwort
Benutzerbild von erich.wanker
erich.wanker

Registriert seit: 31. Jan 2008
Ort: im schönen Salzburger Land
459 Beiträge
 
Delphi XE4 Professional
 
#1

Indy -> SSL3_GET_RECORD:wrong version number

  Alt 14. Dez 2017, 11:40
Hallo Leute,

ich verwende Win10 - Delphi XE4 - 32 Bit - deutsch


Beim Abrufen von meinen Mails ( 1und1.de) bekomme ich immer einen Fehler..
Fehler beim Verbinden mit SSL.
error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number


Mein IdSSLIOHandlerSocketOpenSSL1 hat folgende Werte:


Mein TidPOP3 hat folgende Werte:
  • IOHandler = IdSSLIOHandlerSocketOpenSSL1
  • UseTLS = utUseImplicitTLS

Im Programmverzeichnis habe ich libeay32.dll und ssleay32.dll (Version 1.0.1.5)


Die Host - und Porteinstellungen habe ich alle schon durchprobiert: https://hilfe-center.1und1.de/e-mail...m-a783411.html


Was mache ich da falsche????

Vielen Dank für Hinweise

Erich
Erich Wanker - for life:=1971 to lebensende do begin ..
O
/H\
/ \
  Mit Zitat antworten Zitat
Delphi.Narium

Registriert seit: 27. Nov 2017
2.451 Beiträge
 
Delphi 7 Professional
 
#2

AW: Indy -> SSL3_GET_RECORD:wrong version number

  Alt 14. Dez 2017, 11:49
Guckst Du hier: http://www.delphipraxis.net/1387928-post3.html
  Mit Zitat antworten Zitat
Benutzerbild von erich.wanker
erich.wanker

Registriert seit: 31. Jan 2008
Ort: im schönen Salzburger Land
459 Beiträge
 
Delphi XE4 Professional
 
#3

AW: Indy -> SSL3_GET_RECORD:wrong version number

  Alt 14. Dez 2017, 12:05
Hallo und Danke für den Tipp - leider keine Änderung:

Hab jetzt IdSSLIOHandlerSocketOpenSSL1 - Meothod: sslvTLSv1

Zitat:
Fehler beim Verbinden mit SSL.
error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
Erich Wanker - for life:=1971 to lebensende do begin ..
O
/H\
/ \
  Mit Zitat antworten Zitat
Benutzerbild von erich.wanker
erich.wanker

Registriert seit: 31. Jan 2008
Ort: im schönen Salzburger Land
459 Beiträge
 
Delphi XE4 Professional
 
#4

AW: Indy -> SSL3_GET_RECORD:wrong version number

  Alt 14. Dez 2017, 12:18
hab jetzt folgendes probiert

TIdPOP3 - UseTLS: utUseRequireTLS

und die beiden (!!!) Dlls gelöscht (??)

Jetzt gehts .. .. wieso auch immer ??

LiGrü
Erich
Erich Wanker - for life:=1971 to lebensende do begin ..
O
/H\
/ \

Geändert von erich.wanker (14. Dez 2017 um 12:21 Uhr)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 12:00 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz