AGB  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Delphi-PRAXiS - Lounge Betriebssysteme Win10: Stetiger Performanceverlust

Win10: Stetiger Performanceverlust

Ein Thema von Zacherl · begonnen am 8. Jan 2018 · letzter Beitrag vom 13. Feb 2018
Antwort Antwort
Seite 4 von 5   « Erste     234 5   
Der schöne Günther
Online

Registriert seit: 6. Mär 2013
4.456 Beiträge
 
Delphi 10 Seattle Enterprise
 
#31

AW: Win10: Stetiger Performanceverlust

  Alt 8. Jan 2018, 22:33
Ich will kein Arsch sein, aber könnt ihr so geschmeidig sein und die Virenscanner woanders besprechen?

Mich interessiert die TortoiseMerge und Konsorten-Geschichte dafür zu sehr
  Mit Zitat antworten Zitat
QuickAndDirty

Registriert seit: 13. Jan 2004
Ort: Hamm(Westf)
1.398 Beiträge
 
Delphi XE8 Professional
 
#32

AW: Win10: Stetiger Performanceverlust

  Alt 9. Jan 2018, 09:47
Es dürfte unter WIN 10 nicht ein all zu großes Problem sein.
Dennoch ist es ein mögliches Ressourcen Leck.
Manche Programme spammen dei Windows Atom Tabellen voll.
Es gibt nen Atomtable Viewer der in Delphi geschrieben wurde.
Andreas
Zu gehen schickt sich, nicht zu gasten stets an derselben Statt.Der Liebe wird leid, der lange weilt. In des andern Haus.
  Mit Zitat antworten Zitat
Benutzerbild von Zacherl
Zacherl

Registriert seit: 3. Sep 2004
4.484 Beiträge
 
Delphi 10.1 Berlin Starter
 
#33

AW: Win10: Stetiger Performanceverlust

  Alt 9. Jan 2018, 15:00
Ich habe mal ausgehend vom verlinkten TortoiseGit BugReport noch etwas weitergehend recherchiert und folgendes herausgefunden:
  • Die MSDN-Library durchsuchenGetPixel Funktion scheint der Hauptübeltäter bei Tortoise zu sein (das Preview Build startet deutlich flüssiger; wenn auch immer noch langsamer als unter 1703)
    • Diese API wird tatsächlich langsamer, je länger das System läuft
    • MFC Anwendungen benutzen die API scheinbar sehr frequent
    • Delphi Anwendungen mit DevExpress scheinen auch recht frequent TBitmap.GetTransparentColor aufzurufen, was unter der Haube einen MSDN-Library durchsuchenGetPixel Call auslöst
  • Es könnte ein Zusammenhang mit dem neuen CFG Exploit Schutz bestehen, der in 1709 erstmals standardmäßig Systemweit aktiv ist (De-/Aktivieren im Wechsel bringt bei einigen Leuten den gleichen Efekt wie ein Reboot/Ab-/Anmelden; kann ich bei mir allerdings nicht bestätigen)
  • Gefixt werden soll das Problem scheinbar erst in Build 1803

Den Taskmanager habe ich interessehalber mal debuggt und dort allerdings keinen GetPixel Aufruf feststellen können. Es gibt also vermutlich noch weitere APIs, die betroffen sind oder aber der CFG hat generell einen ziemlichen Performance Impact auf einige Anwendungen.
Projekte:
- GitHub (Profil, zyantific)
- zYan Disassembler Engine ( Zydis Online, Zydis GitHub)
  Mit Zitat antworten Zitat
Der schöne Günther
Online

Registriert seit: 6. Mär 2013
4.456 Beiträge
 
Delphi 10 Seattle Enterprise
 
#34

AW: Win10: Stetiger Performanceverlust

  Alt 9. Jan 2018, 16:24
Falls es dich beruhigt: Auf meinem PC zu Hause läuft die Windows-Previewbuild 17063, da tritt das Problem mit TortoiseMerge auch nicht mehr auf.

Ich wundere mich nur warum das Problem sich mit einem Ab/Anmelden temporär beseitigen lässt. Was da intern wohl abgeht?
  Mit Zitat antworten Zitat
Benutzerbild von Zacherl
Zacherl

Registriert seit: 3. Sep 2004
4.484 Beiträge
 
Delphi 10.1 Berlin Starter
 
#35

AW: Win10: Stetiger Performanceverlust

  Alt 9. Jan 2018, 18:29
Falls es dich beruhigt: Auf meinem PC zu Hause läuft die Windows-Previewbuild 17063, da tritt das Problem mit TortoiseMerge auch nicht mehr auf.
Immerhin ein Lichtblick

Ich wundere mich nur warum das Problem sich mit einem Ab/Anmelden temporär beseitigen lässt. Was da intern wohl abgeht?
Das frage ich mich auch. Bei einigen Leuten lässt sich das Problem sogar temporär durch ändern bestimmter DPI Kompatibilitätseinstellungen oder wie erwähnt das alternierende De-/Aktivieren des CFG Exploit Schutzes beheben
Projekte:
- GitHub (Profil, zyantific)
- zYan Disassembler Engine ( Zydis Online, Zydis GitHub)
  Mit Zitat antworten Zitat
ulli71

Registriert seit: 13. Feb 2018
2 Beiträge
 
#36

AW: Win10: Stetiger Performanceverlust

  Alt 13. Feb 2018, 12:02
Mein PC läuft immer noch auf Win7...lohnt sich denn das Upgrade auf 10? Nachdem man das so liest hier...ohje.
  Mit Zitat antworten Zitat
Der schöne Günther
Online

Registriert seit: 6. Mär 2013
4.456 Beiträge
 
Delphi 10 Seattle Enterprise
 
#37

AW: Win10: Stetiger Performanceverlust

  Alt 13. Feb 2018, 12:04
Das ist ein ganz anderes Thema, da hat man auch hier im Forum schon x mal emotional drüber gestritten, such doch mal. Für mich - Contra: Eine bestimmte Anwendung braucht lange zum Laden. Pro: So viel kann ich gar nicht aufzählen.
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
6.747 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#38

AW: Win10: Stetiger Performanceverlust

  Alt 13. Feb 2018, 12:28
Mein PC läuft immer noch auf Win7...lohnt sich denn das Upgrade auf 10? Nachdem man das so liest hier...ohje.
Kurz zusammengefasst:
Lohnen definitiv, aber man muss sich auch auf etwas Neues einlassen können.
Für Details siehe einen der vielen passenden Threads.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Aviator

Registriert seit: 3. Jun 2010
1.279 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#39

AW: Win10: Stetiger Performanceverlust

  Alt 13. Feb 2018, 12:31
Da das Thema gerade wieder hoch geholt wurde. Hat schon irgendjemand eine Lösung oder eine Besserung für das Problem gefunden?

Ich merke auch zunehmend, dass das System nach wenigen Minuten bzw. Stunden Laufzeit sehr träge und langsam reagiert. Ab- und wieder anmelden bzw. ein kompletter Neustart des PCs hilft zwar, finde ich aber sehr schlecht da ich dann immer wieder alle Anwendungen öffnen muss in denen ich gerade am Arbeiten bin. Und das sind nicht gerade wenige.

Mir kommt es so vor, dass sich der Fehler bei upgegradeten Windows 7 Systemen stärker äußert als es bei frisch installierten Windows 10 Systemen der Fall ist.

Mein Notebook zu Hause habe ich komplett neu installiert und das ist wesentlich schneller als mein PC in der Firma und wird auch nicht so langsam. Gut man muss dazu sagen, dass ich da nur selten damit arbeite. Die Hardware ist vielleicht auch etwas neuer, aber das sollte es nicht ausmachen.

Mein Rechner in der Firma ist nach einem kompletten Neustart auch super schnell. Nur nach ein paar Minuten wird er schon wieder langsam. Das merkt man vor allem beim Öffnen des Windows Explorers. Der braucht das bis zu einer Sekunde zum Öffnen. Nach dem Neustart ist der direkt offen (50ms vielleicht). Und das zieht sich durch das gesamte System.
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
6.747 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#40

AW: Win10: Stetiger Performanceverlust

  Alt 13. Feb 2018, 12:36
Bei mir reproduzieren kann ich nur das Problem mit Tortoise und Delphi. Wenn Delphi offen ist, ist Tortoise extrem langsam, schließe ich Delphi, ist es wieder schnell. Das passiert aber unter Windows 7, 8 und 10 gleichermaßen.

Ansonsten lief der Rechner nun mehrfach mehrere Tage lang ohne dass ich dort andere Verlangsamungseffekte gehabt hätte.
Es handelt sich um eine frische Installation, kein Update.

// EDIT:
Ach ja:
Von wegen Update... ich hatte ja nun schon vor längerer Zeit auf Windows 10 aktualisiert. Eine Neuinstallation wird aber verweigert mit dem Key obwohl dieser bei meinem Account hinterlegt ist. Aber auch die Übertragung schlägt fehl ohne besondere Fehlerbeschreibung ("ungültiger Key oder oder").
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!

Geändert von jaenicke (13. Feb 2018 um 12:38 Uhr)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 12:24 Uhr.
Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2018 by Daniel R. Wolf