AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

WebBrowser.Parent nur lesend?

Ein Thema von e-gon · begonnen am 28. Mai 2018 · letzter Beitrag vom 28. Mai 2018
Antwort Antwort
Seite 1 von 2  1 2   
e-gon

Registriert seit: 7. Jul 2003
Ort: Stuttgart
141 Beiträge
 
Delphi 6 Enterprise
 
#1

WebBrowser.Parent nur lesend?

  Alt 28. Mai 2018, 08:45
Hallo,

in meinem Adressprogramm nutze ich zur Darstellung der Personen derzeit pro Person jeweils ein Panel, auf dem links ein TImage das Foto der Person und rechts ein TRichEdit die Daten anzeigt. Da es schön wäre, diese Daten formatiert und evtl. mit kleinen Grafiken darzustellen, wollte ich das RichEdit auf jedem Panel durch ein TWebBrowser ersetzten.

Dabei stieß ich allerdings auf ein Problem: Laut Compiler kann auf WebBrowser.Parent nur lesend zugegriffen werden. Viele Einträge in diesem Forum besagen aber, dass es möglich sei Parent einen Wert zuzuweisen. Was mache ich also falsch?

Ein Beispiel:
Delphi-Quellcode:
uses
  ...
  SHDocVw;

var
  ...
  HTML: Array [0..5] of TWebBrowser;


procedure TForm1.FormCreate(Sender: TObject);
var x: Integer;
begin
  for x:= 0 to 5 do begin
    HTML[x]:= TWebBrowser.Create(Self);
    HTML[x].Parent:= Panel1; // Hier tritt der Fehler auf: "Einer Nur-Lesen Eigenschaft kann kein Wert zugewiesen werden"
  end;
end;
Das Problem konnte ich mit Delphi 6 und 2009 nachvollziehen.

Gruß
e-gon
  Mit Zitat antworten Zitat
Fritzew

Registriert seit: 18. Nov 2015
Ort: Kehl
628 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#2

AW: WebBrowser.Parent nur lesend?

  Alt 28. Mai 2018, 09:10
Parent is überschrieben von Twebbrowser und ist dort ein IDispatch.

Erzeuge Deine Webbrowser Instanzen gleich auf dem Panel :

Delphi-Quellcode:
procedure TForm1.FormCreate(Sender: TObject);
var x: Integer;
begin
  for x:= 0 to 5 do begin
// HTML[x]:= TWebBrowser.Create(Self);
     HTML[x]:= TWebBrowser.Create(Panel[x]); // Wie auch immer Du diese verwaltest
  // HTML[x].Parent:= Panel1; // Hier tritt der Fehler auf: "Einer Nur-Lesen Eigenschaft kann kein Wert zugewiesen werden"
  end;
end;
Fritz Westermann
  Mit Zitat antworten Zitat
e-gon

Registriert seit: 7. Jul 2003
Ort: Stuttgart
141 Beiträge
 
Delphi 6 Enterprise
 
#3

AW: WebBrowser.Parent nur lesend?

  Alt 28. Mai 2018, 09:33
Hallo Fritzew,

danke für die schnelle Antwort! So einfach geht's natürlich auch. Da habe ich mal wieder zu kompliziert gedacht...

Gruß
e-gon
  Mit Zitat antworten Zitat
e-gon

Registriert seit: 7. Jul 2003
Ort: Stuttgart
141 Beiträge
 
Delphi 6 Enterprise
 
#4

AW: WebBrowser.Parent nur lesend?

  Alt 28. Mai 2018, 12:00
Leider funktioniert es immer noch nicht.

Trotz HTML[x]:= TWebBrowser.Create(Panel[x]); bleibt Panel[x].Parent auf "nil". Kann mir jemand sagen warum? Gibt es eine Möglichkeit dieses Parent noch irgendwie zu setzen?
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
34.931 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#5

AW: WebBrowser.Parent nur lesend?

  Alt 28. Mai 2018, 12:02
Panel[x].Parent oder HTML[x].Parent ?
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
Fritzew

Registriert seit: 18. Nov 2015
Ort: Kehl
628 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#6

AW: WebBrowser.Parent nur lesend?

  Alt 28. Mai 2018, 12:03
Vielleicht würde es helfen, wenn Du uns erklärst was Du eigentlich erreichen willst.
Parent im TWebBrowser ist etwas total anderes als ein parent von zb einem Button.....

Trotz rot abgeschickt....
Fritz Westermann
  Mit Zitat antworten Zitat
Benutzerbild von KodeZwerg
KodeZwerg

Registriert seit: 1. Feb 2018
2.263 Beiträge
 
Delphi 2010 Professional
 
#7

AW: WebBrowser.Parent nur lesend?

  Alt 28. Mai 2018, 12:03
Existiert denn überhaupt ein Panel[x] ? Das ist aus dem Code nicht ersichtlich.
Gruß vom KodeZwerg
Wenn ein unerwarteter Fehler aufgetreten ist, frage ich mich immer, welche Fehler erwartet wurden...
  Mit Zitat antworten Zitat
e-gon

Registriert seit: 7. Jul 2003
Ort: Stuttgart
141 Beiträge
 
Delphi 6 Enterprise
 
#8

AW: WebBrowser.Parent nur lesend?

  Alt 28. Mai 2018, 12:13
Hallo,

sorry, es war das falsche Parent! HTML[x].Parent natürlich!

Wie anfangs schon beschrieben habe ich für die Übersicht in meinem Adressprogramm für jede Person ein Panel (Panel[x]). Und auf jedem Panel befinden sich zwei Komponenten. Links ein TImage, welches das Bild der Person anzeigt, und rechts hatte ich zunächst ein RichEdit für die Ausgabe der Daten. Nun wollte ich das jeweilige RichEdit auf dem Panel gegen ein WebBrowser ersetzen. Dabei stieß ich jedoch auf das Problem, dass ich bei TWebBrowser den Parameter Parent nicht setzen kann. Also hat Fritzew vorgeschlagen, gleich bei Create das Panel[x] als Parameter zu übergeben. Nun sollte WebBrowser.Parent ja eigentlich auf "Panel[x]" zeigen. Stattdessen ist es aber nil.

Ja, Panel[x] exisitert. Sonst würde es mir der Compiler ja gleich um die Ohren hauen.

Gruß
Heiko
  Mit Zitat antworten Zitat
Fritzew

Registriert seit: 18. Nov 2015
Ort: Kehl
628 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#9

AW: WebBrowser.Parent nur lesend?

  Alt 28. Mai 2018, 12:32
Du willst also von Deinem TWebbrowser den Panel finden?

Da das Property Parent in Twebbrowser aber neu eingeführt (Überschrieben) wird hilft ein Cast.

TOleControl(WebBrowser1).Parent ist das was Du suchst
Fritz Westermann
  Mit Zitat antworten Zitat
e-gon

Registriert seit: 7. Jul 2003
Ort: Stuttgart
141 Beiträge
 
Delphi 6 Enterprise
 
#10

AW: WebBrowser.Parent nur lesend?

  Alt 28. Mai 2018, 12:41
Nein. Sorry für das Missverständnis.

Ich will eigentlich nur dass der jeweilige WebBrowser auf dem dazugehörendem Panel[x] angezeigt wird. Aber das funktioniert nicht. Also habe ich schon die verschiedensten Dinge ausprobiert und dabei festgestellt, dass Parent bei jedem WebBrowser auf nil steht und nicht - wie ich erwarte - auf des dazugehörge Panel[x] zeigt. Also gehe ich davon aus, dass deshalb keines der WebBrowser in der Übersicht auf dem Panel[x] zu sehen ist.

Gruß
e-gon
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 00:16 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf