AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Sprachen und Entwicklungsumgebungen Die Delphi-IDE Projektoptionen - Symbol - Unbekannte Bilddateierweiterung .ico bei 10.2.3

Projektoptionen - Symbol - Unbekannte Bilddateierweiterung .ico bei 10.2.3

Ein Thema von uli066 · begonnen am 24. Jul 2018 · letzter Beitrag vom 25. Jul 2018
Antwort Antwort
uli066

Registriert seit: 21. Apr 2006
5 Beiträge
 
#1

Projektoptionen - Symbol - Unbekannte Bilddateierweiterung .ico bei 10.2.3

  Alt 24. Jul 2018, 09:59
Folgendes Problem:
Ich habe gestern meine Delphi-Installation von 10.2.2 auf 10.2.3 upgedatet. Also altes Delphi deinstalliert und neues installiert.

Alles soweit problemlos gelaufen. Wenn ich nun aber ein Projekt öffne, gibt es bei den Einstellungen im Projekt - Anwendung - Symbol eine Fehlermeldung bei der Symbolbilddatei. "Symbol kann nicht gesetzt werden: Unbekannte Bilddateierweiterung (.ico)".

Es kann überhaupt keine .ico -Datei mehr in dem Bereich geladen werden. Meine Programme haben danach leider nur noch ein "Kreuz" als Symbol.

Hat jemand diesen Bug auch schon mal gehabt und das Problem gelöst?

Vielen Dank für Eure Hilfe
Miniaturansicht angehängter Grafiken
unbekanntebilddateierweiterung.jpg  
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
6.265 Beiträge
 
Delphi XE4 Professional
 
#2

AW: Projektoptionen - Symbol - Unbekannte Bilddateierweiterung .ico bei 10.2.3

  Alt 24. Jul 2018, 10:46
Hallo,
versucht das Ico mal in Gimp zu öffnen und neu zu exportieren

http://chapmanworld.com/2016/02/17/r...lication-icon/
Heiko
  Mit Zitat antworten Zitat
uli066

Registriert seit: 21. Apr 2006
5 Beiträge
 
#3

AW: Projektoptionen - Symbol - Unbekannte Bilddateierweiterung .ico bei 10.2.3

  Alt 24. Jul 2018, 11:01
Danke für den Tip, werde ich heute abend mal probieren.

Jedoch gehen auf meinen Laptop, gleiche Programmversion, die bisherigen Icon's problemlos. Denke ggf. eher an ein IDE-Problem. Wir werden sehen.
  Mit Zitat antworten Zitat
Benutzerbild von KodeZwerg
KodeZwerg

Registriert seit: 1. Feb 2018
1.676 Beiträge
 
Delphi 2009 Professional
 
#4

AW: Projektoptionen - Symbol - Unbekannte Bilddateierweiterung .ico bei 10.2.3

  Alt 24. Jul 2018, 11:10
Erscheint diese Fehlermeldung auch wenn Du ein neues Projekt startest und dem ein Icon zuweist?
Gruß vom KodeZwerg
Wenn ein unerwarteter Fehler aufgetreten ist, frage ich mich immer, welche Fehler erwartet wurden...
  Mit Zitat antworten Zitat
uli066

Registriert seit: 21. Apr 2006
5 Beiträge
 
#5

AW: Projektoptionen - Symbol - Unbekannte Bilddateierweiterung .ico bei 10.2.3

  Alt 24. Jul 2018, 11:14
Nein, erst wenn ich ein Symbol zuweisen möchte. Jetzt bin ich aber verwundert, der Fehler trat beim Compilieren erstes mal auf. Da ich dieses Problem ja sonst gar nicht gemerkt hätte. Wann ändert man schon mal ein Symbol
Ich werde das mit dem neuen Projekt auch heute abend probieren und berichten.
  Mit Zitat antworten Zitat
uli066

Registriert seit: 21. Apr 2006
5 Beiträge
 
#6

AW: Projektoptionen - Symbol - Unbekannte Bilddateierweiterung .ico bei 10.2.3

  Alt 24. Jul 2018, 22:43
Vielen Dank für Eure Antworten.
Nun habe ich alles probiert, leider keine Besserung.
Die Fehlermeldung kommt nun direkt wenn man die Projektoptionen öffnet. Auch bei einem neuen leeren Projekt.
Ich habe die .ico-Datei nach Vorgabe von Hoika konvertiert, leider auch keine Besserung. Fehlermeldung kommt sofort.

Ob da in der Installation was schief gegangen ist? Sollte ich das nochmal de- und installieren?
Hat noch jemand eine Idee oder kennt das Problem schon? Normalerweise hat man ja nicht als erster einen Bug
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe
Online

Registriert seit: 20. Jan 2006
Ort: Lübbecke
5.972 Beiträge
 
Delphi 10.2 Tokyo Architect
 
#7

AW: Projektoptionen - Symbol - Unbekannte Bilddateierweiterung .ico bei 10.2.3

  Alt 25. Jul 2018, 07:31
Ich würde zunächst prüfen, ob ich bei einem neuen VCL_Projekt in einer TImage-Komponente auf dem Form das Icon laden kann.

Wenn das nicht geht, liste doch bitte mal deine installierten Fremdkomponenten auf.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 19:03 Uhr.
Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2018 by Daniel R. Wolf