AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Bug in Vcl.Forms?

Ein Thema von SearchBot · begonnen am 25. Okt 2018 · letzter Beitrag vom 26. Okt 2018
Antwort Antwort
Seite 1 von 2  1 2   
SearchBot

Registriert seit: 27. Jun 2004
Ort: N-W vom Bodensee
232 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#1

Bug in Vcl.Forms?

  Alt 25. Okt 2018, 00:28
Hallo,

ich habe da ein seltsames Phänomen entdeckt, wenn ich mein Programm beende (siehe Bild).

Es kommt an dieser Stelle zu einer Zugriffsverletzung, weil FMenu plötzlich nil ist.
Wenn ich dort zur Behebung reinschreibe "if FMenu<>nil then ".., könnte ich es ja abfangen und vermeiden.

Aber die IDE kann meine Änderung nicht speichern, weil "Sicherungsordner 'c:\program files\embarcadero\studio\19.0\SOURCE\VCL\__history \' kann nicht angelegt werden."

Ich hab nicht die neuste Tokyo, vielleicht wurde es ja bereits behoben (wegen 20 Byte Fehlerkorrektur deinstalliere ich doch nicht mein Delphi, nur um dann die neuste Version 12GB und stundenlang wieder zu installieren!); wie kann ich mein Delphi dazu bringen, meinen kleinen Bugfix anzuwenden (auch erstmal zu speichern)?
Miniaturansicht angehängter Grafiken
delphi_vcl_forms_bug.png  
  Mit Zitat antworten Zitat
DieDolly

Registriert seit: 22. Jun 2018
1.913 Beiträge
 
#2

AW: Bug in Vcl.Forms?

  Alt 25. Okt 2018, 00:35
Versuch mal ganz klassisch mit dem Windows Notepad und Administratorrechten. Damit umgehst du das Problem mit dem History-Verzeichnis.

Als kleiner Hinweis. In der aktuellen Community-Version ist ein Hotfix wie deiner nicht vorhanden.
Das Problem muss also von woanders herkommen.

Geändert von DieDolly (25. Okt 2018 um 00:41 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
8.673 Beiträge
 
Delphi 10.4 Sydney
 
#3

AW: Bug in Vcl.Forms?

  Alt 25. Okt 2018, 00:46
Es kommt an dieser Stelle zu einer Zugriffsverletzung, weil FMenu plötzlich nil ist.
Aber warum ist es plötzlich nil, wenn es das doch zwei Zeilen vorher offenbar noch nicht war?

Wenn das ein Bug in dem Code wäre, dann müsste man schon die Umstände beschreiben, bei dem das passiert. Es ist vermutlich kein generelles Problem, denn dann hätten das sicher noch viel mehr Leute.

Es wäre also interessant zu erfahren, wie es in deinem Fall zu dem nil-Wert kommt. Es ist gut möglich, daß du da einen viel schwerwiegenderen Fehler in deinem Code hast.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Aviator

Registriert seit: 3. Jun 2010
1.588 Beiträge
 
Delphi 10.3 Rio
 
#4

AW: Bug in Vcl.Forms?

  Alt 25. Okt 2018, 00:48
So etwas hatte ich auch schonmal. Im Endeffekt war es ein Fehler in meinen eigenen Sourcen der sich bis zum Ende nicht bemerkbar gemacht hat. Meistens ein zu früh freigegebenes Objekt auf das am Ende wieder zugegriffen wird oder so.

An den Sourcen von Emba würde ich selbst nicht rumfummeln. Ich meine mich auch zu erinnern, dass es damals die gleiche Stelle war, kann dir aber meinen Fehler nicht mehr sagen.


Die Community Version basiert von den Sourcen her soweit ich weiß auf der 10.2 ohne Updates. Aber da kann sicherlich jemand anderes mehr dazu sagen oder auch einen Beweis vorlegen.
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
7.993 Beiträge
 
Delphi XE4 Professional
 
#5

AW: Bug in Vcl.Forms?

  Alt 25. Okt 2018, 04:09
Hallo,
Erzeuge mal ein neues Projekt mit einem Menü.
Tritt der Fehler jetzt nicht auf, liegt es an Deinem Code.
Heiko
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
8.673 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: Bug in Vcl.Forms?

  Alt 25. Okt 2018, 08:12
Die Community Version basiert von den Sourcen her soweit ich weiß auf der 10.2 ohne Updates. Aber da kann sicherlich jemand anderes mehr dazu sagen oder auch einen Beweis vorlegen.
Die Community Version basiert auf dem letzen Stand 10.2.3 mit allen zur Zeit verfügbaren Updates.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Aviator

Registriert seit: 3. Jun 2010
1.588 Beiträge
 
Delphi 10.3 Rio
 
#7

AW: Bug in Vcl.Forms?

  Alt 25. Okt 2018, 10:57
Die Community Version basiert von den Sourcen her soweit ich weiß auf der 10.2 ohne Updates. Aber da kann sicherlich jemand anderes mehr dazu sagen oder auch einen Beweis vorlegen.
Die Community Version basiert auf dem letzen Stand 10.2.3 mit allen zur Zeit verfügbaren Updates.
  Mit Zitat antworten Zitat
Benutzerbild von p80286
p80286

Registriert seit: 28. Apr 2008
Ort: Stolberg (Rhl)
6.658 Beiträge
 
Delphi 7 Personal
 
#8

AW: Bug in Vcl.Forms?

  Alt 25. Okt 2018, 11:05
Tritt der Fehler jetzt nicht auf, liegt es an Deinem Code.
das sollte sich in der Zwischenzeit herum gesprochen haben. Zumindest Profis wissen das.

Gruß
K-H
Programme gehorchen nicht Deinen Absichten sondern Deinen Anweisungen
R.E.D retired error detector
  Mit Zitat antworten Zitat
Benutzerbild von KodeZwerg
KodeZwerg

Registriert seit: 1. Feb 2018
3.061 Beiträge
 
Delphi 10.3 Rio
 
#9

AW: Bug in Vcl.Forms?

  Alt 25. Okt 2018, 12:08
Hallo,
Erzeuge mal ein neues Projekt mit einem Menü.
Tritt der Fehler jetzt nicht auf, liegt es an Deinem Code.
Interessant finde ich die Sachlage dennoch.
"if <> nil then" aber im abschnitt ist es nil obwohl abfrage <> nil ist.

/edit
oder baue in deiner abfrage if FMenu.WindowHandle <> Nil ein, was passiert dann?
Ich meine, vielleicht hast Du ja ein FMenu object was nur noch kein WindowHandle besitzt?
Gruß vom KodeZwerg

Geändert von KodeZwerg (25. Okt 2018 um 12:12 Uhr)
  Mit Zitat antworten Zitat
TiGü

Registriert seit: 6. Apr 2011
Ort: Berlin
2.812 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#10

AW: Bug in Vcl.Forms?

  Alt 25. Okt 2018, 12:19
Hallo,
Erzeuge mal ein neues Projekt mit einem Menü.
Tritt der Fehler jetzt nicht auf, liegt es an Deinem Code.
Interessant finde ich die Sachlage dennoch.
"if <> nil then" aber im abschnitt ist es nil obwohl abfrage <> nil ist.
Nebenläufigkeit, Threads, Tasks...
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 03:35 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf