AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Es wird keine EXE erstellt

Ein Thema von kwhk · begonnen am 21. Jan 2019 · letzter Beitrag vom 26. Jan 2019
Antwort Antwort
Seite 1 von 3  1 23   
Benutzerbild von kwhk
kwhk

Registriert seit: 25. Mär 2009
Ort: Dresden
148 Beiträge
 
Delphi 10.3 Rio
 
#1

Es wird keine EXE erstellt

  Alt 21. Jan 2019, 23:32
Bei der Übernahme eines Projektes von Delphi 7 => 10.3 ist eigentlich alles OK Ich habe alle Anpassungen gemacht und kann fehlerfrei compilieren und erzeugen. In beiden Fällen wird jedoch keine EXE erstellt, deshalb kann ich auch kein DEBUG oder AUSFÜHREN machen.
Ich habe auf meinen sämtlichen Platten nach der EXE gesucht, aber nichts gefunden.
Ich habe schon einige Delphi 7 Programme auf 10.3 umgestellt, da gab es niemals ein so merkwürdiges Problem.
Hartmut

Geändert von kwhk (21. Jan 2019 um 23:36 Uhr)
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
8.026 Beiträge
 
Delphi 10.4 Sydney
 
#2

AW: Es wird keine EXE erstellt

  Alt 21. Jan 2019, 23:38
Hallo,
startet das Programm denn aus der IDE?
Heiko
  Mit Zitat antworten Zitat
Benutzerbild von kwhk
kwhk

Registriert seit: 25. Mär 2009
Ort: Dresden
148 Beiträge
 
Delphi 10.3 Rio
 
#3

AW: Es wird keine EXE erstellt

  Alt 22. Jan 2019, 00:34
Wenn ich starte, kommt folgende Fehlermeldung:
Prozess kann nicht erzeugt werden. Das System kann die angegebene Datei nicht finden.

Am Anfang habe ich das gar nicht bemerkt.
Ich hatte aus dem Delphi7-Bereich den Ordner in Delphi10.3 kopiert und damit auch die alte EXE.
Da konnte ich compilieren (wie jetzt auch ohne Fehlermeldung), gestartet wurde aber immer die alte EXE.
Ich habe mich gewundert, dass Änderungen am Programm nicht zu erkennen waren.
Dann habe ich die alte EXE gelöscht. Und nun startet nichts mehr.
Die EXE müsste ja in das Projekt-Verzeichnis erstellt werden.

Wenn ich in Projekt => Bereitstellung gehe, dann sehe ganz schwach sichtbar die eigentlich notwendige Zeile.

Lokaler Pfad (ist leer)
Lokaler Name (da steht der EXE-Name)
Typ (ProjectOutput)
Konfiguration (Debug)
Plattformen ([Win32])
Remotepfad (.\)
Remote-Name (wieder der EXE-Name)
Remote-Status (Nicht verbunden)
Überschreiben (Immer)
Hartmut

Geändert von kwhk (22. Jan 2019 um 00:54 Uhr)
  Mit Zitat antworten Zitat
HolgerX

Registriert seit: 10. Apr 2006
Ort: Leverkusen
924 Beiträge
 
Delphi 6 Professional
 
#4

AW: Es wird keine EXE erstellt

  Alt 22. Jan 2019, 05:32
Hmm..

Hast Du beim Erstellen eine Meldung erhalten?
Mal in der Quarantäne deines Virus-Scanners nachgeschaut?

Ich habe an und ab eine Compilierung gemacht und das Ergebnis wurde vom Virenscanner als gefährlich eingestuft, obwohl da glaube ich nur eine Website mit INDY abgerufen wurde...
  Mit Zitat antworten Zitat
Benutzerbild von ConnorMcLeod
ConnorMcLeod

Registriert seit: 13. Okt 2010
Ort: Bayern
439 Beiträge
 
Delphi 10.3 Rio
 
#5

AW: Es wird keine EXE erstellt

  Alt 22. Jan 2019, 07:37
Bei mir sind alle Einstellungen gleich bis auf: Lokaler Pfad (angehakt)
Nr.1 Delphi-Tool: [F7]
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
8.026 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: Es wird keine EXE erstellt

  Alt 22. Jan 2019, 07:38
Hallo,
was passiert bei einem neu erzeugten Projekt, startet das?
Heiko
  Mit Zitat antworten Zitat
Benutzerbild von kwhk
kwhk

Registriert seit: 25. Mär 2009
Ort: Dresden
148 Beiträge
 
Delphi 10.3 Rio
 
#7

AW: Es wird keine EXE erstellt

  Alt 22. Jan 2019, 08:18
Ich habe eine Menge von Projekten. Bei allen wird die EXE erstellt und ich kann das Programm starten, DEBUG-Modus einwandfrei.
Es wird irgendwie mit dem Import von Delphi7 zusammenhängen.
Hartmut
  Mit Zitat antworten Zitat
Benutzerbild von kwhk
kwhk

Registriert seit: 25. Mär 2009
Ort: Dresden
148 Beiträge
 
Delphi 10.3 Rio
 
#8

AW: Es wird keine EXE erstellt

  Alt 22. Jan 2019, 08:19
Bei mir sind alle Einstellungen gleich bis auf: Lokaler Pfad (angehakt)
Der ist bei mir auch angehakt, obwohl die Zeile nur blasses grau anzeigt.
Hartmut
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
8.942 Beiträge
 
Delphi 10.4 Sydney
 
#9

AW: Es wird keine EXE erstellt

  Alt 22. Jan 2019, 08:45
Es wird irgendwie mit dem Import von Delphi7 zusammenhängen.
Kannst du die dproj-Datei hier hochladen?
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Benutzerbild von kwhk
kwhk

Registriert seit: 25. Mär 2009
Ort: Dresden
148 Beiträge
 
Delphi 10.3 Rio
 
#10

AW: Es wird keine EXE erstellt

  Alt 22. Jan 2019, 08:55
Die ZIP habe ich hochgeladen.
Ich habe auf meinem PC mehrere Windows Versionen parallel installiert.
Delphi 10.3 läuft unter Windows 10 (Pro 1809 64bit).
In meinem Win8.1Pro-64 habe ich noch Delphi 10.1 Berlin installiert.
Damit habe ich es probiert, der gleiche Effekt.
Fehlerfreies compilieren / Erstellen.
Keine EXE, kein Ausführen.
Angehängte Dateien
Dateityp: zip HkMp3Dir.zip (3,3 KB, 8x aufgerufen)
Hartmut

Geändert von kwhk (22. Jan 2019 um 08:59 Uhr)
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 3  1 23   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 09:01 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf