AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Mono-Anwendung analysieren

Ein Thema von Lemmy · begonnen am 6. Mär 2019 · letzter Beitrag vom 31. Jan 2020
Antwort Antwort
Seite 1 von 2  1 2   
Lemmy

Registriert seit: 8. Jun 2002
Ort: Berglen
2.277 Beiträge
 
Delphi 10.3 Rio
 
#1

Mono-Anwendung analysieren

  Alt 6. Mär 2019, 22:23
Hallo,

ich weiß, ich bewege mich mit dieser Frage auf ziemlich dünnem Eis, nur weiß ich mir nicht mehr anders zu helfen.

Wir haben ein Zusatztool im Einsatz (bzw. sind dazu vertraglich verpflichtet). Das Tool ist eine Mono-Anwendung, die einen REST-Service bereit stellt, mit dem unsere Anwendung am Ende kommuniziert.

Bei einem Kunden habe ich das Problem, dass das Teil nicht läuft. Konkret heißt das, der Dienst startet zwar beim Windows-Start, beendet sich aber ohne weitere Log-Meldung nach 5-10 Minuten. Dito, wenn ich den Dienst manuell starte.

Der Port auf dem der Webserver eigentlich lauscht ist nicht blockiert bzw. habe auch schon andere Ports ausprobiert, keine Änderung. Auch nach dem Start des Dienstes ist der Port lt. netstat noch frei.

Nun mein Problem: Dem Hersteller ist das um es mal direkt zu sagen Sch**** egal. Software läuft bei x anderen problemlos, also liegts an der Installation.

Letzte Woche aber, der Zufall wollte es wohl, ist das selbe Problem auf einem unserer Rechner aufgetreten. Insofern gehe ich nicht mehr von einem Installationsproblem aus, sondern schon eher von einem Softwareproblem.


Meine Frage: Vom Hersteller erwarte ich aktuell keine Hilfe. Habe ich eine Chance eine (vermutlich obfuskatierte) Mono-Anwendung in irgend einer Form zusätzlich zu überwachen, ggf. in einem Debugmodus auszuführen um zusätzliche Informationen zu erhalten warum das Teil abschmiert?

Grüße


Nachtrag: Hardware vom Kunden: neuer Notebook, WIndows 10, aktuelle Patches eingespielt. Software lief da früher, ab Januar dann nicht mehr. Software wurde schon mehrfach deinstalliert, Reste gelöscht, neu gestartet installiert. Virenscanner, Firewall alles schon abgeschaltet...

Geändert von Lemmy ( 6. Mär 2019 um 22:28 Uhr)
  Mit Zitat antworten Zitat
TiGü

Registriert seit: 6. Apr 2011
Ort: Berlin
2.619 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#2

AW: Mono-Anwendung analysieren

  Alt 6. Mär 2019, 22:42
Sind Mono Anwendung soweit kompatibel, dass man sich den Quelltext mit ILSpy oder Telrik JustDecompile anschauen kann?
So dass du zumindest dir grob einen Überblick verschaffen kannst?
  Mit Zitat antworten Zitat
Lemmy

Registriert seit: 8. Jun 2002
Ort: Berglen
2.277 Beiträge
 
Delphi 10.3 Rio
 
#3

AW: Mono-Anwendung analysieren

  Alt 6. Mär 2019, 22:59
sorry, keinen blassen Schimmer. Werde ich mir morgen mal anschauen ob ich mit den beiden genannten Programmen was anfangen kann
  Mit Zitat antworten Zitat
Benutzerbild von sh17
sh17

Registriert seit: 26. Okt 2005
Ort: Radebeul
1.534 Beiträge
 
Delphi 10.4 Sydney
 
#4

AW: Mono-Anwendung analysieren

  Alt 7. Mär 2019, 08:27
Stürzt das Teil auch ab, wenn man nicht mit ihm kommuniziert? Evtl. mal den HTTP-Traffic überwachen, vielleicht gibt es ja bestimmte Endpunkte, die das Problem verursachen
Sven
--
  Mit Zitat antworten Zitat
TiGü

Registriert seit: 6. Apr 2011
Ort: Berlin
2.619 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#5

AW: Mono-Anwendung analysieren

  Alt 7. Mär 2019, 09:15
Hier mal zwei kleine Videotutorials zu den beiden kostenlosen Tools:
https://www.youtube.com/watch?v=N_fy2pTdMAo
https://www.youtube.com/watch?v=zDQHL99MiKA

Ruhig dann auch in Kombination verwenden. Manche Sachen kann ILSpy besser als Telriks JustDecompile und umgekehrt. Cooles Feature von JustDecompile: Es kann unter den Menüpunkt Tools wieder ein CSPROJ erzeugen.
Das kompiliert zwar immer noch nicht sofort, aber man kann innerhalb von VS navigieren.

Ich suche mal gleich ein OpenSource-Projekt, was mit Mono entwickelt wurde und schaue mal, ob man das mit den Tools öffnen kann.
  Mit Zitat antworten Zitat
TiGü

Registriert seit: 6. Apr 2011
Ort: Berlin
2.619 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#6

AW: Mono-Anwendung analysieren

  Alt 7. Mär 2019, 09:29
Ja, das geht mit beiden Tools.
Habe ich hiermit getestet: http://sky-net.sourceforge.net/screenshots.php

Damit kannst du zumindest erahnen, wenn es halt nicht obfuscated ist, wie da die kritischen Pfade sind.
Mit den Tipp von sh17 solltest du der Sache relativ schnell auf der Spur kommen.
  Mit Zitat antworten Zitat
jsp

Registriert seit: 9. Aug 2003
50 Beiträge
 
#7

AW: Mono-Anwendung analysieren

  Alt 7. Mär 2019, 10:07
@TiGü

Kannte ich bis anhin nicht...
Danke dafür! Wird mir demnächst eine grosse Hilfe sein

Jörn
  Mit Zitat antworten Zitat
Frickler

Registriert seit: 6. Mär 2007
Ort: Osnabrück
313 Beiträge
 
Delphi XE6 Enterprise
 
#8

AW: Mono-Anwendung analysieren

  Alt 7. Mär 2019, 11:05
Nachtrag: Hardware vom Kunden: neuer Notebook, WIndows 10, aktuelle Patches eingespielt. Software lief da früher, ab Januar dann nicht mehr. Software wurde schon mehrfach deinstalliert, Reste gelöscht, neu gestartet installiert. Virenscanner, Firewall alles schon abgeschaltet...
Ab Januar nicht mehr? Eventuell wurde da Windows 10 1809 aufgespielt. Mal ne ältere Version probiert?
  Mit Zitat antworten Zitat
mjustin

Registriert seit: 14. Apr 2008
2.781 Beiträge
 
Delphi 2009 Professional
 
#9

AW: Mono-Anwendung analysieren

  Alt 7. Mär 2019, 11:08
Wollte nur das hier vorschlagen:


https://docs.microsoft.com/en-us/sys...nloads/procmon


Vielleicht hat das Programm einfach nur Probleme aufgrund fehlender Rechte.
In den Windows Ereignisanzeige(n) sind keine Absturzmeldungen zu sehen?

So ein Zufall: Ghidra: NSA stellt quelloffenes Software-Analyse-Tool vor
Michael Justin

Geändert von mjustin ( 7. Mär 2019 um 11:43 Uhr) Grund: Link auf https://www.heise.de/newsticker/meldung/Ghidra-NSA-stellt-quelloffenes-Software-Analyse-Tool-vor-4327737.html
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
16.805 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#10

AW: Mono-Anwendung analysieren

  Alt 7. Mär 2019, 15:11
Wir haben ein Zusatztool im Einsatz (bzw. sind dazu vertraglich verpflichtet) .....

...

Bei einem Kunden habe ich das Problem, dass das Teil nicht läuft. Konkret heißt das, der Dienst startet zwar beim Windows-Start, beendet sich aber ohne weitere Log-Meldung nach 5-10 Minuten. Dito, wenn ich den Dienst manuell starte.

...

Meine Frage: Vom Hersteller erwarte ich aktuell keine Hilfe.
Hast du das schon intern eskaliert?
Es kann ja nicht sein das ihr etwas einsetzen müsste und keine Hilfe bekommt.
Wie du es schilterst hast du ja alles gemacht was man ohne Quellcode oder tiefes Wissen über die Anwendung machen kann.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 03:39 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf