AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

jpeg- fehler #53

Ein Thema von zeina · begonnen am 14. Mai 2019 · letzter Beitrag vom 15. Mai 2019
Antwort Antwort
Seite 2 von 2     12
zeina

Registriert seit: 8. Jun 2018
56 Beiträge
 
#11

AW: jpeg- fehler #53

  Alt 15. Mai 2019, 08:46
.. du könntest bei TMemoryStream bleiben.

Delphi-Quellcode:
type
  TPictureTyp = (pw_None, pw_BMP, pw_JPG, pw_PNG);

function PictureTyp_pruefen(const imageStream: TMemoryStream): TPictureTyp;
var
  Buffer : Word;

begin
  imageStream.Read(Buffer,4);
 //High-Byte und Low-Byte im Buffer tauschen
  //(dadurch stimmt die Byte-Anordnung wieder mit der in der Bild-Datei überein)
  Buffer := Swap(Buffer);

  //Prüfung ob BMP, JPG oder PNG
  case Buffer of
    $424D: Result := pw_BMP;
    $FFD8: Result := pw_JPG;
    $8950: Result := pw_PNG;
  else
    Result := pw_None;
  end;
end;
Nur sehe ich in Deinem Code nicht, wie der MemoryStream "lmstImage" gefüllt wird.

Grüße
Klaus
der MemoryStream wird in dieser Zeile gefüllt

Delphi-Quellcode:
 if lGetRecord(lpTblGraph, 1) then
    begin
{$IFDEF TITAN}
      laImage := GetBlob(lpTblGraph);
{$ENDIF} // DEF TITAN
      lmstImage.Clear;
      lmstImage.Write(laImage[0], Length(laImage));
      lmstImage.Position := 0;
es tritt mir eine Fehler auf:
wenn ich (__).loadFromStream ????

Delphi-Quellcode:
procedure TFormFoto.ZeigeFoto(DB: String; ID: TiBtrvID);
var
  lpTblGraph: TpBtrvDBTableData;
  lbmpImage: TBitmap;
  lmstImage: Tmemorystream;
  laImage : TaByte;
  lgrpImage: TGraphic;
  ljpgImage: TJPEGImage ;
  lpicImage:TPictureTyp ;
    Buffer : Word;

begin
  lbmpImage := nil;
  lmstImage := nil;
  ljpgImage := nil;
  try
    //lbmpImage := TBitmap.Create;
    lmstImage := Tmemorystream.Create;
    ljpgImage := TJPEGImage.Create;

    lpTblGraph := RelData('GR');
    PutSField('GR', 1, DB);
    PutIdField('GR', 2, ID);
    if lGetRecord(lpTblGraph, 1) then
    begin
{$IFDEF TITAN}
      laImage := GetBlob(lpTblGraph);
{$ENDIF} // DEF TITAN
      lmstImage.Clear;
      lmstImage.Write(laImage[0], Length(laImage));
      lmstImage.Position := 0;
      lmstImage.Read(Buffer,4);
      Buffer := Swap(Buffer);
      //lpicImage:= PictureTyp_pruefen(lmstImage);
      case Buffer of
        $FFD8:
          begin
            ljpgImage.LoadFromStream(lmstImage);
            lbmpImage := TBitmap.Create;
            try
              lbmpImage.Assign(ljpgImage);
              lgrpImage.Free;
              lgrpImage := lbmpImage;
              Image1.picture.Graphic := (lgrpImage);
            finally
              lbmpImage.Free;
             end;
           end;
        $424D:
          begin
           lbmpImage.Transparent := True;
            lbmpImage.LoadFromStream(lmstImage);
            lbmpImage.TransparentColor := lbmpImage.Canvas.Pixels[0,lbmpImage.Height - 1];
            lbmpImage.ReleaseMaskHandle;
            lgrpImage.Free;
            lgrpImage := lbmpImage;
            Image1.picture.Graphic := (lgrpImage);
          end;
          $8950:
          begin
          Showmessage('ÄÄ');
          end;
      end;

      FormFoto.Caption := DB + '-' + IntToStr(ID);
      FotoResize;
    end
    else
    begin
      lgrpImage := nil;
    end;
  finally
   // lbmpImage.Free;
    lmstImage.Free;
    ljpgImage.Free;
  end;

end;
  Mit Zitat antworten Zitat
Klaus01

Registriert seit: 30. Nov 2005
Ort: München
5.303 Beiträge
 
Delphi XE7 Professional
 
#12

AW: jpeg- fehler #53

  Alt 15. Mai 2019, 08:52
Delphi-Quellcode:
type
  TPictureTyp = (pw_None, pw_BMP, pw_JPG, pw_PNG);

function PictureTyp_pruefen(const imageStream: TMemoryStream): TPictureTyp;
var
  Buffer : Word;

begin
  imageStream.Read(Buffer,2);
 //High-Byte und Low-Byte im Buffer tauschen
  //(dadurch stimmt die Byte-Anordnung wieder mit der in der Bild-Datei überein)
  Buffer := Swap(Buffer);

  //Prüfung ob BMP, JPG oder PNG
  case Buffer of
    $424D: Result := pw_BMP;
    $FFD8: Result := pw_JPG;
    $8950: Result := pw_PNG;
  else
    Result := pw_None;
  end;
  imageStream.seek(0,soFromBeginning) //zurücksetzen des Lesezeigers im stream
end;
Klaus

Geändert von Klaus01 (15. Mai 2019 um 09:09 Uhr) Grund: 4 mit 2 ersetzt
  Mit Zitat antworten Zitat
Benutzerbild von DeddyH
DeddyH

Registriert seit: 17. Sep 2006
Ort: Barchfeld
26.827 Beiträge
 
Delphi 10.3 Rio
 
#13

AW: jpeg- fehler #53

  Alt 15. Mai 2019, 09:04
Zitat:
Delphi-Quellcode:
var
  Buffer : Word;

begin
  imageStream.Read(Buffer,4);
Nur mal aus Interesse: weshalb werden 4 Byte in einen 2 Byte-Datentyp eingelesen?
Detlef
"Ich habe Angst vor dem Tag, an dem die Technologie unsere menschlichen Interaktionen übertrumpft. Die Welt wird eine Generation von Idioten bekommen." (Albert Einstein)
Dieser Tag ist längst gekommen
  Mit Zitat antworten Zitat
Klaus01

Registriert seit: 30. Nov 2005
Ort: München
5.303 Beiträge
 
Delphi XE7 Professional
 
#14

AW: jpeg- fehler #53

  Alt 15. Mai 2019, 09:08
Nur mal aus Interesse: weshalb werden 4 Byte in einen 2 Byte-Datentyp eingelesen?
ups - muss natürlich 2 sein.
Danke - werde es ausbessern.

Grüße
Klaus
Klaus
  Mit Zitat antworten Zitat
Delphi.Narium

Registriert seit: 27. Nov 2017
1.093 Beiträge
 
Delphi 7 Professional
 
#15

AW: jpeg- fehler #53

  Alt 15. Mai 2019, 11:39
Delphi-Quellcode:
   if lGetRecord(lpTblGraph, 1) then
    begin
{$IFDEF TITAN}
      laImage := GetBlob(lpTblGraph);
{$ENDIF} // DEF TITAN
      lmstImage.Clear;
      lmstImage.Write(laImage[0], Length(laImage));
      lmstImage.Position := 0;
      lmstImage.Read(Buffer,2); // <- geändert
      Buffer := Swap(Buffer);
      //lpicImage:= PictureTyp_pruefen(lmstImage);
      case Buffer of
        $FFD8:
          begin
            lmstImage.Position := 0; // <- neu eingefügt.
            ljpgImage.LoadFromStream(lmstImage);
Fehler #53 heißt, dass ein JPeg kein JPeg ist oder das der Inhalt schlicht und einfach defekt ist. Die Prüfung der ersten beiden Byte auf $FFD8 schließt das Auftreten des Fehlers #53 nicht aus, verringert nur die Wahrscheinlichkeit seines Auftretens.

Speichere den MemoryStream bitte mal als Datei und lass Dir diese von 'nem anderen Programm (oder z. B. in 'nem Browser) anzeigen. Funktioniert das oder wird da auch 'ne Fehlermeldung ausgegeben?

Wenn der Fehler bestehen bleibt: Könntest Du bitte mal eine entsprechende Datei hier anhängen? Eventuell kann man da ja was sehen oder der Fehlerursache irgendwie auf den Grund gehen.
  Mit Zitat antworten Zitat
zeina

Registriert seit: 8. Jun 2018
56 Beiträge
 
#16

AW: jpeg- fehler #53

  Alt 15. Mai 2019, 11:45
Danke an alle ...es Funktioniert
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 22:19 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf