AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Programmieren allgemein Delphi Unit %s wurde mit einer unterschiedlichen version von %s compiliert

Unit %s wurde mit einer unterschiedlichen version von %s compiliert

Ein Thema von delphicoder123 · begonnen am 29. Mai 2019 · letzter Beitrag vom 29. Mai 2019
Antwort Antwort
delphicoder123

Registriert seit: 14. Feb 2019
102 Beiträge
 
#1

Unit %s wurde mit einer unterschiedlichen version von %s compiliert

  Alt 29. Mai 2019, 08:11
Hallo,
ich habe aus meinem Projekt eine Unit entfernt, weil die Unit nicht mehr benötigt wird.
Nach dem compilieren bekomme ich untenstehende Fehlermeldung:

Zitat:
Unit %s wurde mit einer unterschiedlichen Version von %s compiliert
Suchfunktion habe ich auch benutzt, trotzdem verstehe ich nicht, was der Fehler ist.

https://www.delphipraxis.net/147887-...compilier.html
  Mit Zitat antworten Zitat
Der schöne Günther

Registriert seit: 6. Mär 2013
4.959 Beiträge
 
Delphi 10 Seattle Enterprise
 
#2

AW: Unit %s wurde mit einer unterschiedlichen version von %s compiliert

  Alt 29. Mai 2019, 08:14
Eine generelle Faustregel ist dass Uwe Raabe immer Recht hat. Der letzte Beitrag im von dir verlinkten Thema - Dem würde ich einmal nachgehen.
  Mit Zitat antworten Zitat
delphicoder123

Registriert seit: 14. Feb 2019
102 Beiträge
 
#3

AW: Unit %s wurde mit einer unterschiedlichen version von %s compiliert

  Alt 29. Mai 2019, 08:23
Unter Projekt-> Optionen finde ich keinen Eintrag "Bibliothekspfad".
Und woher weiß ich, welcher Pfad da hin gehört?
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
6.903 Beiträge
 
Delphi 10.3 Rio
 
#4

AW: Unit %s wurde mit einer unterschiedlichen version von %s compiliert

  Alt 29. Mai 2019, 08:30
Eine generelle Faustregel ist dass Uwe Raabe immer Recht hat.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Der schöne Günther

Registriert seit: 6. Mär 2013
4.959 Beiträge
 
Delphi 10 Seattle Enterprise
 
#5

AW: Unit %s wurde mit einer unterschiedlichen version von %s compiliert

  Alt 29. Mai 2019, 09:31
Unter Projekt-> Optionen finde ich keinen Eintrag "Bibliothekspfad".
Tools ➡ Optionen
  Mit Zitat antworten Zitat
delphicoder123

Registriert seit: 14. Feb 2019
102 Beiträge
 
#6

AW: Unit %s wurde mit einer unterschiedlichen version von %s compiliert

  Alt 29. Mai 2019, 09:59
Unter Projekt-> Optionen finde ich keinen Eintrag "Bibliothekspfad".
Tools ➡ Optionen
Soweit bin ich auch gekommen. Nurfinde ich nirgendwo "Bibliothekspfad"
Woher weiß ich, welcher Bibliothekspfad, der richtige ist?
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
6.903 Beiträge
 
Delphi 10.3 Rio
 
#7

AW: Unit %s wurde mit einer unterschiedlichen version von %s compiliert

  Alt 29. Mai 2019, 10:06
Vollständig: Tools - Optionen - Umgebungsoptionen - Delphi-Optionen - Bibliothek - Bibliothekspfad (auf ausgewählte Plattform achten!)

Falls du 10.3 hast: Tools - Optionen - Sprache - Delphi-Optionen - Bibliothek - Bibliothekspfad
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
delphicoder123

Registriert seit: 14. Feb 2019
102 Beiträge
 
#8

AW: Unit %s wurde mit einer unterschiedlichen version von %s compiliert

  Alt 29. Mai 2019, 10:15
Vollständig: Tools - Optionen - Umgebungsoptionen - Delphi-Optionen - Bibliothek - Bibliothekspfad (auf ausgewählte Plattform achten!)

Falls du 10.3 hast: Tools - Optionen - Sprache - Delphi-Optionen - Bibliothek - Bibliothekspfad

Und was muss ich beim Bibliothekspfad jetzt angeben? Dieser Fehler tritt auf, wenn ich eine Unit aus dem Projekt entfernt habe.
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
7.178 Beiträge
 
Delphi XE4 Professional
 
#9

AW: Unit %s wurde mit einer unterschiedlichen version von %s compiliert

  Alt 29. Mai 2019, 10:48
Hallo,
lade dir Search Everything herunter.
Suche dort nach der Unitx.* .
Du hast irgendwo eine alte DCU/PAS.
Verschiebe alle PAS/DCU in ein leeres Verzeichnis.

Dann Shift+F9. Irgendwo steht die Unit wohl noch drin, dann raus damit.
Heiko
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 07:04 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf