AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

XML Kommentare

Ein Thema von t2000 · begonnen am 9. Jun 2020 · letzter Beitrag vom 29. Jul 2020
Antwort Antwort
Seite 1 von 2  1 2   
t2000

Registriert seit: 15. Dez 2005
Ort: NRW
67 Beiträge
 
Delphi 10.4 Sydney
 
#1

XML Kommentare

  Alt 9. Jun 2020, 16:17
Hi all,

10.4 Sydney
gibt es bei euch auch ein Problem mit den ///-Kommentaren?
Bei mir werden die gar nicht mehr angezeigt. Es kommt kurz ein winziger ToolTip mit "wird berechnet ..." und dann passiert nichts.
Thomas
(Wir suchen eine(n) Entwickler(in) mit Ambitionen später ggf. das Geschäft zu leiten)
Aktuell nicht mehr. Aber in vielleicht 5 Jahren wird das wieder sehr interessant!
  Mit Zitat antworten Zitat
Benutzerbild von blawen
blawen

Registriert seit: 30. Nov 2003
Ort: Luterbach (CH)
444 Beiträge
 
Delphi 10.3 Rio
 
#2

AW: XML Kommentare

  Alt 9. Jun 2020, 18:01
Hi all,

10.4 Sydney
gibt es bei euch auch ein Problem mit den ///-Kommentaren?
Bei mir werden die gar nicht mehr angezeigt. Es kommt kurz ein winziger ToolTip mit "wird berechnet ..." und dann passiert nichts.
Kann ich so bei mir nicht bestätigen.
Roland
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
811 Beiträge
 
Delphi 10.3 Rio
 
#3

AW: XML Kommentare

  Alt 9. Jun 2020, 22:33
Hallo t2000,

kannst du mal die Situation in der das Auftritt etwas näher beschreiben?
Ja, in 10.4 sind da noch ein paar Kinderkrankheiten drin, wenn's bei dir gar nicht mehr
geht kannst du auch vom LSP auf das alte CodeInsight umschalten.

Dann hast du aber halt auch wieder ErrorInside statt ErrorInsight
  Mit Zitat antworten Zitat
t2000

Registriert seit: 15. Dez 2005
Ort: NRW
67 Beiträge
 
Delphi 10.4 Sydney
 
#4

AW: XML Kommentare

  Alt 10. Jun 2020, 09:33
Ich möchte ungern das neue System abschalten, weil es einfach viel besser ist.
Aber sämtliche Kommentare, egal ob meine eigenen oder auch die von Delphi/Embarcadero selbst, werden nicht mehr angezeigt, wenn die Maus über der Funktion steht.
Das gleiche ist auch bei meinem Kollegen so. Daher wundere ich mich, das es bei euch funktioniert.

Ich weiß nicht, wie ich die Situation näher beschreiben soll. Es ist einfach immer so. Maus über eine Funktion, sollte den Kommentartext anzeigen

Delphi-Quellcode:
/// <summary> Dieser Text sollte angezeigt werden
/// </summary>
function DieseFunktion(ab: String): Integer;
Thomas
(Wir suchen eine(n) Entwickler(in) mit Ambitionen später ggf. das Geschäft zu leiten)
Aktuell nicht mehr. Aber in vielleicht 5 Jahren wird das wieder sehr interessant!
  Mit Zitat antworten Zitat
t2000

Registriert seit: 15. Dez 2005
Ort: NRW
67 Beiträge
 
Delphi 10.4 Sydney
 
#5

AW: XML Kommentare

  Alt 10. Jun 2020, 09:37
Wir haben es gerade nochmal ausprobiert.
Manuell mit Umsch-Strg-H funktioniert es. Aber nicht mehr automatisch.
Thomas
(Wir suchen eine(n) Entwickler(in) mit Ambitionen später ggf. das Geschäft zu leiten)
Aktuell nicht mehr. Aber in vielleicht 5 Jahren wird das wieder sehr interessant!
  Mit Zitat antworten Zitat
t2000

Registriert seit: 15. Dez 2005
Ort: NRW
67 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: XML Kommentare

  Alt 10. Jun 2020, 10:07
Problem gefunden:

Die Anzeige erscheint nicht mehr in der Deklaration. Also dort, wo die Funktion erstellt wurde, sonder NUR NOCH dort, wo man sie benutzt!!

Darauf muss man aber erstmal kommen.
Thomas
(Wir suchen eine(n) Entwickler(in) mit Ambitionen später ggf. das Geschäft zu leiten)
Aktuell nicht mehr. Aber in vielleicht 5 Jahren wird das wieder sehr interessant!
  Mit Zitat antworten Zitat
Benutzerbild von sakura
sakura

Registriert seit: 10. Jun 2002
Ort: München
11.538 Beiträge
 
Delphi 10.4 Sydney
 
#7

AW: XML Kommentare

  Alt 10. Jun 2020, 10:20
Die Anzeige erscheint nicht mehr in der Deklaration. Also dort, wo die Funktion erstellt wurde, sonder NUR NOCH dort, wo man sie benutzt!!
Leider aber auch oft genug dort nicht, lediglich der Hinweis "wird berechnet ..." erscheint. Momentan bin ich extrem genervt vom neuen CodeInsight, welches für mich deutlich öfters komplett nichts anzeigt, als es früher der Fall war.

......
Daniel W.
Ich bin nicht zurück, ich tue nur so
  Mit Zitat antworten Zitat
DasWolf

Registriert seit: 7. Jun 2016
Ort: Neubrandenburg
58 Beiträge
 
Delphi 10.1 Berlin Professional
 
#8

AW: XML Kommentare

  Alt 10. Jun 2020, 10:26
Problem gefunden:

Die Anzeige erscheint nicht mehr in der Deklaration. Also dort, wo die Funktion erstellt wurde, sonder NUR NOCH dort, wo man sie benutzt!!

Darauf muss man aber erstmal kommen.
Das wäre dann ja ein Rückschritt.
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
811 Beiträge
 
Delphi 10.3 Rio
 
#9

AW: XML Kommentare

  Alt 10. Jun 2020, 20:22
Wenn das neue Insight nicht funktioniert läuft evtl. der LSP Prozess nicht...
  Mit Zitat antworten Zitat
Benutzerbild von Jaynder
Jaynder

Registriert seit: 2. Dez 2004
Ort: Süderelbe
134 Beiträge
 
Delphi 10.3 Rio
 
#10

AW: XML Kommentare

  Alt 29. Jul 2020, 11:00
sobald du in einer Klasse eine "class var" definierst, gehen alle danach definierten xml-Kommentare dieser Klasse nicht mehr...
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 06:22 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf