AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Delphi 10.3.3 auf Android 11

Ein Thema von WladiD · begonnen am 24. Okt 2020 · letzter Beitrag vom 18. Aug 2021
Antwort Antwort
Seite 6 von 7   « Erste     456 7   
MichaMD

Registriert seit: 20. Mär 2021
Ort: Magdeburg
18 Beiträge
 
Delphi 10.3 Rio
 
#51

AW: Delphi 10.3.3 auf Android 11

  Alt 20. Mär 2021, 15:36
Moin moin,
Absoluter Anfänger hier(einzige Erfahrung war in der Schule, damals noch mit Delphi 6).
Ich habe das selbe Problem wie die anderen hier, dass sich die App(Hello world erstmal nur) nach 1-2 Sekunden auf dem Android-11-Gerät direkt wieder schliesst.
Bei Embarcadero angerufen und gesagt bekommen, das ich den Workaround hier verwenden soll.
Soweit so gut, allerdings scheine ich dazu zu blöd zu sein.^^

Ich habe in AndroidManifest.template:
<uses-sdk android:minSdkVersion="%minSdkVersion%" android:targetSdkVersion="%targetSdkVersion%" />
zu
<uses-sdk android:minSdkVersion="%minSdkVersion%" android:targetSdkVersion="29" />
oder
<uses-sdk android:minSdkVersion="%minSdkVersion%" android:targetSdkVersion=29 />
oder
<uses-sdk android:minSdkVersion="%minSdkVersion%" android:targetSdkVersion="30" />
oder
<uses-sdk android:minSdkVersion="%minSdkVersion%" android:targetSdkVersion=30 />
abgeändert, ohne Erfolg.

Dann habe ich die beiden Datein
build_script.zip
und
missing_source_files.zip
runtergeladen und build_script ausgeführt.
Immernoch kein Erfolg.

Dann %USERPROFILE%\build im explorer eingegeben und die beiden Ordner Android und Android64 in meinem entsprechenden Projektordner ausgetauscht.

... immernoch kein Erfolg.

Jetzt die Frage, was habe ich übersehen oder falsch gemacht?^^
  Mit Zitat antworten Zitat
linus_wildcat

Registriert seit: 25. Jun 2008
Ort: Hamburg
33 Beiträge
 
Delphi 10.3 Rio
 
#52

AW: Delphi 10.3.3 auf Android 11

  Alt 20. Mär 2021, 23:30
Guten Abend zusammen,

als alter Delphi-Hase (habe in den späten 80ern bei Borland gearbeitet und selber noch Delphi 1 !!! auf den Markt gebracht, verzeiht, ich war das) und programmiere immer wieder mal ein wenig nur so zum Spaß und wollte jetzt mal für Android anfangen zu coden.

Dank des Fixes von WladiD (Vielen Dank dafür!!!) geht das ja auch mit der CE.

Aber ich habe folgendes Problem, in der Hoffnung, dass das hier jemand auflösen kann.

Ich habe zwei Rechner, einen Desktop und ein (recht neues) Windows-Tablet.
Beide haben den gleichen Windows10-Build-Stand.
Auf beiden läuft D10.3.3-CE mit dem Fix einwandfrei.

Mein Handy (Samsung S10+) hat Entwicklermodus und USB-Debugging eingeschaltet und auf beiden Rechnern taucht es identisch und fehlerfrei im Gerätemanager auf.

Aber auf dem Tablet erscheint es in Delphi einfach nicht in der Projektverwaltung unter Ziel.

Ich habe keine Ahnung was das sein kann.

Danke schon mal....

Kai
Kai
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
3.354 Beiträge
 
Delphi 10.4 Sydney
 
#53

AW: Delphi 10.3.3 auf Android 11

  Alt 21. Mär 2021, 09:35
und selber noch Delphi 1 !!! auf den Markt gebracht, verzeiht, ich war das)

Hallo Kai,
habe selber nicht mit D1 gearbeitet, war da mehr auf C/C++, aber trotzdem Danke dafür das überhaupt angestossen zu haben



Mein Handy (Samsung S10+) hat Entwicklermodus und USB-Debugging eingeschaltet und auf beiden Rechnern taucht es identisch und fehlerfrei im Gerätemanager auf.
Wichtig ist ob die AndroidDebugBridge das Gerät erkennt, ansonsten ist es für Delphi (und Andere) nicht vorhanden.

adb_path=C:\Users\Public\Documents\Embarcadero\Stu dio\%D_VerCode%\CatalogRepository\AndroidSDK-%D_SdkCode%%D_VerCode%.%and_folder%\platform-tools
echo . ADB full path %adb_path%

%adb_path%\adb.exe devices
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu
Online

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
38.964 Beiträge
 
Delphi 10.4 Sydney
 
#54

AW: Delphi 10.3.3 auf Android 11

  Alt 21. Mär 2021, 11:50
Zitat:
Wichtig ist ob die AndroidDebugBridge das Gerät erkennt
Es kann auch bedeuten, dass für das Gerät eventuell erst ein Treiber installiert werden muß, damit ADB dieses Gerät findet/versteht.

Und auch kann der USB-Port unterschiedlich konfiguriert sein.
Nur weil die Entwickleroptionen aktiviert wurden, ist USB nicht unbedingt für ADB freigeschaltet.
Der USB-Port lässt sich ja oft für NurLaden (es reagiert auf nichts), als MediaDevice (Fotos oder Videos), wie eine SD-Karte oder eben für FastBoot/AndroidDebugBridge uvm. einstellen, also als welches "Gerät" es vom PC erkannt wird und welche Protokolle es unterstützt.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
3.354 Beiträge
 
Delphi 10.4 Sydney
 
#55

AW: Delphi 10.3.3 auf Android 11

  Alt 21. Mär 2021, 12:30
Es kann auch bedeuten, dass für das Gerät eventuell erst ein Treiber installiert werden muß, damit ADB dieses Gerät findet/versteht.
Richtig, da hat mir bei Samsung SmartSwitch geholfen.
Auch bei S10+, neuere Samsung Geräte habe ich noch nicht getestet.
  Mit Zitat antworten Zitat
linus_wildcat

Registriert seit: 25. Jun 2008
Ort: Hamburg
33 Beiträge
 
Delphi 10.3 Rio
 
#56

AW: Delphi 10.3.3 auf Android 11

  Alt 21. Mär 2021, 13:41
Wie gesagt, Entwicklermodus und USB-Debugging sind auf meinem Samsung aktiviert.

Wenn ich es an den großen Desktop anschließe, fragt mich Windows, was mit dem Gerät passieren soll -> Dateiübertragung und am Handy kann ich das auch so einschalten (anstatt nur laden) -> geht.

Schließe ich es am Tablet an, kommen auch diese Fragen auf beiden Geräten -> geht nicht.

Auf beiden Rechnern taucht es auch identisch im Gerätemanager auf.
Zugegeben, auf dem Tablet tauchte es erst auf, als ich den offiziellen Samsung-Treiber installiert habe.
Auf dem "Dicken" schien das wohl mal automatisch passiert zu sein....

Einziger Unterschied: Desktop: USB-2, Tablet: USB-3

Test über CMD
Code:
C:\Users\kaijo>echo %adb_path%
C:\Users\Public\Documents\Embarcadero\Studio\20.0\CatalogRepository\AndroidSDK-2525_20.0.36039.7899\platform-tools

C:\Users\kaijo>%adb_path%\adb.exe devices
List of devices attached
R58M437J4VH    unauthorized
Also gesehen wird es mit der richtigen Seriennummer, warum Delphi es nicht sieht....keine Ahnung.

Danke schon mal für jeden sachdienlichen Hinweis.
Kai
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
3.354 Beiträge
 
Delphi 10.4 Sydney
 
#57

AW: Delphi 10.3.3 auf Android 11

  Alt 21. Mär 2021, 13:48
Versuch mal das

Zitat:
Resolution
Possible solutions if "adb devices" shows a device as "unauthorized":

C:\Users\JohnDoo>adb devices
List of devices attached
17310D821D unauthorized

Disconnect USB between PC and device
Stop adb server by entering "adb kill-server" in command window
On device use "Revoke USB debugging authorizations" in "Developer Options"
On PC delete "adbkey" file in user directory, for example "C:\Users\JohnDoo\.android"
Reconnect the device to the PC
Open a command window and enter "adb devices". Watch the device's screen for any Authorization message and allow the connection.

The device should now show as "device":


C:\Users\JohnDoo>adb devices
List of devices attached
17310D821D device

If the above does not help, re-installing adb and or USB drivers may help.
  Mit Zitat antworten Zitat
linus_wildcat

Registriert seit: 25. Jun 2008
Ort: Hamburg
33 Beiträge
 
Delphi 10.3 Rio
 
#58

AW: Delphi 10.3.3 auf Android 11

  Alt 21. Mär 2021, 15:19
Tja, leider nichts gebracht.

Der "richtige" Samsung Treiber ist installiert und das Handy steht als "Samsung Android ADB Interface" im Gerätemanager, ADB wird ja von Delphi mitgeliefert, aber das unauthorized will einfach nicht gehen.
Kai
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
3.354 Beiträge
 
Delphi 10.4 Sydney
 
#59

AW: Delphi 10.3.3 auf Android 11

  Alt 21. Mär 2021, 15:28
Tja, leider nichts gebracht.
Woher hast Du den Treiber ?

Zitat:
Einziger Unterschied: Desktop: USB-2, Tablet: USB-3
Ich benutze einen USB3-zu-USB2 Hub, um mögliche USB3 Probleme zu Vermeiden.
Mir ist aber auch mit USB3 nichts Negatives bekannt ...

Manchmal ist es auch nur das falsche USB-Kabel

Geändert von Rollo62 (21. Mär 2021 um 15:31 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu
Online

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
38.964 Beiträge
 
Delphi 10.4 Sydney
 
#60

AW: Delphi 10.3.3 auf Android 11

  Alt 21. Mär 2021, 15:44
Falls es mit USB-3 Probleme gibt, dann lässt sich im Gerätemanager das USB-3 deaktiveren,
denn USB 1+2 und USB 3 sind zwei getrennte Controller.
Ist USB 3 deaktiviert, bleibt USB 2 zurück, bzw. wird ein USB 3-Gerät vom Controller erkannt, dann wird auf den USB 3-Controller umgeschaltet, aber wenn es den nicht mehr gibt, dann bleibt es bei USB 2. (oder man kann auch einfach ein USB 2-Kabel verwenden)
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014

Geändert von himitsu (21. Mär 2021 um 16:19 Uhr)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 03:02 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf