AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

IDE falsche Fehleranzeige

Ein Thema von t2000 · begonnen am 7. Jan 2021 · letzter Beitrag vom 8. Jan 2021
Antwort Antwort
Benutzerbild von t2000
t2000

Registriert seit: 16. Dez 2005
Ort: NRW
161 Beiträge
 
Delphi 10.4 Sydney
 
#1

IDE falsche Fehleranzeige

  Alt 7. Jan 2021, 16:30
Hi Leute,

das war bestimmt schon mehrfach ein Thema, aber ich dachte mit 10.4 bzw. 10.4.1 ist das so langsam mal in Ordnung.

Ich habe fast immer in der IDE diese rote Fehleranzeige. Projekt kann ich compilieren, Projekt erzeugen, auf die Fehlerstelle klicken und "Deklaration suchen", usw. Alles funktioniert.
Aber die Fehlerliste verschwindet einfach nicht. Ach nicht nach Neustart der IDE. Alle Units befinden sich im Projekt.
Manchmal ist es sauber, aber meistens nicht.

Kann man dagen was machen?

Hier die Grafik dazu
Miniaturansicht angehängter Grafiken
screenshot-2021-01-07-162421.jpg  
Thomas
(Wir suchen eine(n) Entwickler(in) mit Ambitionen später ggf. die Softwarefirma zu leiten)
Aktuell nicht mehr. Aber ab vielleicht 2023/2024 wird das wieder sehr interessant!
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
8.135 Beiträge
 
Delphi 10.4 Sydney
 
#2

AW: IDE falsche Fehleranzeige

  Alt 7. Jan 2021, 20:57
Das habe ich in 10.4 mit LSP tatsächlich noch nicht geschafft. Manchmal kam schlicht gar nichts mehr, aber falsche Fehler oder so sind mir bisher nicht aufgefallen.

Du hast aber nicht Classic Code Insight eingestellt, oder?
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
38.709 Beiträge
 
Delphi 10.4 Sydney
 
#3

AW: IDE falsche Fehleranzeige

  Alt 7. Jan 2021, 22:14
Die Unbekannt-Fehler selbst können Folgefehler sein.
Für ein paar Units wurden keine Infos gefunden, bzw. sie konnten nicht compiliert werden,
und anschließend fehlen in den nächsten Units die von dort vorhandenen Typen/Methoden/...


Bei vielen Units steht die Zeile dazu.
Wäre bestimmt interessant, was sich dort befindet.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
Benutzerbild von t2000
t2000

Registriert seit: 16. Dez 2005
Ort: NRW
161 Beiträge
 
Delphi 10.4 Sydney
 
#4

AW: IDE falsche Fehleranzeige

  Alt 8. Jan 2021, 08:54
Dies ist nicht dauerhaft. Nachdem ich den PC neu gebootet habe und auch einige (sehr wenige) Programmänderungen gemacht habe, war alls wieder gut.
Das ist ja das blöde. Es taucht mal auf und ist dann auch irgendwann wieder weg.
Es ist aber nicht durch compilieren oder erzeugen zu machen.

Und nein, ich arbeite nicht auf classic.
Thomas
(Wir suchen eine(n) Entwickler(in) mit Ambitionen später ggf. die Softwarefirma zu leiten)
Aktuell nicht mehr. Aber ab vielleicht 2023/2024 wird das wieder sehr interessant!
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 18:48 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf