AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Delphi-PRAXiS - Lounge Klatsch und Tratsch Windows Cache beim Laden der EXE spinnt...oder?

Windows Cache beim Laden der EXE spinnt...oder?

Ein Thema von haentschman · begonnen am 11. Jun 2021 · letzter Beitrag vom 15. Jun 2021
Antwort Antwort
Seite 1 von 3  1 23   
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.837 Beiträge
 
Delphi 10.1 Berlin Professional
 
#1

Windows Cache beim Laden der EXE spinnt...oder?

  Alt 11. Jun 2021, 07:17
Hallöle...

Ich habe eine Exe die auf dem Server im lokalen Netz gespeichert ist. Die Clients laden die EXE von da. Bis jetzt ist es nichts außergewöhnliches...

PROBLEM:
An verschiedenen Arbeitsstationen wird eine alte Version, trotz Neustart der EXE, im Arbeitsspeicher gehalten. Das Dateidatum = EXE Datum (im Menü angezeigt) lautet aber auf die letzte Version.

Beispiel:

1. EXE Datum 10.06.2021 10:00, kein Button auf der Form.
2. Button auf Form hinzugefügt
3. Neustart der EXE vom Server
4. EXE Datum 11.06.2021 07:00, kein Button auf der Form.
5. Neustart des gesamten Computers. (mehrfacher Neustart der EXE bringt es nicht)
6. EXE Datum 11.06.2021 07:00, Button auf der Form.

Ich habe das Gefühl, daß das immer die gleichen Arbeitsstationen sind, wo die EXE nicht "ausgetauscht" wird.

Kann man das irgendwie Prüfen? Eher Server oder Arbeitsstation?
Auch unser EDV Fuzzi ist ratlos...

Danke für Infos...

Crosspost: https://en.delphipraxis.net/topic/51...ing-the-exeor/

Geändert von haentschman (11. Jun 2021 um 08:00 Uhr)
  Mit Zitat antworten Zitat
CCRDude

Registriert seit: 9. Jun 2011
661 Beiträge
 
FreePascal / Lazarus
 
#2

AW: Windows Cache beim Laden der EXE spinnt...oder?

  Alt 11. Jun 2021, 08:40
Manchmal führen Bugs ja dazu, dass Prozesse nicht komplett "schließen". Dann ist die UI schon weg, aber der Prozess läuft bzw. hängt noch. In so einem Fall hätte der PE Loader die exe ja schon im Speicher und würde sie u.U. nicht neu laden. Also als Idee: im Task Manager prüfen, ob wirklich alle Instanzen beendet sind.
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.837 Beiträge
 
Delphi 10.1 Berlin Professional
 
#3

AW: Windows Cache beim Laden der EXE spinnt...oder?

  Alt 11. Jun 2021, 08:44
Zitat:
Also als Idee: im Task Manager prüfen, ob wirklich alle Instanzen beendet sind.
...sind definitiv alle weg.

Zitat:
u.U. nicht neu laden.
...warum stimmt dann die geladene EXE (Datum neuestes) nicht mit der Form (Inhalt) überein?

Geändert von haentschman (11. Jun 2021 um 08:46 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.837 Beiträge
 
Delphi 10.1 Berlin Professional
 
#4

AW: Windows Cache beim Laden der EXE spinnt...oder?

  Alt 11. Jun 2021, 09:01
Nachtrag Info:
Früher mußte ich auf dem Server alle Instanzen "abschießen" um eine neue Version einzuspielen. Bei 15+ Nutzern ist das tagsüber schlecht...

Deshalb habe einen "Finalbuilder Light" erstellt der über ein Tool die aktuelle EXE umbenennt und in einen Order verschiebt der die Versionskennzeichnung hat. Das hat keine Auswirkung auf die Laufzeit. Über ein anderes Tool wird geprüft noch ein User Zugriff hat...wenn nicht, wird der Ordner entfernt.

Damit kann ich jederzeit die Version tauschen und muß nicht alle abschießen.

Mit der Kopie kann es eigentlich nichts zu tun haben, weil immer nur die aktuelle EXE geladen wird...oder?
Miniaturansicht angehängter Grafiken
order1.png  

Geändert von haentschman (11. Jun 2021 um 11:18 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
8.144 Beiträge
 
Delphi 10.4 Sydney
 
#5

AW: Windows Cache beim Laden der EXE spinnt...oder?

  Alt 11. Jun 2021, 09:08
Mit der Kopie kann es eigentlich nichts zu tun haben, weil immer nur die aktuelle EXE geladen wird...oder?
Windows leitet intern die Zugriffe auf die umbenannte Version um. Nur deshalb kannst du diese auch im laufenden Betrieb umbenennen. Wie das genau funktioniert, weiß ich nicht, aber ich vermute der Server muss damit etwas zu tun haben, denn dort wird die Exe ja schließlich trotz Zugriffs umbenannt.

Eine ganz einfache Lösung, die wirklich immer zuverlässig funktioniert:
Ein Loader (der kann ja wie die ursprüngliche Exe heißen) startet die jeweils aktuelle Exe, die unter einem Namen mit Versionsnummer, wie du es ja schon für alte Versionen hast, gespeichert wird. Der Loader kann die neueste vorhandene Exe nehmen, die korrekte aus einer .ini lesen, wie auch immer.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.837 Beiträge
 
Delphi 10.1 Berlin Professional
 
#6

AW: Windows Cache beim Laden der EXE spinnt...oder?

  Alt 11. Jun 2021, 09:17
Zitat:
Ein Loader (der kann ja wie die ursprüngliche Exe heißen) startet die jeweils aktuelle Exe
...den habe ich schon. Der lädt immer die aktuelle EXE. Im Menü (Bild) wurde auch die richtige Version angezeigt, aber der "Inhalt" der EXE war falsch.
Miniaturansicht angehängter Grafiken
version.png  
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
8.144 Beiträge
 
Delphi 10.4 Sydney
 
#7

AW: Windows Cache beim Laden der EXE spinnt...oder?

  Alt 11. Jun 2021, 10:01
Zitat:
Ein Loader (der kann ja wie die ursprüngliche Exe heißen) startet die jeweils aktuelle Exe
...den habe ich schon. Der lädt immer die aktuelle EXE.
Der sollte aber eine Exe mit der Versionsnummer im Namen laden, das meine ich. Dann muss nichts umbenannt werden und das ganze Problem kann nicht mehr auftreten.

Du hast übrigens zwar die Dateinamen verpixelt, nicht aber den vermutlich gleichnamigen Ordnernamen oben.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Redeemer

Registriert seit: 19. Jan 2009
Ort: Kirchlinteln (LK Verden)
793 Beiträge
 
Delphi 2009 Professional
 
#8

AW: Windows Cache beim Laden der EXE spinnt...oder?

  Alt 11. Jun 2021, 10:31
Ich möchte nochmal folgenden Satz hervorheben:
Windows leitet intern die Zugriffe auf die umbenannte Version um.
Genau das ist das Problem (aber nur, wenn die Datei zum Zeitpunkt der Umbenennung gesperrt ist). Da kommst du auch nicht drum rum. Möglicherweise PE-Flag NET_RUN_FROM_SWAP (oder wie das heißt) ausmachen, das verhält sich aber sowieso total seltsam und ist auch keine gute Idee.

Mein Hauptprojekt hat im LAN daher für den LAN-Start einen kleinen Launcher, der die neuste Version sucht und startet. Es kann alternativ in %LOCALAPPDATA% kopiert werden und läuft dann mit einem Updater.
Janni
2005 PE, 2009 PA, XE2 PA
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.837 Beiträge
 
Delphi 10.1 Berlin Professional
 
#9

AW: Windows Cache beim Laden der EXE spinnt...oder?

  Alt 11. Jun 2021, 11:27
Danke an alle...
Zitat:
Der sollte aber eine Exe mit der Versionsnummer im Namen laden, das meine ich.
keine schlechte Idee.
Zitat:
Mein Hauptprojekt hat im LAN daher für den LAN-Start einen kleinen Launcher, der die neuste Version sucht und startet. Es kann alternativ in %LOCALAPPDATA% kopiert werden
auch eine Alternative.
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
16.911 Beiträge
 
Delphi 10.4 Sydney
 
#10

AW: Windows Cache beim Laden der EXE spinnt...oder?

  Alt 11. Jun 2021, 13:29
Wurde auch der Server schon neu gestartet?
Der client wurde ja schon.

Hatten bei uns mal den Fall das der Virenscanner auf dem Server komplett im Wald und schein dafür gesorgt hat das irgendwelche Dateifragmente ausgeliefert wurden.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 3  1 23   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 03:31 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf