AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Delphi 5 zeigt keine Fehlermeldung an

Ein Thema von LikeMike · begonnen am 1. Sep 2021 · letzter Beitrag vom 19. Sep 2021
Antwort Antwort
Seite 1 von 2  1 2   
LikeMike

Registriert seit: 18. Jul 2005
16 Beiträge
 
#1

Delphi 5 zeigt keine Fehlermeldung an

  Alt 1. Sep 2021, 18:36
Hallo!
Das Thema gibt es schon im Forum - leider ohne Lösung, daher hier praktisch das gleiche Problem.
Ohne dass ich bewusst etwas geändert hätte, werden in meinem Programm keine Fehlermeldungen mehr angezeigt (in der compilierten Version).

Schon diese ganz einfache Procedure sollte ja direkt eine Division durch 0 melden - es geschieht aber nichts - nada:
Code:
procedure TFHaupt.Button4Click(Sender: TObject);
VAR
  a,b : INTEGER;
begin
  a:=6; b:=0;
  showmessage(inttostr(a DIV b));
end;
Beim Debuggen erscheint natürlich sofort eine Meldung, aber nicht in der compilierten Version.
Welchen Schalter könnte ich da erwischt haben (Delphi 5 Enterprise).

Danke im voraus
Mike
  Mit Zitat antworten Zitat
Benutzerbild von dummzeuch
dummzeuch

Registriert seit: 11. Aug 2012
Ort: Essen
933 Beiträge
 
Delphi 2007 Professional
 
#2

AW: Delphi 5 zeigt keine Fehlermeldung an

  Alt 1. Sep 2021, 19:25
Das Thema gibt es schon im Forum - leider ohne Lösung, daher hier praktisch das gleiche Problem.
Ohne dass ich bewusst etwas geändert hätte, werden in meinem Programm keine Fehlermeldungen mehr angezeigt (in der compilierten Version).

Schon diese ganz einfache Procedure sollte ja direkt eine Division durch 0 melden - es geschieht aber nichts - nada:
Code:
procedure TFHaupt.Button4Click(Sender: TObject);
VAR
  a,b : INTEGER;
begin
  a:=6; b:=0;
  showmessage(inttostr(a DIV b));
end;
Beim Debuggen erscheint natürlich sofort eine Meldung, aber nicht in der compilierten Version.
Welchen Schalter könnte ich da erwischt haben (Delphi 5 Enterprise).
Sowas kann theoretisch durch eine DLL hervorgerufen werden, die das Floating Point Control Word ändert.

http://www.nacad.ufrj.br/online/inte...ps_contw_f.htm

Das ist aber reine Spekulation. Wobei: Das ist ja eigentlich eine Integer-Operation, die die FPU gar nicht verwenden sollte.
Thomas Mueller
  Mit Zitat antworten Zitat
LikeMike

Registriert seit: 18. Jul 2005
16 Beiträge
 
#3

AW: Delphi 5 zeigt keine Fehlermeldung an

  Alt 1. Sep 2021, 20:26
Hallo!
Danke für die Antwort.
Aber es tritt gar keine Fehlermeldung auf. Ich habe bewusst Datenbankfehler einprogrammiert (Zugriff auf Felder, die gar nicht existieren) etc.
Es erscheint trotzdem nie eine Fehlermeldung.

Es muss irgendwas in meiner Hauptsoftware sein, denn wenn ich ein Testprogramm erstelle (z.B. nur mit der fehlerhaften Procedure oben) funktioniert alles, wie es soll.
  Mit Zitat antworten Zitat
Lemmy

Registriert seit: 8. Jun 2002
Ort: Berglen
2.293 Beiträge
 
Delphi 10.3 Rio
 
#4

AW: Delphi 5 zeigt keine Fehlermeldung an

  Alt 1. Sep 2021, 20:33
Hallo!
Danke für die Antwort.
Aber es tritt gar keine Fehlermeldung auf. Ich habe bewusst Datenbankfehler einprogrammiert (Zugriff auf Felder, die gar nicht existieren) etc.
Es erscheint trotzdem nie eine Fehlermeldung.

Es muss irgendwas in meiner Hauptsoftware sein, denn wenn ich ein Testprogramm erstelle (z.B. nur mit der fehlerhaften Procedure oben) funktioniert alles, wie es soll.
Vollcompile schon mal gemacht? und sicher, dass du die korrekte Unit änderst und nicht zufällig ne Unit, die gar nicht Bestandteil des Projektes ist? Einfach mal QUatsch rein schreiben in die Unit.
  Mit Zitat antworten Zitat
LikeMike

Registriert seit: 18. Jul 2005
16 Beiträge
 
#5

AW: Delphi 5 zeigt keine Fehlermeldung an

  Alt 1. Sep 2021, 20:58
Ja - alles mehrfach durchcompiliert. Wir reden hier allerdings von über 200 Units mit > 2.000.000 Programmierzeilen. Die Software wird ständig erweitert und ich weiß nicht, seit wann genau dieses Verhalten auftritt (keine Fehlermeldung ist ja vordergründig eine gute Nachricht).
Die Frage geht also eher in die Richtung wie man so ein Verhalten überhaupt provozieren könnte. Dann könnte ich vielleicht auf dem umgekehrten Weg Rückschlüsse auf den fehlerhaften Programmteil ziehen.
  Mit Zitat antworten Zitat
Der schöne Günther

Registriert seit: 6. Mär 2013
5.718 Beiträge
 
Delphi 10 Seattle Enterprise
 
#6

AW: Delphi 5 zeigt keine Fehlermeldung an

  Alt 1. Sep 2021, 21:00
Du kannst auch eine Release-Fassung im Debugger laufen lassen. Da sollte die Exception auch auftreten, richtig?

Die Frage ist ja, wie du explizit schreibst, dass sie dem Benutzer nicht angezeigt wird. Das kann man abstellen, indem man z.B. seinen eigenen (leeren) Exception-Handler in der VCL registriert, aber sowas macht man sicher nicht mal "aus Versehen". Aber so klingt es, denn der Benutzer hat in der Debug-Fassung ebenfalls keine Messagebox welche den Fehler anzeigt, richtig?
  Mit Zitat antworten Zitat
LikeMike

Registriert seit: 18. Jul 2005
16 Beiträge
 
#7

AW: Delphi 5 zeigt keine Fehlermeldung an

  Alt 1. Sep 2021, 21:06
Wie lasse ich eine Release-Fassung im Debugger laufen?
  Mit Zitat antworten Zitat
Der schöne Günther

Registriert seit: 6. Mär 2013
5.718 Beiträge
 
Delphi 10 Seattle Enterprise
 
#8

AW: Delphi 5 zeigt keine Fehlermeldung an

  Alt 1. Sep 2021, 21:28
Ich hätte gesagt F9 drücken? Wenn du die Release-Fassung erstellen kannst, dann kannst du sie doch auch debuggen?

Aber sorry, Delphi 5 - Da kann ich nicht helfen. Als das raus kam bin ich noch in die Grundschule 👶 gegangen, und heute bin ich so alt dass ich keine Haare mehr auf dem Kopf habe. Das sollte einen auch mal zum Überlegen bringen, ob man nicht eh mal auf was neueres wechseln sollte - Da können dann vielleicht auch mehr Leute helfen 😉
  Mit Zitat antworten Zitat
LikeMike

Registriert seit: 18. Jul 2005
16 Beiträge
 
#9

AW: Delphi 5 zeigt keine Fehlermeldung an

  Alt 1. Sep 2021, 21:39
Schon richtig, aber ich arbeite natürlich auch mit Delphi Sydney und fast allen Vorgängern, aber bei so einem verzahnten und umfangreichen System mit 100ten von Komponenten (die es teilweise gar nicht mehr in neueren Version zu kaufen gibt) bleibt mir nichts anderes übrig, als mit Delphi 5 weiter zu machen.
Aber nochmal zum Debuggen. Wenn ich mit F9 compiliere erhalte ich schon die Debugger-Fehlermeldung. Die Meldung, die dem Benutzer aber im Normalfall angezeigt würde, erscheint da aber eben auch nicht.
  Mit Zitat antworten Zitat
Der schöne Günther

Registriert seit: 6. Mär 2013
5.718 Beiträge
 
Delphi 10 Seattle Enterprise
 
#10

AW: Delphi 5 zeigt keine Fehlermeldung an

  Alt 1. Sep 2021, 22:06
Alles klar, dann hört sich das tatsächlich so an, als sei nur die Messagebox für den Benutzer vorm Bildschirm abgeschaltet.

Weise doch mal testweise das OnException -Event zu, wie hier in diesem Beispiel:
https://docwiki.embarcadero.com/Code...ption_(Delphi)

Dann wird doch hoffentlich was angezeigt, oder?
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 06:36 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf