AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Enabled funktioniert nicht

Ein Thema von Amalkotey · begonnen am 10. Sep 2021 · letzter Beitrag vom 14. Sep 2021
Antwort Antwort
Seite 2 von 2     12
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
38.607 Beiträge
 
Delphi 10.4 Sydney
 
#11

AW: Enabled funktioniert nicht

  Alt 10. Sep 2021, 17:09
Zitat:
Delphi-Quellcode:
//if chk1.Checked = True then
  rb2.Enabled := False
//else
  rb2.Enabled := False;
Ähhhhhhh?

Fällt wem in diesem Quote was auf? (da wo nichts auskommentiert wurde)


Zitat:
if ABoolean = True then
Sowas macht man auch nicht!

Diese Konstanten am Besten immer nur ausschließlich für Zuweisungen verwenden ... niemals für Vergleiche.


Delphi-Quellcode:
if chk1.Checked then
  rb2.Enabled := True
else
  rb2.Enabled := False;

// oder

if not chk1.Checked then
  rb2.Enabled := False
else
  rb2.Enabled := True;
Außerdem: Warum will man überhaupt sowas machen, wenn doch ...?

Delphi-Quellcode:
rb2.Enabled := chk1.Checked;

// oder andersrum

rb2.Enabled := not chk1.Checked;
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014

Geändert von himitsu (10. Sep 2021 um 17:13 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Amalkotey
Amalkotey

Registriert seit: 9. Feb 2004
Ort: Oberhausen
36 Beiträge
 
Delphi 2007 Enterprise
 
#12

AW: Enabled funktioniert nicht

  Alt 10. Sep 2021, 17:14
Ok, hast recht. Geht aber an dem Problem vor bei. Sobald die Maus auf der Form ist, werden die Radiobuttons dargestellt und sind anwählbar.
esdaS© - ESPRIT DATA SOFTWARE
[esdaS© := Software mit Charisma und Esprit]
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
8.106 Beiträge
 
Delphi 10.4 Sydney
 
#13

AW: Enabled funktioniert nicht

  Alt 10. Sep 2021, 21:03
Häng doch einfach mal das komplette Testprojekt inkl. Exe gezippt hier an. Dann lässt sich ganz einfach feststellen, ob es an dem Projekt, dem Kompilat (Virus?) oder (wenn es bei anderen geht) wirklich an deinem System liegt (was ich komisch fände).
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Benutzerbild von Amalkotey
Amalkotey

Registriert seit: 9. Feb 2004
Ort: Oberhausen
36 Beiträge
 
Delphi 2007 Enterprise
 
#14

AW: Enabled funktioniert nicht

  Alt 14. Sep 2021, 21:26
Vielen Dank für die Hilfe. Ich habe jetzt meinen Entwickler-Notebook neu aufgesetzt und das Problem ist triit nicht auf. Ich denke es lag an einem Update. Ich konnte leider nicht herauf finden, an welchen.

-Amalkotey-
esdaS© - ESPRIT DATA SOFTWARE
[esdaS© := Software mit Charisma und Esprit]
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 17:42 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf