AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi TSQLMontor zeigt nichts an

TSQLMontor zeigt nichts an

Ein Thema von horstmeyer · begonnen am 14. Sep 2021 · letzter Beitrag vom 14. Sep 2021
Antwort Antwort
Seite 1 von 2  1 2   
horstmeyer

Registriert seit: 9. Aug 2021
16 Beiträge
 
#1

TSQLMontor zeigt nichts an

  Alt 14. Sep 2021, 10:04
Datenbank: Oracle • Version: 11g • Zugriff über: TCRSQLConnection
Hallo zusammen,

ich habe ein etwas merkwürdiges Phänomen, wo ich nicht weiterkomme. Ich möchte mir mit der TSQLMonitor-Komponente im SQL-Monitor die SQL-Statements anschaun. Leider funktioniert dies seit einiger Zeit nicht mehr. Nun habe ich mir ein anders Programm angeschaut, wo ich auch eine TSQLMonitor-Komponente eingebaut habe. Dort funktioniert es. Die Einstellungen sind nach meiner Betrachtung eigentlich alle gleich, dennoch funktioniert es nur in diesem Programm, indem anderen werden keine SQL-Statements im Monitor angezeigt. Hatte jemand schon mal so ein Phänomen und eine Ahnung, wo ich noch nachschauen kann, damit die SQL-Statements wieder an den SQL-Monitor übermittelt werden. Denn lauter showmessage-Abfragen einzubauen, ist auch keine Lösung. Danke.

viele Grüße
Horst
  Mit Zitat antworten Zitat
Delphi.Narium

Registriert seit: 27. Nov 2017
1.856 Beiträge
 
Delphi 7 Professional
 
#2

AW: TSQLMontor zeigt nichts an

  Alt 14. Sep 2021, 10:44
Gleiche Anmeldedaten für die Datenbank?

Wenn nein: Rechteproblem bei den entsprechenden Views?
  Mit Zitat antworten Zitat
horstmeyer

Registriert seit: 9. Aug 2021
16 Beiträge
 
#3

AW: TSQLMontor zeigt nichts an

  Alt 14. Sep 2021, 10:49
Danke für die Rückmeldung. Ja, es sind die gleichen Anmeldedaten. Das kann es also nicht sein. An den Rechten der Views kann es auch nicht liegen, denn die sind auch gesetzt. Es hat ja vor einiger Zeit auch noch funktioniert. Ich habe die Vermutung, dass ich beim Ändern des Programmes irgendetwas versehentlich verstellt habe, weiß aber nicht was...
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
7.993 Beiträge
 
Delphi XE4 Professional
 
#4

AW: TSQLMontor zeigt nichts an

  Alt 14. Sep 2021, 12:41
Hallo,
ich kenne jetzt deine Monitor-Komponente/ Programm nicht.
Aber beim DBMonitor (DevArt) musste man das im Programm explizit auch einschalten.
Heiko
  Mit Zitat antworten Zitat
horstmeyer

Registriert seit: 9. Aug 2021
16 Beiträge
 
#5

AW: TSQLMontor zeigt nichts an

  Alt 14. Sep 2021, 12:46
Hallo Heiko,

das macht Sinn. Aber wo habe ich es dann wohlmöglich versehentlich ausgeschaltet. Ich finde den Schalter in Optionen nicht...

Gruß
Horst
  Mit Zitat antworten Zitat
mkinzler
(Moderator)

Registriert seit: 9. Dez 2005
Ort: Heilbronn
39.798 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: TSQLMontor zeigt nichts an

  Alt 14. Sep 2021, 13:11
Eigenschaft Active
Markus Kinzler
  Mit Zitat antworten Zitat
horstmeyer

Registriert seit: 9. Aug 2021
16 Beiträge
 
#7

AW: TSQLMontor zeigt nichts an

  Alt 14. Sep 2021, 13:17
Hallo mkinzler,

die Eigenschaft Active von SQLMonitor ist auf true gesetzt. Das ist es also leider nicht. Wäre auch zu einfach

Gruß
Horst
  Mit Zitat antworten Zitat
Delphi.Narium

Registriert seit: 27. Nov 2017
1.856 Beiträge
 
Delphi 7 Professional
 
#8

AW: TSQLMontor zeigt nichts an

  Alt 14. Sep 2021, 13:24
Eventuell das?
Zitat von https://docwiki.embarcadero.com/Libraries/Sydney/de/Data.SqlExpr.TSQLMonitor:
Anmerkung: TSQLMonitor verwendet die Eigenschaft TraceCallbackEvent der SQL-Verbindungskomponente, deren Nachrichten sie protokolliert. Wenn Sie dieser Eigenschaft selbst einen Wert zuweisen, funktioniert die TSQLMonitor-Komponente nicht mehr.
oder ist da was dabei?

https://stackoverflow.com/questions/...uses-the-new-o

Geändert von Delphi.Narium (14. Sep 2021 um 13:28 Uhr)
  Mit Zitat antworten Zitat
horstmeyer

Registriert seit: 9. Aug 2021
16 Beiträge
 
#9

AW: TSQLMontor zeigt nichts an

  Alt 14. Sep 2021, 13:34
Hallo Delphi.Narium,

mmh? Die SQL-Componente TCRSQLConnection hat diese Eigenschaft nicht, daher kann ich dort auch nichts zuweisen. Und wenn ich nach TraceCallbackEvent suche, finde ich nichts im Quellcode. Also sollte nichts zugewiesen sein...

Gruß
Horst
  Mit Zitat antworten Zitat
Delphi.Narium

Registriert seit: 27. Nov 2017
1.856 Beiträge
 
Delphi 7 Professional
 
#10

AW: TSQLMontor zeigt nichts an

  Alt 14. Sep 2021, 13:49
Versehentlich was in den TraceFlags geändert?

Zitat von https://docwiki.embarcadero.com/Libraries/Sydney/de/Data.SqlExpr.TSQLMonitor.TraceList:
Nur Nachrichten, die den in der Eigenschaft TraceFlags festgelegten Kriterien entsprechen, werden zu TraceList hinzugefügt.
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 07:40 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf