AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

select mit ' läuft nicht

Ein Thema von Dr. Jack · begonnen am 8. Okt 2021 · letzter Beitrag vom 10. Okt 2021
Antwort Antwort
Seite 1 von 3  1 23   
Dr. Jack

Registriert seit: 17. Mär 2010
77 Beiträge
 
Delphi 10.2 Tokyo Architect
 
#1

select mit ' läuft nicht

  Alt 8. Okt 2021, 15:59
Datenbank: sqlite • Version: 3 • Zugriff über: firedac
Hallo zusammen,

mein Problem ist, dass ich mit einen Select direkt in der DB auch ein richtiges Ergebnis bekomme.

select * from fam_check where DATE(verfall, + '1 year') <= CURRENT_DATE AND (DATE(p_datum, + '5 years') <= CURRENT_DATE)

übertrage ich den Select in Delphi bekomme ich kein Ergebnis

Delphi-Quellcode:
  
       main.qryproducts.FetchOptions.AutoClose := False;
       main.qryproducts.SQL.Clear;
   
// erster Versuch so:
       main.qryproducts.SQL.Add('SELECT * ');
       main.qryproducts.SQL.Add('FROM fam_check ');
       main.qryproducts.SQL.Add('WHERE DATE(verfall, + '+ quotedstr('1 year')+ ' ) <= CURRENT_DATE' );
       main.qryproducts.SQL.Add('AND (DATE(p_datum, + ' + quotedstr('5 years') +') <= CURRENT_DATE) '   );

// zweite Versuch mit Parametern
       main.qryproducts.SQL.Add('SELECT * ');
       main.qryproducts.SQL.Add('FROM fam_check ') ;
       main.qryproducts.SQL.Add('WHERE DATE(verfall, + :jahr_begin ) <= CURRENT_DATE' );
       main.qryproducts.SQL.Add('AND (DATE(p_datum, + :jahr_end ) <= CURRENT_DATE) '   );

       main.qryproducts.ParamByName('jahr_begin').AsString := '1 year';
       main.qryproducts.ParamByName('jahr_end').AsString := '5 years';

       main.qryproducts.SQL.SaveToFile('S:\log.txt');

       main.qryproducts.Open;

        while not main.qryproducts.Eof do
          begin
          loeschfristen_apbetro_fam_insert_lv(main.qryproducts.FieldByName('ID').AsString,
          main.qryproducts.FieldByName('name').AsString,main.qryproducts.FieldByName('dafo_kurz').AsString);
          main.qryproducts.Next;
          end;
die Ausgabe im Logfile kann ich 1:1 in die DB kopieren und es geht. Woran ligt es? Hoffe ihr könnt mir helfen thx.
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
38.712 Beiträge
 
Delphi 10.4 Sydney
 
#2

AW: select mit ' läuft nicht

  Alt 8. Okt 2021, 16:18
Was ist am zweiten Versuch verkehrt,
bzw. warum verwendest du das nicht?


Stimmt die Syntax so überhaupt?
Ich bin mir fast sicher, dass das + in den String gehört, und nicht davor.
DATE(verfall, '+1 year')



QuotedStr ist ausschließlich für die Pascal-Syntax, also aus ' wird ''.
Du brauchst aber eine Quote/Escape-Funktion für die SQL-Syntax, welche also aus ' ein \' machen, sowie aus \ ein \\ usw.

Hier wird es damit zufällig "funktionieren", so lange keine ' oder \ im String vorkommen.

Fazit: Such in deiner DB-Komponente, bzw. in deren Units nach einer passenden Funktion.


Und ja, daß in vielen Beispielen, Tutorials usw. QuoteStr genommen wird, ist grauenhaft und es war schon immer falsch, aber immer wieder wird dieser Mist kopiert.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014

Geändert von himitsu ( 8. Okt 2021 um 16:31 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Sherlock
Sherlock

Registriert seit: 10. Jan 2006
Ort: Offenbach
3.555 Beiträge
 
Delphi 10.3 Rio
 
#3

AW: select mit ' läuft nicht

  Alt 8. Okt 2021, 16:20
Wie genau lautet denn die Fehlermeldung? Es fehlt ein kleines bisschen Exceptionhandling an der Stelle, die vielleicht Wunder wirken könnte. Oder zumindest Licht ins Dunkel bringen kann

Sherlock
Geändert von Sherlock (Morgen um 16:78 Uhr) Grund: Weil ich es kann
  Mit Zitat antworten Zitat
Dr. Jack

Registriert seit: 17. Mär 2010
77 Beiträge
 
Delphi 10.2 Tokyo Architect
 
#4

AW: select mit ' läuft nicht

  Alt 8. Okt 2021, 16:23
Wie genau lautet denn die Fehlermeldung? Es fehlt ein kleines bisschen Exceptionhandling an der Stelle, die vielleicht Wunder wirken könnte. Oder zumindest Licht ins Dunkel bringen kann

Sherlock
Es gibt tatsächlich keine Fehlermeldung, ich bekomme nur einfach keinen Daten. D.h., wenn ich nur select * from fam_check nehme geht alles. Es liegt offensichtlich an der where bedingung, genauer an den Hochkommata
  Mit Zitat antworten Zitat
Dr. Jack

Registriert seit: 17. Mär 2010
77 Beiträge
 
Delphi 10.2 Tokyo Architect
 
#5

AW: select mit ' läuft nicht

  Alt 8. Okt 2021, 16:29
Was ist am zweiten Versuch verkehrt,
bzw. warum verwendest du das nicht?



QuotedStr ist ausschließlich für die Pascal-Syntax, also aus ' wird ''.
Du brauchst aber eine Quote/Escape-Funktion für SQL, Strings, welche also aus ' ein \' machen, sowie aus \ ein \\ usw.

Fazit: Such in deiner DB-Komponente, bzw. in deren Units nach einer passenden Funktion.


Und ja, daß in vielen Tutorials QuoteStr genommen wird ist grauenhaft und es war schon immer falsch, aber immer wieder wird dieser Mist kopiert.
Der zweite Versuch liefert auch kein Ergebnis. select * from fam_check geht. Nur die Where-Bedingung scheint irgendwie fehlerhaft zu sein.

Habe mal Bilder angehängt. 01 liefert kein Ergebnis mit der vollen Query. 02 ist auf select * from fam_check reduziert
Miniaturansicht angehängter Grafiken
01.png   02.png  
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
38.712 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: select mit ' läuft nicht

  Alt 8. Okt 2021, 16:32
Siehe mein "Edit" da oben ... das bezüglich dem "+"
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
Dr. Jack

Registriert seit: 17. Mär 2010
77 Beiträge
 
Delphi 10.2 Tokyo Architect
 
#7

AW: select mit ' läuft nicht

  Alt 8. Okt 2021, 16:39
Siehe mein "Edit" da oben ... das bezüglich dem "+"
Was ist am zweiten Versuch verkehrt,
bzw. warum verwendest du das nicht?


Stimmt die Syntax so überhaupt?
Ich bin mir fast sicher, dass das + in den String gehört, und nicht davor.
DATE(verfall, '+1 year')
Geht beides, sehr lustig Aber Delphi ists immer noch egal... mist Hoffnungsschimmer....
  Mit Zitat antworten Zitat
Delphi.Narium

Registriert seit: 27. Nov 2017
1.909 Beiträge
 
Delphi 7 Professional
 
#8

AW: select mit ' läuft nicht

  Alt 8. Okt 2021, 16:45
Korrekte Syntax siehe: SQLite date Function
  Mit Zitat antworten Zitat
Dr. Jack

Registriert seit: 17. Mär 2010
77 Beiträge
 
Delphi 10.2 Tokyo Architect
 
#9

AW: select mit ' läuft nicht

  Alt 8. Okt 2021, 16:48
Daher habe ich das tatsächlich auch: SELECT DATE('2018-11-01','+1 year'); Ich habe es geändert, aber liefert immer noch kein Ergebnis.
  Mit Zitat antworten Zitat
Benutzerbild von Sherlock
Sherlock

Registriert seit: 10. Jan 2006
Ort: Offenbach
3.555 Beiträge
 
Delphi 10.3 Rio
 
#10

AW: select mit ' läuft nicht

  Alt 8. Okt 2021, 16:56
Der Unterschied ist aber immer noch da, oder hast Du den behoben?

SQL: SELECT DATE('2018-11-01','+1 year');
Delphi: SELECT DATE('2018-11-01', + '1 year');

Sherlock
Geändert von Sherlock (Morgen um 16:78 Uhr) Grund: Weil ich es kann
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 3  1 23   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 21:19 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf