AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

GlobalUseMetal Problem

Ein Thema von CHackbart · begonnen am 3. Dez 2021 · letzter Beitrag vom 3. Dez 2021
Antwort Antwort
CHackbart

Registriert seit: 22. Okt 2012
252 Beiträge
 
#1

GlobalUseMetal Problem

  Alt 3. Dez 2021, 13:02
Hi,

kann jemand folgendes Problem reproduzieren? Ein geschlossenes Formular, lässt sich unter MacOS nicht mehr öffnen, ohne dass die Darstellung nicht mehr geht.

Beispiel:

Ich erstelle eine Firemonkey Anwendung mit aktiviertem GlobalUseMetal. Die Anwendung besteht aus 2 Formularen. Das erste Formular hat einen Knopf der das 2te Formular öffnet.
Auf dem 2ten Formular befinden sich ein paar Firemonkeyelemente, wie weitere Knöpfe. Wenn ich das zweite Fenster jetzt schließe und erneut öffne, dann funktionieren die Elemente nicht mehr.

Christian
  Mit Zitat antworten Zitat
philipp.hofmann

Registriert seit: 21. Mär 2012
Ort: Hannover
656 Beiträge
 
Delphi 10.4 Sydney
 
#2

AW: GlobalUseMetal Problem

  Alt 3. Dez 2021, 14:48
Das Problem kann ich in meiner App nicht nachvollziehen. Da funktioniert dieses Vorgehen.
  Mit Zitat antworten Zitat
CHackbart

Registriert seit: 22. Okt 2012
252 Beiträge
 
#3

AW: GlobalUseMetal Problem

  Alt 3. Dez 2021, 15:51
Sicher, dass du GlobalUseMetal in der Projektdatei eingetragen hast?

Ich hab mal ein Beispielprojekt angehängt. Einfach auf den Button klicken, das zweite Fenster schließen und erneut auf den Button klicken.

Bei mir geht as auf keinem System, weder M1 noch X64.

Christian
Angehängte Dateien
Dateityp: zip example.zip (21,6 KB, 1x aufgerufen)
  Mit Zitat antworten Zitat
philipp.hofmann

Registriert seit: 21. Mär 2012
Ort: Hannover
656 Beiträge
 
Delphi 10.4 Sydney
 
#4

AW: GlobalUseMetal Problem

  Alt 3. Dez 2021, 16:47
Sorry, ich habe in meinen Code geschaut. Ich setze das zweite Formular auf visible:=false. Weiß jetzt nicht warum ich diesen Ansatz seinerzeit gewählt habe, aber dies klappt in meinem Fall.
Aber in deinem Beispiel reagiert es bei mir genau wie bei dir, d.h. geht nicht.
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
2.050 Beiträge
 
Delphi 10.3 Rio
 
#5

AW: GlobalUseMetal Problem

  Alt 3. Dez 2021, 17:54
Bitte ggf. in QP einen Report erstellen und Nummer hier posten.
  Mit Zitat antworten Zitat
CHackbart

Registriert seit: 22. Okt 2012
252 Beiträge
 
#6

AW: GlobalUseMetal Problem

  Alt 3. Dez 2021, 20:07
Gerne:
https://quality.embarcadero.com/browse/RSP-36446
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 21:01 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf