AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Sprachen und Entwicklungsumgebungen Object-Pascal / Delphi-Language Delphi Anwendung in RemoteDesktop (RDP) sehr langsamer Aufbau

Anwendung in RemoteDesktop (RDP) sehr langsamer Aufbau

Ein Thema von Eppos · begonnen am 21. Sep 2022 · letzter Beitrag vom 28. Sep 2022
Antwort Antwort
Seite 2 von 4     12 34   
Rolf Frei

Registriert seit: 19. Jun 2006
553 Beiträge
 
Delphi 11 Alexandria
 
#11

AW: Anwendung in RemoteDesktop (RDP) sehr langsamer Aufbau

  Alt 21. Sep 2022, 13:38
Das ist hier doch alles Symptombekämpfung. Die Frage ist, was bei der XE5 App anders ist, als in der D11 App. Nutzt du Styles? Hat die XE5 Version keine Styles aktiviert und nutz damit das nativen Windowpainting der Controls? Ist in de D11 App ein unbeabsichtigtes Style aktiv, das nun zu massivem Painting der Oberfläche führt. Ist in D11 die Option "Enable Runtime Themes" aktiviert und bei XE5 nicht?
  Mit Zitat antworten Zitat
Eppos

Registriert seit: 7. Aug 2006
Ort: Heilbronn
518 Beiträge
 
Delphi 11 Alexandria
 
#12

AW: Anwendung in RemoteDesktop (RDP) sehr langsamer Aufbau

  Alt 21. Sep 2022, 14:44
Alles steht auf DoubleBufferes.
Ich nutze Styles von TMS.
Laufzeit-Themes sind aktiviert.
DPI-Unterstützung steht auf keiner.
Ausfürhungseben auf Als Aufrufer.
  Mit Zitat antworten Zitat
Rolf Frei

Registriert seit: 19. Jun 2006
553 Beiträge
 
Delphi 11 Alexandria
 
#13

AW: Anwendung in RemoteDesktop (RDP) sehr langsamer Aufbau

  Alt 21. Sep 2022, 15:04
Dann deaktiviere doch mal die Runtime Themes und schau, ob das was verändert.
  Mit Zitat antworten Zitat
Eppos

Registriert seit: 7. Aug 2006
Ort: Heilbronn
518 Beiträge
 
Delphi 11 Alexandria
 
#14

AW: Anwendung in RemoteDesktop (RDP) sehr langsamer Aufbau

  Alt 21. Sep 2022, 15:28
Die Laufzeit Themes waren es, ich konnte es aber nicht deaktivieren. Nach dem speichern war der Haken immer wieder drin.

Jetzt sieht natürlich die Anwednung total furchtbar aus, mich interessiert eher, warum man hier einen Rückschrit gemacht hat.
  Mit Zitat antworten Zitat
Eppos

Registriert seit: 7. Aug 2006
Ort: Heilbronn
518 Beiträge
 
Delphi 11 Alexandria
 
#15

AW: Anwendung in RemoteDesktop (RDP) sehr langsamer Aufbau

  Alt 21. Sep 2022, 15:40
Wenn ich das deaktiviere, spinnt alles. Es werden sogar Eigenschaften aus den DFMs komplett entfernt.
Beispiel: DropDownCount = 20
  Mit Zitat antworten Zitat
Rolf Frei

Registriert seit: 19. Jun 2006
553 Beiträge
 
Delphi 11 Alexandria
 
#16

AW: Anwendung in RemoteDesktop (RDP) sehr langsamer Aufbau

  Alt 21. Sep 2022, 19:12
Die Einstellung "Enable Runtime Themes" unter Applikation/Manifest solltet du eingeschalten lassen, sonst spinnt da so einiges, weil die IDE mit aktivierten Themes läuft und dann bestimmte Sachen nicht mehr richtig geladen/gespeichert werden (DFM -> z.b. Imagelisten). Sorry, das ist garnicht die Einstellung, die ich gemeint habe. Ich meinte, ob die Delphi Styles aktiviert sind oder nicht. Das ist unter Application/Appearance zu finden. Da solltest du den Dafault Style auf "Windows" stehen haben. Damit wird der Windows Theme Support verwednet und nicht der Delphi Style Support, der eventuell für dein Verhalten zuständig ist. Wenn du da unter Customstyles nichts ausgewählt hast, sollte der Delphi Style nicht zum Einsatz kommen.

Sorry, dass ich dich hier fehlgeleitet habe. Unter Manifest muss "Enable Runtime Themes" auf jeden Fall aktiv sein.

Das Problem könnte aber schon irgendwas mit der automatisch erzeugten Manifest Datei zu tun haben. Gibt da glaube ich auch Einträge für Remotedesktop.

Versuch auch mal folgende Zeile im DPR direkt nach den Uses einzufügen:
Delphi-Quellcode:
uses
  Controls,
  Classes,
  Forms,
  Windows, // dieses wird unbedingt benötigt, damit IMAGE_DLLCHARACTERISTICS_TERMINAL_SERVER_AWARE erkannt wird.
  ...;

{$SetPEOptFlags IMAGE_DLLCHARACTERISTICS_TERMINAL_SERVER_AWARE}

Ich habe hier mit Remote Desktop und D11 kompilierten Programmen keine Probleme, daher vermute ich, dass das bei dir nicht direkt was mit D11 zu tun hat, sondern eventuell am einem Eintrag der Manifesstdatei liegt, die eventuell hier anders ist als be XE5.

Geändert von Rolf Frei (21. Sep 2022 um 19:14 Uhr)
  Mit Zitat antworten Zitat
Eppos

Registriert seit: 7. Aug 2006
Ort: Heilbronn
518 Beiträge
 
Delphi 11 Alexandria
 
#17

AW: Anwendung in RemoteDesktop (RDP) sehr langsamer Aufbau

  Alt 21. Sep 2022, 19:57
hat leider kein Unterscheid gebracht.

Styles verwende ich keine.
  Mit Zitat antworten Zitat
Rolf Frei

Registriert seit: 19. Jun 2006
553 Beiträge
 
Delphi 11 Alexandria
 
#18

AW: Anwendung in RemoteDesktop (RDP) sehr langsamer Aufbau

  Alt 22. Sep 2022, 13:33
Das ist alles sehr komisch. Wie gesagt läuft mein Prorgamm unter RDP ohne Probleme und ich habe da echt keine Idee mehr, was da noch dein Problem sein könnte. Hast du ein eigenes Manifestfile, das du in dein Programm linkst oder verwendest du das von der IDE zur Verfügung gestelte? Hast du das Problem auch mit einer neuen Anwendung?
  Mit Zitat antworten Zitat
Eppos

Registriert seit: 7. Aug 2006
Ort: Heilbronn
518 Beiträge
 
Delphi 11 Alexandria
 
#19

AW: Anwendung in RemoteDesktop (RDP) sehr langsamer Aufbau

  Alt 22. Sep 2022, 15:16
Ich verwende das von IDE.

Ich habe ein komplett neues Programm erstellt und eine Maske dort hineinkopiert - ohne Code. Gleiches Problem.
Vermutlich werde ich ein Supportticket bei Emba aufmachen.
  Mit Zitat antworten Zitat
Rolf Frei

Registriert seit: 19. Jun 2006
553 Beiträge
 
Delphi 11 Alexandria
 
#20

AW: Anwendung in RemoteDesktop (RDP) sehr langsamer Aufbau

  Alt 22. Sep 2022, 15:32
Darf ich noch fragen was für Komponenten du da in deiner Testanwendung drin hast? Ist da evenutell eine 3rd Party Komponente dafür verantwortlich, die unter D11 irgendwas anders macht? Lösch dir doch dann einfach mal Komponente für Komponente raus und teste jeweils, ob sich was verändert hat. Ist das eigentlich eine FMX oder VCL Anwendung? Meine ist eine VCL Anwendung.

Läuft eventuell noch der Firefox parallel im Remode Desktop? Wenn ja, beenden den mal. Der mach bei mir nämlich manchmal auch Probleme, wenn der zu lange läuft oder zu viele Tabs offen hat. Dann werden die Fenster von neu geöffneten Anwendung (beliebige nicht D11 bezogene) auch x-Mal neu gepaintet und alles verlangsamt, bis die Anwenungd richtig geladen ist. Danach ist aber wieder gut. Wenn ich dann den FF beende, ist wieder alles gut und die Anwendungen werden wieder normal geladen, bis das Probmlen dann irgendwann wieder anfängt. Vermutlich hat das aber nichts mit deinem Problem zu tun.

Geändert von Rolf Frei (22. Sep 2022 um 15:41 Uhr)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 02:15 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf