AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Delphi-PRAXiS - Lounge Betriebssysteme VM findet Computernamen nicht mehr

VM findet Computernamen nicht mehr

Ein Thema von TurboMagic · begonnen am 12. Mai 2024 · letzter Beitrag vom 15. Mai 2024
Antwort Antwort
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
2.856 Beiträge
 
Delphi 12 Athens
 
#1

VM findet Computernamen nicht mehr

  Alt 12. Mai 2024, 10:51
Hallo,

eine VM Ware Player VM auf dem Laptop (Host Windows 11, Guest Windows 10) findet seit heute
meinen anderen PC im Netzwerk nicht mehr per Namen. Per IP Adresse schon, aber ich brauche
auch die Namensauflösung.

Woran kann es liegen?
Habe der Netzwerkverbindung schon NetBIOS als generell aktiv eingestellt.
Hosts und lmhosts Dateien sind leer.
In der Netzwerkumgebug des Explorers werden der Host und die VM angezeigt, der gesuchte PC aber nicht.

Ping auf IP Adresse geht auf Namen nicht.
Im VM Ware Player ist NAT eingestellt.
Auf dem betreffendne PC läuft auch VM Ware Workstation, da ist auch Nat eingestellung und der Name
wird gefunden (ok, es ist der vom eigenen PC).
Grüße
TurboMagic
  Mit Zitat antworten Zitat
Christian Seehase
(Co-Admin)

Registriert seit: 29. Mai 2002
Ort: Hamburg
11.107 Beiträge
 
Delphi 11 Alexandria
 
#2

AW: VM findet Computernamen nicht mehr

  Alt 13. Mai 2024, 06:13
Moin,

Als erstes kannst Du mal den DNS-Cache zurücksetzen.
(ipconfig /flushdns in einer cmd ausführen).
Danach dann:
Wird denn etwas zurückgegeben, wenn Du von der VM aus den Rechner per Namen anpungst?
Falls keine Adresse zurückgegeben wird, kommt nichts vom DNS.
Dann wird entweder der falsche genommen oder ist enthält den Eintrag nicht mehr.
Falls eine Adresse zurückgegeben wird, die aber nicht stimmt, hat sich der Eintrag im DNS geändert
Ganz zur Not kannst Du ja auch den Rechner in der hosts eintragen.
Tschüss Chris
Die drei Feinde des Programmierers: Sonne, Frischluft und dieses unerträgliche Gebrüll der Vögel.
Der Klügere gibt solange nach bis er der Dumme ist
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
9.370 Beiträge
 
Delphi 11 Alexandria
 
#3

AW: VM findet Computernamen nicht mehr

  Alt 13. Mai 2024, 08:35
Welche DNS-Server werden denn genutzt?
Das siehst du in den Windows Einstellungen unter Netzwerk und Internet, wenn du oben in der Mitte auf Eigenschaften klickst.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Hobbycoder

Registriert seit: 22. Feb 2017
933 Beiträge
 
#4

AW: VM findet Computernamen nicht mehr

  Alt 13. Mai 2024, 09:42
Sowas lässt ggf. auch ganz gut über die Eingabeaufforderung testen:

1. genutzte DNS-Server -> ipconfig /all
Dort werden dann alle Netzwerkinterfaces mit ihren IP-Einstellungen aufgelistet.

2. dnslookup
Dort dann mit "set debug" in den Debugmodus gehen und danach einfach den Zielrechnernamen eingeben.
Dort erkennst du dann welcher DNS die Namensauflösung durchführt und was er zurückliefert, oder eben nicht.

Auch mal ruhig alle Firewalls/Virenscanner abschalten. Die machen gerne mal ein bisschen Probleme.
Gruß Hobbycoder
Alle sagten: "Das geht nicht.". Dann kam einer, der wusste das nicht, und hat's einfach gemacht.
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
2.856 Beiträge
 
Delphi 12 Athens
 
#5

AW: VM findet Computernamen nicht mehr

  Alt 14. Mai 2024, 07:06
Danke für die Antworten. Werde ich alles testen.
DNS Server ist die heimische Fritzbox.

NSLookup hatte ich schon probiert, aber nicht set debug.
Das hatte auch nur irgendwas ala "Name kenne ich nicht" zurückgeliefert.
Grüße
TurboMagic
  Mit Zitat antworten Zitat
johndoe049

Registriert seit: 22. Okt 2006
140 Beiträge
 
#6

AW: VM findet Computernamen nicht mehr

  Alt 14. Mai 2024, 07:57
Hallo,

eine VM Ware Player VM auf dem Laptop (Host Windows 11, Guest Windows 10) findet seit heute
meinen anderen PC im Netzwerk nicht mehr per Namen. Per IP Adresse schon, aber ich brauche
auch die Namensauflösung.

Woran kann es liegen?
Habe der Netzwerkverbindung schon NetBIOS als generell aktiv eingestellt.
Hosts und lmhosts Dateien sind leer.
In der Netzwerkumgebug des Explorers werden der Host und die VM angezeigt, der gesuchte PC aber nicht.

Ping auf IP Adresse geht auf Namen nicht.
Im VM Ware Player ist NAT eingestellt.
Auf dem betreffendne PC läuft auch VM Ware Workstation, da ist auch Nat eingestellung und der Name
wird gefunden (ok, es ist der vom eigenen PC).
Geh mal auf den Host. Wieviel Netzwerkkarten werden angezeigt? VMWare erstellt noch eigene, die für NAT und Host Only notwendig sind. Wenn mehr im VMWare konfiguriert ist, gibt es auch mehr Netzwerkkarten. Die NET Nummer gibt die Konfiguration in VMWare an. Die kann man im Player und der Workstation sehen und anpassen.

Schon auf die 17.5.1 aktualisiert? Da gab es ein Problem mit der Zuordnung. In der Netzwerkkonfiguration vom Player/Workstation alle konfigurierten Netzwerkadapter öffen, irgendwas ändern und speichern, damit die Konfiguration und Zuordnung neu erstellt wird.

Mach aus der VM einen Ping ohne Anzahleinschränkung und seh dir an, welcher Netzwerkadapter Traffic hat. Ggf. die Netzwerkkonfiguation der VM anpassen.

Kann sein, dass in der Konfiguration NAT steht, die .vmx jedoch auf Host Only eingestellt ist. Einfach den Netzwerkadapter 2x ändern. Dann sollte es auch in der .vmx eingetragen sein.
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
2.856 Beiträge
 
Delphi 12 Athens
 
#7

AW: VM findet Computernamen nicht mehr

  Alt 14. Mai 2024, 20:28
Moin,

Als erstes kannst Du mal den DNS-Cache zurücksetzen.
(ipconfig /flushdns in einer cmd ausführen).
Danach dann:
Wird denn etwas zurückgegeben, wenn Du von der VM aus den Rechner per Namen anpungst?
Falls keine Adresse zurückgegeben wird, kommt nichts vom DNS.
Dann wird entweder der falsche genommen oder ist enthält den Eintrag nicht mehr.
Falls eine Adresse zurückgegeben wird, die aber nicht stimmt, hat sich der Eintrag im DNS geändert
Ganz zur Not kannst Du ja auch den Rechner in der hosts eintragen.
Hallo,

1. DNS Cache Löschen hat leider nix gebracht

2. Da sich die IP V4 Adresse ja anpingen lies, hab' ich wie vorgeschlagen den Rechner mal
in die Hosts Datei eingetragen. Das funktioniert.

3. Nur: eine gute Lösung ist es nicht, da der andere PC derzeit auf DHCP eingestellt ist
(ja kann geändert werden). Ich wüsste hat immer noch gerne warum "das normale Verfahren"
hier nicht klappt.
Grüße
TurboMagic
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
2.856 Beiträge
 
Delphi 12 Athens
 
#8

AW: VM findet Computernamen nicht mehr

  Alt 14. Mai 2024, 20:36
Hallo,

ja, habe 17.5.1.
Habe es jetzt aber anders gelöst:
Habe auf bridged statt NAT umgestellt und die Änderung der Hosts
Datei rückgängig gemacht.

ipconfig /all zeigt jetzt auch die IP-Adresse der Fritzbox als DNS Server an,
ohne, dass ich die manuell in den Netzwerkeinstellungen von Windows eintragen
muss.
Grüße
TurboMagic
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
43.202 Beiträge
 
Delphi 12 Athens
 
#9

AW: VM findet Computernamen nicht mehr

  Alt 14. Mai 2024, 23:43
In der VM in die hosts-Datei den Namen+IP eintragen.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
my Delphi wish list : BugReports/FeatureRequests
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
2.856 Beiträge
 
Delphi 12 Athens
 
#10

AW: VM findet Computernamen nicht mehr

  Alt 15. Mai 2024, 17:39
In der VM in die hosts-Datei den Namen+IP eintragen.
Ähm, das hatte ich doch weiter oben geschrieben gehabt dass ich das getestet hatte
und das wie erwartet funktioniert hatte. Nur ist's keine tolle Lösung, v.a. auch
weil der andere PC auf DHCP steht.

=> die Lösung auf Bridged statt NAT umzustellen funktioniert und ist für mich ok.
Grüße
TurboMagic
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 13:24 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz