AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi MDAC 2.8 lässt sich nicht installieren

MDAC 2.8 lässt sich nicht installieren

Ein Thema von Generalissimo · begonnen am 22. Okt 2004 · letzter Beitrag vom 22. Okt 2004
Antwort Antwort
Generalissimo

Registriert seit: 28. Aug 2003
187 Beiträge
 
Delphi 6 Enterprise
 
#1

MDAC 2.8 lässt sich nicht installieren

  Alt 22. Okt 2004, 14:42
Hi,

Ich wollte mir mal aus dem VB.NET Resource Kit die Samples zu den Komponenten von Compenent One anschauen.
Speziell die DB-Kompos.
Beim starten der Demo-Anwendung bekomm ich folgenden Fehler:

"Der .Net Data OLE DB Provider (System.Data.OleDb) erfordert mindestens Microsoft Data Access-Komponenten (MDAC) Version 2.6. Version 02.10.3711.9 ist installiert."

Da ich mir dachte das 2.1 bissl zu niedrig ist, wollte ich bei mir MDAC 2.8 installieren.

Bei der Installation kommt folgender Fehler:

"MDAC 2.8 RTM ist mit dieser Version von Windows nicht kompatibel. Alle Funktionen sind zurzeit Teil von Windows."

Kann mir das jemand erklären?

PS: mein Betriebssystem ist Win XP mit SP2
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
17.177 Beiträge
 
Delphi 10.4 Sydney
 
#2

Re: MDAC 2.8 lässt sich nicht installieren

  Alt 22. Okt 2004, 15:14
Wenn Du XP hast, so solltest Du schon mindestens MDAC 2.6 (oder wars 2.7) haben.

Jetzt könnte natürlich folgendes passiert sein:
- Irgendein Installer hat Mist gebaut und dir dein MDAC zerschossen (wenn Du Pech hast heißt es Rechner neu installieren)
- Component one ist nicht fähig die MDAC-Version korrekt zu bestimmen (Also Component One wegschmeißen).

Überprüf mal die MDAC-Version mit dem MDAC-Checker

Mit .NET sollte ja sowas (evtl. vorhandene DLL-Hölle) nicht mehr möglich sein - Aber zwischen Wunsch und Wirklichkeit liegen Welten.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
clues1

Registriert seit: 11. Feb 2004
97 Beiträge
 
#3

Re: MDAC 2.8 lässt sich nicht installieren

  Alt 22. Okt 2004, 21:44
Wenn du Windows XP installierst, wird MDAC 2.7 mitgeliefert.
Sobald du aber SP2 installierst hast du sogar 2.8 mit drin.
SP2 wird mit 2.8 ausgeliefert.
PS: MDAC 2.1 ist in Win98
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 04:27 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz