AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi BDE Datenbank "verliert" ersten Datensatz

BDE Datenbank "verliert" ersten Datensatz

Ein Thema von Luckie · begonnen am 20. Jul 2002 · letzter Beitrag vom 25. Jul 2002
Antwort Antwort
Benutzerbild von Luckie
Luckie
(Moderator)

Registriert seit: 29. Mai 2002
37.621 Beiträge
 
Delphi 2006 Professional
 
#1

BDE Datenbank "verliert" ersten Datensatz

  Alt 20. Jul 2002, 03:50
Hallo,
ich habe mal wieder ein Datenbank-Problem.

Und zwar verliert einen Datenbank ab und zu mal den ersten Datensatz beim öffnen. In 9 von 10 Fällen ist alles in Ordnung, aber beim 10. Öffnen fehlt dann mal der erste Datensatz.

Zur Zeit befinden sich 1200 Datensätze in der Datenbank. Betriebssystem ist Windows XP.

Ich bin da so ziemlich ratlos, da das Problem sporadisch auftritt.
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Benutzerbild von MrSpock
MrSpock
(Co-Admin)

Registriert seit: 7. Jun 2002
Ort: Owingen
6.015 Beiträge
 
Delphi 2010 Professional
 
#2
  Alt 20. Jul 2002, 09:42
Hallo Luckie,

obwohl ich schon relativ lange mit Paradox und der BDE arbeite (zwar noch nie unter XP) habe ich sowas noch nie gesehen.

Aber mal ein zwei Fragen:

1. Mit welcher Datenbank arbeitest du?
2. Wie macht sich der Verlust bemerkbar?
Albert
Live long and prosper


MrSpock
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)

Registriert seit: 29. Mai 2002
37.621 Beiträge
 
Delphi 2006 Professional
 
#3
  Alt 20. Jul 2002, 11:39
Zitat von MrSpock:
1. Mit welcher Datenbank arbeitest du?
Paradox
Zitat:
2. Wie macht sich der Verlust bemerkbar?
Er ist halt weg.
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Nils

Registriert seit: 8. Jun 2002
24 Beiträge
 
#4
  Alt 20. Jul 2002, 17:10
WEG? Der kann doch nicht einfach weg sein...

Mal so ne Frage:
Du sagst beim Öffnen wird der gelöscht. Ist das sicher oder kann das auch beim Schließen sein? Könntest du mal den Code posten, mit denm du das alles machst?

Aber so ein Datensatz kann doch nicht einfach verschwinden...
Irren ist menschlich - um die Sache wirklich ekelhaft zu machen, braucht man schon einen Computer
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)

Registriert seit: 29. Mai 2002
37.621 Beiträge
 
Delphi 2006 Professional
 
#5
  Alt 22. Jul 2002, 23:59
Na ja, ich füge die Datensätze ganz normal hinzu. Und es geht ja auch, nur halt den ersten verlierrt er ab und zu mal. Es tritt ja auch anscheinend nicht regelmäßig auf, das ist ja das Problem, es läßt sich keine Regelmäßigkeit erkennen. In 95% der Fälle klappt ja alles. Ich kann auch nicht sagen, ob er in beim Speichern nicht speichert oder ob er ihn beim Anzeigen verliert. Alles was ich habe ist die Aussage des Benutzers.
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Benutzerbild von MrSpock
MrSpock
(Co-Admin)

Registriert seit: 7. Jun 2002
Ort: Owingen
6.015 Beiträge
 
Delphi 2010 Professional
 
#6
  Alt 25. Jul 2002, 20:38
Hallo Luckie,

Zitat:
Alles was ich habe ist die Aussage des Benutzers.
Tja, ich mag am liebsten die Benutzer die anfangen mit: "Also ich habe nichts gemacht und dann ganz plötzlich..."

Ich habe einen solchen Effekt, dass ein Satz einfach verloren geht noch nicht erlebt. Natürlich ist es möglich, wenn eine Aktion verhindert, dass ein Post ausgeführt wird, dass ein Satz nicht gespeichert wird. Aber ein gespeicherter Satz geht nicht einfach verloren. Versuch doch noch einmal etwas genauere Aussagen von dem Benutzer zu bekommen.
Albert
Live long and prosper


MrSpock
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 15:58 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf